summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-01-02 07:05:34 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-01-02 07:05:34 +0000
commit7d85a7f075ce93698de1fb77277108aec781064b (patch)
treef83c8a6b97ae9be33d29759c6e730ef70e589a3a /app-crypt/gpg-agent
parentUnstable ppc-macos. (Manifest recommit) (diff)
downloadgentoo-2-7d85a7f075ce93698de1fb77277108aec781064b.tar.gz
gentoo-2-7d85a7f075ce93698de1fb77277108aec781064b.tar.bz2
gentoo-2-7d85a7f075ce93698de1fb77277108aec781064b.zip
Initial version from bug #70811
Diffstat (limited to 'app-crypt/gpg-agent')
-rw-r--r--app-crypt/gpg-agent/ChangeLog11
-rw-r--r--app-crypt/gpg-agent/Manifest4
-rw-r--r--app-crypt/gpg-agent/files/digest-gpg-agent-1.9.141
-rw-r--r--app-crypt/gpg-agent/gpg-agent-1.9.14.ebuild82
-rw-r--r--app-crypt/gpg-agent/metadata.xml20
5 files changed, 118 insertions, 0 deletions
diff --git a/app-crypt/gpg-agent/ChangeLog b/app-crypt/gpg-agent/ChangeLog
new file mode 100644
index 000000000000..2c42b7d7085f
--- /dev/null
+++ b/app-crypt/gpg-agent/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-crypt/gpg-agent
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpg-agent/ChangeLog,v 1.1 2005/01/02 07:05:34 dragonheart Exp $
+
+*gpg-agent-1.9.14 (02 Jan 2005)
+
+ 02 Jan 2005; Daniel Black <dragonheart@gentoo.org> +metadata.xml,
+ +gpg-agent-1.9.14.ebuild:
+ Initial version from bug #70811. Ebuild initially by Diego Pettenò
+ <dgp85@users.sourceforge.net>
+
diff --git a/app-crypt/gpg-agent/Manifest b/app-crypt/gpg-agent/Manifest
new file mode 100644
index 000000000000..13a6173da4ff
--- /dev/null
+++ b/app-crypt/gpg-agent/Manifest
@@ -0,0 +1,4 @@
+MD5 bd3111a23e723478b92508214cafcef3 gpg-agent-1.9.14.ebuild 1956
+MD5 d41d8cd98f00b204e9800998ecf8427e ChangeLog 0
+MD5 b1a4c3f100342f9335a6974737f5e5ec metadata.xml 872
+MD5 337c9671ff169f922ba7d007a3ceaae6 files/digest-gpg-agent-1.9.14 66
diff --git a/app-crypt/gpg-agent/files/digest-gpg-agent-1.9.14 b/app-crypt/gpg-agent/files/digest-gpg-agent-1.9.14
new file mode 100644
index 000000000000..3b16262cdbf9
--- /dev/null
+++ b/app-crypt/gpg-agent/files/digest-gpg-agent-1.9.14
@@ -0,0 +1 @@
+MD5 fd121b7d368cf27928bfa4ef4e4cc982 gnupg-1.9.14.tar.bz2 1631267
diff --git a/app-crypt/gpg-agent/gpg-agent-1.9.14.ebuild b/app-crypt/gpg-agent/gpg-agent-1.9.14.ebuild
new file mode 100644
index 000000000000..7286572a60ce
--- /dev/null
+++ b/app-crypt/gpg-agent/gpg-agent-1.9.14.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpg-agent/gpg-agent-1.9.14.ebuild,v 1.1 2005/01/02 07:05:34 dragonheart Exp $
+
+inherit eutils flag-o-matic
+
+# gpg-agent is took from gnupg package.
+GPG_P=gnupg-${PV}
+S=${WORKDIR}/${GPG_P}
+
+DESCRIPTION="The GNU Privacy Guard Agent"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/alpha/gnupg/${GPG_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86"
+# ~arm ~ia64 ~mips ~s390 ~sparce missing until libassuan gets the keywords
+
+IUSE="nls caps"
+
+RDEPEND="<app-crypt/gnupg-1.9
+ nls? ( sys-devel/gettext )
+ virtual/libc
+ >=dev-libs/libassuan-0.6.9
+ caps? ( sys-libs/libcap )
+ >=dev-libs/libgpg-error-0.7
+ >=dev-libs/libgcrypt-1.1.94"
+
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ sys-apps/sed"
+
+src_unpack() {
+ unpack ${A}
+ sed -e 's:GNUPG_LIBEXECDIR:"/usr/lib/gnupg":' -i ${S}/g10/keyserver.c
+}
+
+src_compile() {
+
+ append-ldflags -Wl,-z,now
+ econf \
+ --libexecdir=/usr/lib \
+ --enable-agent-only \
+ `use_with caps capabilities` \
+ || die
+
+ emake || die
+}
+
+src_test() {
+ einfo "self test is broken"
+}
+
+src_install() {
+ cd ${S}
+ emake DESTDIR=${D} libexecdir="/usr/lib/gnupg" install || die
+
+ # keep the documentation in /usr/share/doc/...
+ rm -rf "${D}/usr/share/gnupg/FAQ" "${D}/usr/share/gnupg/faq.html"
+
+ dodoc README
+
+ if ! use caps ; then
+ fperms u+s /usr/bin/gpg-agent
+ fi
+}
+
+pkg_postinst() {
+
+ ewarn "** WARNING ** WARNING ** WARNING ** WARNING ** WARNING ** WARNING **"
+ ewarn " THIS IS _ALPHA_ CODE, IT MAY NOT WORK CORRECTLY OR AT ALL. THERE"
+ ewarn " MAY BE UNDISCOVERED SECURITY OR DATA-LOSS ISSUES, DO NOT USE "
+ ewarn " IN A PRODUCTION ENVIRONMENT."
+
+ if ! use caps; then
+ einfo "gpg is installed suid root to make use of protected memory space"
+ einfo "This is needed in order to have a secure place to store your"
+ einfo "passphrases, etc. at runtime but may make some sysadmins nervous."
+ fi
+ echo
+}
diff --git a/app-crypt/gpg-agent/metadata.xml b/app-crypt/gpg-agent/metadata.xml
new file mode 100644
index 000000000000..479005f01d7d
--- /dev/null
+++ b/app-crypt/gpg-agent/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>crypto</herd>
+<maintainer>
+ <email>crypto@gentoo.org</email>
+ <name>Crypto Herd</name>
+</maintainer>
+<longdescription>
+In an ideal world, Assuan is irrelevant. Assuan's primary use is to
+allow a client to interact with a non-persistent server. Using Assuan,
+this is accomplished by forking a subprocess and communicating with it
+via, for example, a pipe or unix domain socket. This method is neither
+elegant nor efficient especially when there is a lot of data spread
+across several transactions: not only is there a penalty for an
+increased number of context switches, but also a significant amount of
+data is MEMCPYed from the client to a file descriptor and from the file
+descriptor to the server.
+</longdescription>
+</pkgmetadata>