summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2013-07-19 13:04:28 +0000
committerEray Aslan <eras@gentoo.org>2013-07-19 13:04:28 +0000
commit6a30441fe1f3b5642e548966ecc89630853e6102 (patch)
tree56c9f21107d05bfaf4b55bc4ec66a4924cd08542 /app-crypt/heimdal
parentVersion bump (bug #477366 by teidakankan). (diff)
downloadgentoo-2-6a30441fe1f3b5642e548966ecc89630853e6102.tar.gz
gentoo-2-6a30441fe1f3b5642e548966ecc89630853e6102.tar.bz2
gentoo-2-6a30441fe1f3b5642e548966ecc89630853e6102.zip
Add support for db-6 thanks to Lars Wendler bug #476362
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 0x77F1F175586A3B1F)
Diffstat (limited to 'app-crypt/heimdal')
-rw-r--r--app-crypt/heimdal/ChangeLog8
-rw-r--r--app-crypt/heimdal/files/heimdal_db6.patch41
-rw-r--r--app-crypt/heimdal/heimdal-1.5.3-r1.ebuild135
3 files changed, 183 insertions, 1 deletions
diff --git a/app-crypt/heimdal/ChangeLog b/app-crypt/heimdal/ChangeLog
index 74823643cb46..290bffbfc103 100644
--- a/app-crypt/heimdal/ChangeLog
+++ b/app-crypt/heimdal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/heimdal
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/ChangeLog,v 1.213 2013/06/27 20:40:29 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/ChangeLog,v 1.214 2013/07/19 13:04:28 eras Exp $
+
+*heimdal-1.5.3-r1 (19 Jul 2013)
+
+ 19 Jul 2013; Eray Aslan <eras@gentoo.org> +files/heimdal_db6.patch,
+ +heimdal-1.5.3-r1.ebuild:
+ Add support for db-6 thanks to Lars Wendler bug #476362
27 Jun 2013; Alexis Ballier <aballier@gentoo.org> heimdal-1.5.3.ebuild:
keyword ~amd64-fbsd
diff --git a/app-crypt/heimdal/files/heimdal_db6.patch b/app-crypt/heimdal/files/heimdal_db6.patch
new file mode 100644
index 000000000000..316cf1533791
--- /dev/null
+++ b/app-crypt/heimdal/files/heimdal_db6.patch
@@ -0,0 +1,41 @@
+--- a/cf/db.m4
++++ b/cf/db.m4
+@@ -51,6 +51,8 @@ dnl db_create is used by db3 and db4 and db5
+ #include <stdio.h>
+ #ifdef HAVE_DBHEADER
+ #include <$dbheader/db.h>
++ #elif HAVE_DB6_DB_H
++ #include <db6/db.h>
+ #elif HAVE_DB5_DB_H
+ #include <db5/db.h>
+ #elif HAVE_DB4_DB_H
+--- a/lib/hdb/db3.c
++++ b/lib/hdb/db3.c
+@@ -276,7 +276,7 @@
+ }
+ db->hdb_db = d;
+
+-#if (DB_VERSION_MAJOR >= 4) && (DB_VERSION_MINOR >= 1)
++#if (DB_VERSION_MAJOR > 4) || ((DB_VERSION_MAJOR == 4) && (DB_VERSION_MINOR >= 1))
+ ret = (*d->open)(db->hdb_db, NULL, fn, NULL, DB_BTREE, myflags, mode);
+ #else
+ ret = (*d->open)(db->hdb_db, fn, NULL, DB_BTREE, myflags, mode);
+@@ -284,7 +284,7 @@
+
+ if (ret == ENOENT) {
+ /* try to open without .db extension */
+-#if (DB_VERSION_MAJOR >= 4) && (DB_VERSION_MINOR >= 1)
++#if (DB_VERSION_MAJOR > 4) || ((DB_VERSION_MAJOR == 4) && (DB_VERSION_MINOR >= 1))
+ ret = (*d->open)(db->hdb_db, NULL, db->hdb_name, NULL, DB_BTREE,
+ myflags, mode);
+ #else
+--- a/cf/db.m4
++++ b/cf/db.m4
+@@ -38,6 +38,7 @@ AS_IF([test "x$with_berkeley_db" != xno],
+ fi
+ ])],
+ [AC_CHECK_HEADERS([ \
++ db6/db.h \
+ db5/db.h \
+ db4/db.h \
+ db3/db.h \
diff --git a/app-crypt/heimdal/heimdal-1.5.3-r1.ebuild b/app-crypt/heimdal/heimdal-1.5.3-r1.ebuild
new file mode 100644
index 000000000000..dd4e0ffaad5e
--- /dev/null
+++ b/app-crypt/heimdal/heimdal-1.5.3-r1.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-1.5.3-r1.ebuild,v 1.1 2013/07/19 13:04:28 eras Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_2,3_3} )
+VIRTUALX_REQUIRED="manual"
+
+inherit autotools db-use eutils multilib python-any-r1 toolchain-funcs virtualx flag-o-matic
+
+MY_P="${P}"
+DESCRIPTION="Kerberos 5 implementation from KTH"
+HOMEPAGE="http://www.h5l.org/"
+SRC_URI="http://www.h5l.org/dist/src/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+IUSE="afs +berkdb caps hdb-ldap ipv6 otp +pkinit ssl static-libs threads test X"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ berkdb? ( sys-libs/db )
+ !berkdb? ( sys-libs/gdbm )
+ caps? ( sys-libs/libcap-ng )
+ >=dev-db/sqlite-3.5.7
+ >=sys-libs/e2fsprogs-libs-1.41.11
+ sys-libs/ncurses
+ sys-libs/readline
+ afs? ( net-fs/openafs )
+ hdb-ldap? ( >=net-nds/openldap-2.3.0 )
+ X? ( x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXt )
+ !!app-crypt/mit-krb5
+ !!app-crypt/mit-krb5-appl"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/autoconf-2.62
+ test? ( X? ( ${VIRTUALX_DEPEND} ) )"
+
+src_prepare() {
+ epatch "${FILESDIR}/heimdal_missing-include.patch"
+ epatch "${FILESDIR}/heimdal_db6.patch"
+ epatch "${FILESDIR}/heimdal_disable-check-iprop.patch"
+ epatch "${FILESDIR}/heimdal_link_order.patch"
+ epatch "${FILESDIR}/heimdal_missing_symbols.patch"
+ epatch "${FILESDIR}/heimdal_texinfo-5.patch"
+ eautoreconf
+}
+
+src_configure() {
+ # QA
+ append-flags -fno-strict-aliasing
+
+ local myconf=""
+ if use berkdb; then
+ myconf="--with-berkeley-db --with-berkeley-db-include=$(db_includedir)"
+ else
+ myconf="--without-berkeley-db"
+ fi
+ econf \
+ --enable-kcm \
+ --disable-osfc2 \
+ --enable-shared \
+ --with-libintl=/usr \
+ --with-readline=/usr \
+ --with-sqlite3=/usr \
+ --libexecdir=/usr/sbin \
+ $(use_enable afs afs-support) \
+ $(use_enable otp) \
+ $(use_enable pkinit kx509) \
+ $(use_enable pkinit pk-init) \
+ $(use_enable static-libs static) \
+ $(use_enable threads pthread-support) \
+ $(use_with caps capng) \
+ $(use_with hdb-ldap openldap /usr) \
+ $(use_with ipv6) \
+ $(use_with ssl openssl /usr) \
+ $(use_with X x) \
+ ${myconf}
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ INSTALL_CATPAGES="no" emake DESTDIR="${D}" install
+
+ dodoc ChangeLog README NEWS TODO
+
+ # Begin client rename and install
+ for i in {telnetd,ftpd,rshd,popper}
+ do
+ mv "${D}"/usr/share/man/man8/{,k}${i}.8
+ mv "${D}"/usr/sbin/{,k}${i}
+ done
+
+ for i in {rcp,rsh,telnet,ftp,su,login,pagsh,kf}
+ do
+ mv "${D}"/usr/share/man/man1/{,k}${i}.1
+ mv "${D}"/usr/bin/{,k}${i}
+ done
+
+ mv "${D}"/usr/share/man/man5/{,k}ftpusers.5
+ mv "${D}"/usr/share/man/man5/{,k}login.access.5
+
+ newinitd "${FILESDIR}"/heimdal-kdc.initd-r2 heimdal-kdc
+ newinitd "${FILESDIR}"/heimdal-kadmind.initd-r2 heimdal-kadmind
+ newinitd "${FILESDIR}"/heimdal-kpasswdd.initd-r2 heimdal-kpasswdd
+ newinitd "${FILESDIR}"/heimdal-kcm.initd-r1 heimdal-kcm
+
+ newconfd "${FILESDIR}"/heimdal-kdc.confd heimdal-kdc
+ newconfd "${FILESDIR}"/heimdal-kadmind.confd heimdal-kadmind
+ newconfd "${FILESDIR}"/heimdal-kpasswdd.confd heimdal-kpasswdd
+ newconfd "${FILESDIR}"/heimdal-kcm.confd heimdal-kcm
+
+ insinto /etc
+ newins "${FILESDIR}"/krb5.conf krb5.conf.example
+
+ if use hdb-ldap; then
+ insinto /etc/openldap/schema
+ doins "${S}/lib/hdb/hdb.schema"
+ fi
+
+ use static-libs || find "${D}"/usr/lib* -name '*.la' -delete
+
+ # default database dir
+ keepdir /var/heimdal
+
+ # Ugly hack for broken symlink - bug #417081
+ rm "${D}"/usr/share/man/man5/qop.5 || die
+ dosym mech.5 /usr/share/man/man5/qop.5
+}