summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-09-02 22:15:32 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-09-02 22:15:32 +0000
commit7b74db33afcacbf55178bb3760cc6c4c0bd6d714 (patch)
tree2f92ec5654211e5f62eb770debbefcb18c54812e /app-crypt/opencdk/opencdk-0.4.5.ebuild
parentinitial ebuild, part of gnutls (diff)
downloadgentoo-2-7b74db33afcacbf55178bb3760cc6c4c0bd6d714.tar.gz
gentoo-2-7b74db33afcacbf55178bb3760cc6c4c0bd6d714.tar.bz2
gentoo-2-7b74db33afcacbf55178bb3760cc6c4c0bd6d714.zip
initial ebuild, part of gnutls
Diffstat (limited to 'app-crypt/opencdk/opencdk-0.4.5.ebuild')
-rw-r--r--app-crypt/opencdk/opencdk-0.4.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-crypt/opencdk/opencdk-0.4.5.ebuild b/app-crypt/opencdk/opencdk-0.4.5.ebuild
new file mode 100644
index 000000000000..e0a5e48a0d66
--- /dev/null
+++ b/app-crypt/opencdk/opencdk-0.4.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/opencdk/opencdk-0.4.5.ebuild,v 1.1 2003/09/02 22:15:28 liquidx Exp $
+
+DESCRIPTION="Open Crypto Development Kit for basic OpenPGP message manipulation"
+HOMEPAGE="http://www.gnutls.org/"
+SRC_URI="ftp://ftp.gnutls.org/pub/gnutls/opencdk/${P}.tar.gz"
+
+IUSE="doc"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+RDEPEND=">=dev-libs/libgcrypt-1.1.12"
+
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5.6"
+
+src_compile() {
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ einstall || die "installed failed"
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README \
+ README-alpha THANKS TODO
+ [ "`use doc`" ] && dohtml doc/opencdk-api.html
+}