summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2011-10-23 12:52:59 +0000
committerMike Auty <ikelos@gentoo.org>2011-10-23 12:52:59 +0000
commitdc0996a030265d31d55dd3826fdc99f03c3f5c7e (patch)
tree5ef7815e22a31a2ab867acd131293d95376fb595 /app-crypt/ophcrack
parentia64 stable wrt #385235 (diff)
downloadgentoo-2-dc0996a030265d31d55dd3826fdc99f03c3f5c7e.tar.gz
gentoo-2-dc0996a030265d31d55dd3826fdc99f03c3f5c7e.tar.bz2
gentoo-2-dc0996a030265d31d55dd3826fdc99f03c3f5c7e.zip
Added a pointless USE flag instead of requiring users to install a pointless package. Fixes bug 387023.
(Portage version: 2.2.0_alpha69/cvs/Linux i686)
Diffstat (limited to 'app-crypt/ophcrack')
-rw-r--r--app-crypt/ophcrack/ChangeLog9
-rw-r--r--app-crypt/ophcrack/metadata.xml3
-rw-r--r--app-crypt/ophcrack/ophcrack-3.3.1.ebuild14
3 files changed, 17 insertions, 9 deletions
diff --git a/app-crypt/ophcrack/ChangeLog b/app-crypt/ophcrack/ChangeLog
index 79ce952d7911..5d807e8cf0a5 100644
--- a/app-crypt/ophcrack/ChangeLog
+++ b/app-crypt/ophcrack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/ophcrack
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/ophcrack/ChangeLog,v 1.32 2009/09/30 11:30:17 ikelos Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ophcrack/ChangeLog,v 1.33 2011/10/23 12:52:59 ikelos Exp $
+
+ 23 Oct 2011; Mike Auty <ikelos@gentoo.org> ophcrack-3.3.1.ebuild,
+ metadata.xml:
+ Added a pointless USE flag instead of requiring users to install a pointless
+ package. Fixes bug 387023.
*ophcrack-3.3.1 (30 Sep 2009)
diff --git a/app-crypt/ophcrack/metadata.xml b/app-crypt/ophcrack/metadata.xml
index 06d733f61883..d01d52d783a6 100644
--- a/app-crypt/ophcrack/metadata.xml
+++ b/app-crypt/ophcrack/metadata.xml
@@ -5,4 +5,7 @@
<email>ikelos@gentoo.org</email>
<name>Mike Auty</name>
</maintainer>
+<use>
+ <flag name="tables">Require the additional tables used to carry out cracking (<pkg>app-crypt/ophcrack-tables</pkg>)</flag>
+</use>
</pkgmetadata>
diff --git a/app-crypt/ophcrack/ophcrack-3.3.1.ebuild b/app-crypt/ophcrack/ophcrack-3.3.1.ebuild
index a30f93c9d88b..c833028f7596 100644
--- a/app-crypt/ophcrack/ophcrack-3.3.1.ebuild
+++ b/app-crypt/ophcrack/ophcrack-3.3.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/ophcrack/ophcrack-3.3.1.ebuild,v 1.1 2009/09/30 11:30:17 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ophcrack/ophcrack-3.3.1.ebuild,v 1.2 2011/10/23 12:52:59 ikelos Exp $
-EAPI="1"
+EAPI="3"
inherit eutils
DESCRIPTION="A time-memory-trade-off-cracker"
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="qt4 debug"
+IUSE="qt4 debug +tables"
CDEPEND="dev-libs/openssl
net-libs/netwib
@@ -20,17 +20,17 @@ CDEPEND="dev-libs/openssl
DEPEND="app-arch/unzip
>=dev-util/pkgconfig-0.22
${CDEPEND}"
-RDEPEND="app-crypt/ophcrack-tables
+RDEPEND="tables? ( app-crypt/ophcrack-tables )
${CDEPEND}"
-src_compile() {
+src_configure() {
+
local myconf
myconf="$(use_enable qt4 gui)"
myconf="${myconf} $(use_enable debug)"
econf ${myconf} || die "Failed to compile"
- emake || die "Failed to make"
}
src_install() {