summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2008-08-31 00:50:15 +0000
committerDaniel Black <dragonheart@gentoo.org>2008-08-31 00:50:15 +0000
commit5367427720173ab4fe387e8591f08a14657736b2 (patch)
tree4d0217de338cd8f0fff1182623d66979fc7fdacb /app-crypt/qca-gnupg
parentadded missing libXt dependency as per bug #231476. thanks David and Alon (diff)
downloadgentoo-2-5367427720173ab4fe387e8591f08a14657736b2.tar.gz
gentoo-2-5367427720173ab4fe387e8591f08a14657736b2.tar.bz2
gentoo-2-5367427720173ab4fe387e8591f08a14657736b2.zip
version bump as per bug #225389 requested by Davide Pesavento
(Portage version: 2.2_rc8/cvs/Linux 2.6.22-vs2.2.0.7-gentoo x86_64)
Diffstat (limited to 'app-crypt/qca-gnupg')
-rw-r--r--app-crypt/qca-gnupg/ChangeLog8
-rw-r--r--app-crypt/qca-gnupg/qca-gnupg-2.0.0_beta3.ebuild53
2 files changed, 60 insertions, 1 deletions
diff --git a/app-crypt/qca-gnupg/ChangeLog b/app-crypt/qca-gnupg/ChangeLog
index 907478f37e22..d6ef029b6636 100644
--- a/app-crypt/qca-gnupg/ChangeLog
+++ b/app-crypt/qca-gnupg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/qca-gnupg
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca-gnupg/ChangeLog,v 1.7 2008/07/18 13:04:59 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca-gnupg/ChangeLog,v 1.8 2008/08/31 00:50:15 dragonheart Exp $
+
+*qca-gnupg-2.0.0_beta3 (31 Aug 2008)
+
+ 31 Aug 2008; Daniel Black <dragonheart@gentoo.org>
+ +qca-gnupg-2.0.0_beta3.ebuild:
+ version bump as per bug #225389 requested by Davide Pesavento
18 Jul 2008; Alexis Ballier <aballier@gentoo.org>
qca-gnupg-2.0.0_beta2.ebuild:
diff --git a/app-crypt/qca-gnupg/qca-gnupg-2.0.0_beta3.ebuild b/app-crypt/qca-gnupg/qca-gnupg-2.0.0_beta3.ebuild
new file mode 100644
index 000000000000..e58f6db2db25
--- /dev/null
+++ b/app-crypt/qca-gnupg/qca-gnupg-2.0.0_beta3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca-gnupg/qca-gnupg-2.0.0_beta3.ebuild,v 1.1 2008/08/31 00:50:15 dragonheart Exp $
+
+inherit eutils qt4
+
+MY_P="${P/_/-}"
+QCA_VER="${PV%.*}"
+
+DESCRIPTION="GnuPG plugin for QCA"
+HOMEPAGE="http://delta.affinix.com/qca/"
+SRC_URI="http://delta.affinix.com/download/qca/${QCA_VER}/plugins/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+DEPEND=">=app-crypt/qca-${QCA_VER}"
+RDEPEND="${DEPEND}
+ app-crypt/gnupg"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use debug && ! built_with_use ">=app-crypt/qca-${QCA_VER}" debug; then
+ echo
+ eerror "You are trying to compile ${PN} with USE=\"debug\""
+ eerror "while qca is built without this flag. It will not work."
+ echo
+ eerror "Possible solutions to this problem are:"
+ eerror "a) install ${PN} without debug USE flag"
+ eerror "b) re-emerge qca with debug USE flag"
+ echo
+ die "can't emerge ${PN} with debug USE flag"
+ fi
+}
+
+src_compile() {
+ # cannot use econf because of non-standard configure script
+ ./configure \
+ --qtdir=/usr \
+ $(use debug && echo "--debug" || echo "--release") \
+ --no-separate-debug-info \
+ || die "configure failed"
+
+ eqmake4 ${PN}.pro
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+}