summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-05-25 14:59:36 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-05-25 14:59:36 +0000
commitb6da4bba3bad32a7747d6b0423a2515bc6819e60 (patch)
tree942d17379adf64b0704b89b3866ebe25006bc4ee /app-crypt/qca-ossl
parentFix build issue per bug #271057. Remove old. (diff)
downloadgentoo-2-b6da4bba3bad32a7747d6b0423a2515bc6819e60.tar.gz
gentoo-2-b6da4bba3bad32a7747d6b0423a2515bc6819e60.tar.bz2
gentoo-2-b6da4bba3bad32a7747d6b0423a2515bc6819e60.zip
Eapy2fy the build system. Per bug #270653.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/qca-ossl')
-rw-r--r--app-crypt/qca-ossl/ChangeLog10
-rw-r--r--app-crypt/qca-ossl/qca-ossl-2.0.0_beta3-r1.ebuild42
2 files changed, 50 insertions, 2 deletions
diff --git a/app-crypt/qca-ossl/ChangeLog b/app-crypt/qca-ossl/ChangeLog
index 5ea060911346..f0b7ae02314b 100644
--- a/app-crypt/qca-ossl/ChangeLog
+++ b/app-crypt/qca-ossl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/qca-ossl
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca-ossl/ChangeLog,v 1.14 2008/10/03 22:32:39 loki_val Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca-ossl/ChangeLog,v 1.15 2009/05/25 14:59:36 scarabeus Exp $
+
+*qca-ossl-2.0.0_beta3-r1 (25 May 2009)
+
+ 25 May 2009; Tomas Chvatal <scarabeus@gentoo.org>
+ +qca-ossl-2.0.0_beta3-r1.ebuild:
+ Eapy2fy the build system. Per bug #270653.
03 Oct 2008; Peter Alfredsen <loki_val@gentoo.org>
files/qca-ossl-openssl-0.9.8i.patch qca-ossl-2.0.0_beta3.ebuild:
diff --git a/app-crypt/qca-ossl/qca-ossl-2.0.0_beta3-r1.ebuild b/app-crypt/qca-ossl/qca-ossl-2.0.0_beta3-r1.ebuild
new file mode 100644
index 000000000000..d4a448b39538
--- /dev/null
+++ b/app-crypt/qca-ossl/qca-ossl-2.0.0_beta3-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca-ossl/qca-ossl-2.0.0_beta3-r1.ebuild,v 1.1 2009/05/25 14:59:36 scarabeus Exp $
+
+EAPI="2"
+
+inherit base eutils qt4
+
+MY_P="${P/_/-}"
+QCA_VER="${PV%.*}"
+
+DESCRIPTION="TLS, S/MIME, PKCS#12, crypto algorithms plugin for QCA"
+HOMEPAGE="http://delta.affinix.com/qca/"
+SRC_URI="http://delta.affinix.com/download/qca/${QCA_VER}/plugins/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+DEPEND=">=app-crypt/qca-${QCA_VER}[debug?]
+ >=dev-libs/openssl-0.9.6"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}/${PN}-openssl-0.9.8i.patch" )
+
+src_configure() {
+ # cannot use econf because of non-standard configure script
+ ./configure \
+ --qtdir=/usr \
+ $(use debug && echo "--debug" || echo "--release") \
+ --no-separate-debug-info \
+ || die "configure failed"
+
+ eqmake4 ${PN}.pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+}