summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2015-06-29 00:55:26 +0000
committerDavide Pesavento <pesa@gentoo.org>2015-06-29 00:55:26 +0000
commit1dc725a1d5263d5e9601b39fd6a0217c05ee959e (patch)
treee392c8aafa4b14769356ce34f6d8b36a9b50b636 /app-crypt/qca
parentIntroduce qt{4,5}_get_plugindir(). Rephrase some eclass doc. (diff)
downloadgentoo-2-1dc725a1d5263d5e9601b39fd6a0217c05ee959e.tar.gz
gentoo-2-1dc725a1d5263d5e9601b39fd6a0217c05ee959e.tar.bz2
gentoo-2-1dc725a1d5263d5e9601b39fd6a0217c05ee959e.zip
Use qmake-utils helper functions to simplify src_configure. Remove double call to cmake-utils_src_install. Add missing die.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xDADED6B2671CB57D!)
Diffstat (limited to 'app-crypt/qca')
-rw-r--r--app-crypt/qca/ChangeLog6
-rw-r--r--app-crypt/qca/qca-2.1.0.3.ebuild42
2 files changed, 21 insertions, 27 deletions
diff --git a/app-crypt/qca/ChangeLog b/app-crypt/qca/ChangeLog
index b444fce9974a..603ddf5e2434 100644
--- a/app-crypt/qca/ChangeLog
+++ b/app-crypt/qca/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-crypt/qca
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/ChangeLog,v 1.109 2015/06/28 09:56:14 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/ChangeLog,v 1.110 2015/06/29 00:55:26 pesa Exp $
+
+ 29 Jun 2015; Davide Pesavento <pesa@gentoo.org> qca-2.1.0.3.ebuild:
+ Use qmake-utils helper functions to simplify src_configure. Remove double call
+ to cmake-utils_src_install. Add missing die.
28 Jun 2015; Mikle Kolyada <zlogene@gentoo.org> qca-2.1.0.3.ebuild:
x86 stable wrt bug #552554
diff --git a/app-crypt/qca/qca-2.1.0.3.ebuild b/app-crypt/qca/qca-2.1.0.3.ebuild
index d9e5541131d9..a9bac0501e98 100644
--- a/app-crypt/qca/qca-2.1.0.3.ebuild
+++ b/app-crypt/qca/qca-2.1.0.3.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/qca-2.1.0.3.ebuild,v 1.9 2015/06/28 09:56:14 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/qca-2.1.0.3.ebuild,v 1.10 2015/06/29 00:55:26 pesa Exp $
EAPI=5
+inherit cmake-utils multibuild qmake-utils
+
MY_PN="${PN}-qt5"
-inherit multilib cmake-utils multibuild
DESCRIPTION="Qt Cryptographic Architecture (QCA)"
HOMEPAGE="http://delta.affinix.com/qca/"
@@ -49,17 +50,17 @@ DEPEND="${RDEPEND}
)
"
-DOCS=( README TODO )
-
S=${WORKDIR}/${MY_PN}-${PV}
+DOCS=( README TODO )
+
PATCHES=(
"${FILESDIR}/${PN}-disable-pgp-test.patch"
"${FILESDIR}/${P}-qt55.patch"
)
qca_plugin_use() {
- echo "-DWITH_${2:-$1}_PLUGIN=$(use $1 && echo yes || echo no)"
+ echo -DWITH_${2:-$1}_PLUGIN=$(usex "$1")
}
pkg_setup() {
@@ -69,6 +70,8 @@ pkg_setup() {
src_configure() {
myconfigure() {
local mycmakeargs=(
+ -DQCA_FEATURE_INSTALL_DIR="${EPREFIX}$(${MULTIBUILD_VARIANT}_get_mkspecsdir)/features"
+ -DQCA_PLUGINS_INSTALL_DIR="${EPREFIX}$(${MULTIBUILD_VARIANT}_get_plugindir)"
$(qca_plugin_use botan)
$(qca_plugin_use gcrypt)
$(qca_plugin_use gpg gnupg)
@@ -81,19 +84,8 @@ src_configure() {
$(cmake-utils_use_build test TESTS)
)
- if [[ ${MULTIBUILD_VARIANT} = qt4 ]]; then
- mycmakeargs+=(
- -DQT4_BUILD=ON
- -DQCA_PLUGINS_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)/qt4/plugins"
- -DQCA_FEATURE_INSTALL_DIR="${EPREFIX}/usr/share/qt4/mkspecs/features"
- )
- fi
-
- if [[ ${MULTIBUILD_VARIANT} = qt5 ]]; then
- mycmakeargs+=(
- -DQCA_PLUGINS_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)/qt5/plugins"
- -DQCA_FEATURE_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)/qt5/mkspecs/features"
- )
+ if [[ ${MULTIBUILD_VARIANT} == qt4 ]]; then
+ mycmakeargs+=(-DQT4_BUILD=ON)
fi
cmake-utils_src_configure
@@ -106,24 +98,22 @@ src_compile() {
multibuild_foreach_variant cmake-utils_src_compile
}
+src_test() {
+ multibuild_foreach_variant cmake-utils_src_test
+}
+
src_install() {
multibuild_foreach_variant cmake-utils_src_install
if use doc; then
- pushd "${BUILD_DIR}" >/dev/null
+ pushd "${BUILD_DIR}" >/dev/null || die
doxygen Doxyfile.in || die
dohtml apidocs/html/*
- popd >/dev/null
+ popd >/dev/null || die
fi
if use examples; then
insinto /usr/share/doc/${PF}
doins -r "${S}"/examples
fi
-
- cmake-utils_src_install
-}
-
-src_test() {
- multibuild_foreach_variant cmake-utils_src_test
}