summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-05-02 09:25:20 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-05-02 09:25:20 +0000
commit9b843076bef2d7f8ebc879552004b04e120ac618 (patch)
tree73f819dffd36516ef6343edea63aa9991ba431b4 /app-crypt/qca
parentCleanup (diff)
downloadgentoo-2-9b843076bef2d7f8ebc879552004b04e120ac618.tar.gz
gentoo-2-9b843076bef2d7f8ebc879552004b04e120ac618.tar.bz2
gentoo-2-9b843076bef2d7f8ebc879552004b04e120ac618.zip
Version bump, thanks to Davide Pesavento. Fixes bug #268090
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/qca')
-rw-r--r--app-crypt/qca/ChangeLog8
-rw-r--r--app-crypt/qca/qca-2.0.2.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/app-crypt/qca/ChangeLog b/app-crypt/qca/ChangeLog
index bb710476f203..5a1d04d6610a 100644
--- a/app-crypt/qca/ChangeLog
+++ b/app-crypt/qca/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/qca
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/ChangeLog,v 1.60 2009/04/26 15:32:25 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/ChangeLog,v 1.61 2009/05/02 09:25:20 hwoarang Exp $
+
+*qca-2.0.2 (02 May 2009)
+
+ 02 May 2009; Markos Chandras <hwoarang@gentoo.org> +qca-2.0.2.ebuild:
+ Version bump, thanks to Davide Pesavento <davidepesa@gmail.com> for the
+ initial ebuild. Fixes bug #268090
26 Apr 2009; Ben de Groot <yngwin@gentoo.org> qca-2.0.0-r2, qca-2.0.1-r1:
Fix qt dep, move 2.0.1 to eapi-2 with use dep
diff --git a/app-crypt/qca/qca-2.0.2.ebuild b/app-crypt/qca/qca-2.0.2.ebuild
new file mode 100644
index 000000000000..0e017556e3c0
--- /dev/null
+++ b/app-crypt/qca/qca-2.0.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/qca-2.0.2.ebuild,v 1.1 2009/05/02 09:25:20 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils multilib qt4
+
+DESCRIPTION="Qt Cryptographic Architecture (QCA)"
+HOMEPAGE="http://delta.affinix.com/qca/"
+SRC_URI="http://delta.affinix.com/download/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples"
+RESTRICT="test"
+
+DEPEND="!<app-crypt/qca-1.0-r3
+ x11-libs/qt-core:4[debug=]"
+RDEPEND="${DEPEND}"
+
+#src_prepare() {
+# epatch "${FILESDIR}"/${P}-pcfilespath.patch
+#}
+
+src_configure() {
+ _libdir=$(get_libdir)
+
+ ./configure \
+ --prefix=/usr \
+ --qtdir=/usr \
+ --includedir="/usr/include/qca2" \
+ --libdir="/usr/${_libdir}/qca2" \
+ --no-separate-debug-info \
+ --disable-tests \
+ --$(use debug && echo debug || echo release) \
+ || die "configure failed"
+
+ eqmake4
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc README TODO || die "dodoc failed"
+
+ cat <<-EOF > "${WORKDIR}"/44qca2
+ LDPATH=/usr/${_libdir}/qca2
+ EOF
+ doenvd "${WORKDIR}"/44qca2 || die
+
+ if use doc; then
+ dohtml "${S}"/apidocs/html/* || die "Failed to install documentation"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/
+ doins -r "${S}"/examples || die "Failed to install examples"
+ fi
+}