summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-30 07:39:19 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-30 07:39:19 +0000
commit12bcd60ed8dc7f692969ca1bd4982b74e4846488 (patch)
tree775268365f5d630f4b5a54c8e80f0af97e99a50f /app-crypt
parentBump to 3.2.0 from the gnome overlay. Requires gnome-keyring-3.2 (due to chan... (diff)
downloadgentoo-2-12bcd60ed8dc7f692969ca1bd4982b74e4846488.tar.gz
gentoo-2-12bcd60ed8dc7f692969ca1bd4982b74e4846488.tar.bz2
gentoo-2-12bcd60ed8dc7f692969ca1bd4982b74e4846488.zip
Bump to 3.2.1 from the gnome overlay. The widget library has been split off into a separate package (x11-libs/libcryptui). Drop alpha, ia64, ppc, ppc64, sparc keywords due to gnome-keyring-3.2 dependency. Keywording bug will be filed later for all of gnome-3.2.
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/seahorse/ChangeLog10
-rw-r--r--app-crypt/seahorse/seahorse-3.2.1.ebuild71
2 files changed, 80 insertions, 1 deletions
diff --git a/app-crypt/seahorse/ChangeLog b/app-crypt/seahorse/ChangeLog
index f341f29a51de..9b440fbcaf11 100644
--- a/app-crypt/seahorse/ChangeLog
+++ b/app-crypt/seahorse/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-crypt/seahorse
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/ChangeLog,v 1.150 2011/08/16 23:22:14 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/ChangeLog,v 1.151 2011/10/30 07:39:19 tetromino Exp $
+
+*seahorse-3.2.1 (30 Oct 2011)
+
+ 30 Oct 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +seahorse-3.2.1.ebuild:
+ Bump to 3.2.1 from the gnome overlay. The widget library has been split off
+ into a separate package (x11-libs/libcryptui). Drop alpha, ia64, ppc, ppc64,
+ sparc keywords due to gnome-keyring-3.2 dependency.
*seahorse-3.0.2 (16 Aug 2011)
diff --git a/app-crypt/seahorse/seahorse-3.2.1.ebuild b/app-crypt/seahorse/seahorse-3.2.1.ebuild
new file mode 100644
index 000000000000..63f926e356ee
--- /dev/null
+++ b/app-crypt/seahorse/seahorse-3.2.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/seahorse-3.2.1.ebuild,v 1.1 2011/10/30 07:39:19 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="A GNOME application for managing encryption keys"
+HOMEPAGE="http://www.gnome.org/projects/seahorse/index.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="avahi debug doc ldap test"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.10:2
+ >=x11-libs/gtk+-2.90.0:3
+ >=gnome-base/gnome-keyring-3.1.5
+ net-libs/libsoup:2.4
+ x11-misc/shared-mime-info
+
+ net-misc/openssh
+ >=app-crypt/gpgme-1
+ || (
+ =app-crypt/gnupg-2.0*
+ =app-crypt/gnupg-1.4* )
+
+ avahi? ( >=net-dns/avahi-0.6 )
+ ldap? ( net-nds/openldap )
+"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/gettext
+ >=app-text/gnome-doc-utils-0.3.2
+ >=app-text/scrollkeeper-0.3
+ >=dev-util/pkgconfig-0.20
+ >=dev-util/intltool-0.35
+ doc? ( >=dev-util/gtk-doc-1.9 )
+"
+# Need seahorse-plugins git snapshot
+RDEPEND="${COMMON_DEPEND}
+ !<app-crypt/seahorse-plugins-2.91.0_pre20110114
+"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-pgp
+ --enable-ssh
+ --enable-pkcs11
+ --disable-static
+ --disable-scrollkeeper
+ --disable-update-mime-database
+ --enable-hkp
+ $(use_enable avahi sharing)
+ $(use_enable debug)
+ $(use_enable ldap)
+ $(use_enable test tests)"
+ DOCS="AUTHORS ChangeLog NEWS README TODO THANKS"
+}
+
+src_prepare() {
+ # FIXME: Do not mess with CFLAGS with USE="debug"
+ sed -e '/CFLAGS="$CFLAGS -g -O0/d' \
+ -e 's/-Werror//' \
+ -i configure.ac configure || die "sed 1 failed"
+
+ gnome2_src_prepare
+}