summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2002-05-22 21:03:14 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2002-05-22 21:03:14 +0000
commit326bfbe9e40debcf5b0b5c64ab248830b6d9063c (patch)
tree2184bc5f0183d426d0a7c253204cd5e0df462560 /app-crypt
parentgail is part of gnome2 accessibility things (diff)
downloadgentoo-2-326bfbe9e40debcf5b0b5c64ab248830b6d9063c.tar.gz
gentoo-2-326bfbe9e40debcf5b0b5c64ab248830b6d9063c.tar.bz2
gentoo-2-326bfbe9e40debcf5b0b5c64ab248830b6d9063c.zip
New package.
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/johntheripper/ChangeLog28
-rw-r--r--app-crypt/johntheripper/files/digest-johntheripper-1.62
-rw-r--r--app-crypt/johntheripper/johntheripper-1.6.ebuild48
3 files changed, 78 insertions, 0 deletions
diff --git a/app-crypt/johntheripper/ChangeLog b/app-crypt/johntheripper/ChangeLog
new file mode 100644
index 000000000000..2016f437349e
--- /dev/null
+++ b/app-crypt/johntheripper/ChangeLog
@@ -0,0 +1,28 @@
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/johntheripper/ChangeLog,v 1.1 2002/05/22 21:03:14 g2boojum Exp $
+
+*john-1.6 (22 May 2002)
+
+ 22 May 2002; Grant Goodyear <g2boojum@gentoo.org>
+
+ New package. I use the debian patch because it contains some
+ useful hacks to make john fit in an LFS filesystem (not to
+ mention man pages).
+
+-- Explanation of ChangeLog format:
+
+ Every new version or revision of the package should be marked by a '*'
+ seperator line as above. Changes since the last revision have to be added to
+ the top of the file, underneath the initial copyright and cvs header
+ comments, in exactly the same format as this comment.
+
+ This means that you start with header line that has the following format,
+ indented two spaces:
+
+ DD MMM YYYY; your_name <your_email> changed_file1, changed_file2: Your
+ explanation should follow. It should be indented and wrapped at a line width
+ of 80 characters. The changed_files can be omitted if they are obvious; for
+ example, if you are only modifying the .ebuild file and committing a new rev
+ of a package. Any details about what exactly changed in the code should be
+ added as a message when the changes are committed to cvs, not in this file.
diff --git a/app-crypt/johntheripper/files/digest-johntheripper-1.6 b/app-crypt/johntheripper/files/digest-johntheripper-1.6
new file mode 100644
index 000000000000..57eb0f6245df
--- /dev/null
+++ b/app-crypt/johntheripper/files/digest-johntheripper-1.6
@@ -0,0 +1,2 @@
+MD5 aae782f160041b2bdc624b0a84054e32 john-1.6.tar.gz 497341
+MD5 ec0b4fed7c81d370e85544deab48d03c john_1.6-17.diff.gz 11451
diff --git a/app-crypt/johntheripper/johntheripper-1.6.ebuild b/app-crypt/johntheripper/johntheripper-1.6.ebuild
new file mode 100644
index 000000000000..d04af451039e
--- /dev/null
+++ b/app-crypt/johntheripper/johntheripper-1.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/johntheripper/johntheripper-1.6.ebuild,v 1.1 2002/05/22 21:03:14 g2boojum Exp $
+
+
+PN0="john"
+DEBPATCH=${PN0}_${PV}-17.diff.gz
+DESCRIPTION="John the Ripper is a fast password cracker."
+HOMEPAGE="http://www.openwall.com/${PN0}/"
+LICENSE="GPL-2"
+DEPEND="virtual/glibc
+ >=sys-devel/binutils-2.8.1.0.15"
+#RDEPEND=""
+SRC_URI="${HOMEPAGE}/${PN0}-${PV}.tar.gz
+ http://ftp.debian.org/debian/pool/main/j/${PN0}/${DEBPATCH}"
+
+S=${WORKDIR}/${PN0}-${PV}
+
+src_unpack() {
+ unpack ${PN0}-${PV}.tar.gz
+ zcat ${DISTDIR}/${DEBPATCH} | patch -d ${PN0}-${PV} -p1
+}
+
+src_compile() {
+ cd src
+ mv Makefile Makefile.orig
+ sed -e "s/-m486//" -e "s/-Wall -O2/${CFLAGS}/" \
+ Makefile.orig > Makefile
+ if [ -z "`use mmx`" ]
+ then
+ emake generic
+ else
+ emake linux-x86-mmx-elf
+ fi
+}
+
+src_install () {
+ dodir /usr/share/${PN0} /etc
+ insinto /etc
+ doins run/john.ini debian/john-mail.msg debian/john-mail.conf
+ insinto /usr/share/${PN0}
+ doins run/{all.chr,alpha.chr,digits.chr,lanman.chr,password.lst} \
+ debian/john-dailyscript
+ dodoc debian/{CONFIG.mailer,copyright} doc/*
+ doman debian/{john.1,mailer.1,unafs.1,unique.1,unshadow.1,john-cronjob.1}
+ dosbin run/john debian/mailer debian/john-cronjob
+ (cd ${D}/usr/sbin; ln -s john unafs; ln -s john unique; ln -s john unshadow)
+}