summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-07-27 18:26:48 +0000
committerTim Harder <radhermit@gentoo.org>2014-07-27 18:26:48 +0000
commit7233fc0e1159a60e2f85a1ff9984ab8c5303f55d (patch)
tree032b26c224c500bb2da3c21a27add4fd24bc79ed /app-crypt
parentadding ~arm (diff)
downloadgentoo-2-7233fc0e1159a60e2f85a1ff9984ab8c5303f55d.tar.gz
gentoo-2-7233fc0e1159a60e2f85a1ff9984ab8c5303f55d.tar.bz2
gentoo-2-7233fc0e1159a60e2f85a1ff9984ab8c5303f55d.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/p11-kit/ChangeLog7
-rw-r--r--app-crypt/p11-kit/p11-kit-0.20.3.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/app-crypt/p11-kit/ChangeLog b/app-crypt/p11-kit/ChangeLog
index 40c29c9cbca5..79f5de47640b 100644
--- a/app-crypt/p11-kit/ChangeLog
+++ b/app-crypt/p11-kit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/p11-kit
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/p11-kit/ChangeLog,v 1.65 2014/06/22 17:32:20 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/p11-kit/ChangeLog,v 1.66 2014/07/27 18:26:48 radhermit Exp $
+
+*p11-kit-0.20.3 (27 Jul 2014)
+
+ 27 Jul 2014; Tim Harder <radhermit@gentoo.org> +p11-kit-0.20.3.ebuild:
+ Version bump.
22 Jun 2014; Michał Górny <mgorny@gentoo.org> p11-kit-0.20.2-r1.ebuild:
Fix installing gtk-doc manual, reported by galtgendo.
diff --git a/app-crypt/p11-kit/p11-kit-0.20.3.ebuild b/app-crypt/p11-kit/p11-kit-0.20.3.ebuild
new file mode 100644
index 000000000000..38bb90708582
--- /dev/null
+++ b/app-crypt/p11-kit/p11-kit-0.20.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/p11-kit/p11-kit-0.20.3.ebuild,v 1.1 2014/07/27 18:26:48 radhermit Exp $
+
+EAPI=5
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="Provides a standard configuration setup for installing PKCS#11."
+HOMEPAGE="http://p11-glue.freedesktop.org/p11-kit.html"
+SRC_URI="http://p11-glue.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="+asn1 debug +trust"
+REQUIRED_USE="trust? ( asn1 )"
+
+RDEPEND="asn1? ( >=dev-libs/libtasn1-3.4[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ # disable unsafe tests, bug#502088
+ export FAKED_MODE=1
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable trust trust-module) \
+ $(use_enable debug) \
+ $(use_with asn1 libtasn1)
+
+ if multilib_is_native_abi; then
+ # re-use provided documentation
+ ln -s "${S}"/doc/manual/html doc/manual/html || die
+ fi
+}
+
+multilib_src_install_all() {
+ prune_libtool_files --modules
+}