summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-05-06 08:02:07 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-05-06 08:02:07 +0000
commit8c96f88fa3201f9cb559d626b1c7bc666ce98ab9 (patch)
tree32f9f0907cb58176f5ab75968f95bc0a058252b8 /app-crypt
parentNew package (diff)
downloadgentoo-2-8c96f88fa3201f9cb559d626b1c7bc666ce98ab9.tar.gz
gentoo-2-8c96f88fa3201f9cb559d626b1c7bc666ce98ab9.tar.bz2
gentoo-2-8c96f88fa3201f9cb559d626b1c7bc666ce98ab9.zip
Updated package
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gnupg/ChangeLog8
-rw-r--r--app-crypt/gnupg/files/digest-gnupg-1.0.71
-rw-r--r--app-crypt/gnupg/gnupg-1.0.7.ebuild59
3 files changed, 67 insertions, 1 deletions
diff --git a/app-crypt/gnupg/ChangeLog b/app-crypt/gnupg/ChangeLog
index 50da49671465..cc91f7f2bd27 100644
--- a/app-crypt/gnupg/ChangeLog
+++ b/app-crypt/gnupg/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for app-crypt/gnupg
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.1 2002/02/01 21:53:00 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.2 2002/05/06 08:02:07 rphillips Exp $
+*gnupg-1.0.7 (1 Feb 2002)
+
+ 6 May 2002; Ryan Phillips <rphillips@gentoo.org> gnupg-1.0.7.ebuild :
+
+ Updated to new version.
+
*gnupg-1.0.6 (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
diff --git a/app-crypt/gnupg/files/digest-gnupg-1.0.7 b/app-crypt/gnupg/files/digest-gnupg-1.0.7
new file mode 100644
index 000000000000..847f63475161
--- /dev/null
+++ b/app-crypt/gnupg/files/digest-gnupg-1.0.7
@@ -0,0 +1 @@
+MD5 d8b36d4dfd213a1a1027b1877acbc897 gnupg-1.0.7.tar.gz 2399025
diff --git a/app-crypt/gnupg/gnupg-1.0.7.ebuild b/app-crypt/gnupg/gnupg-1.0.7.ebuild
new file mode 100644
index 000000000000..db49eca450ca
--- /dev/null
+++ b/app-crypt/gnupg/gnupg-1.0.7.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ben Lutgens
+# $Header: /home/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.0.4.ebuild,v 1.0
+# 2001/04/21 12:45 CST blutgens Exp $
+
+DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="ftp://ftp.gnupg.org/pub/gcrypt/gnupg/${P}.tar.gz"
+S="${WORKDIR}/${P}"
+
+DEPEND="virtual/glibc
+ nls? ( >=sys-devel/gettext-0.10.35 )
+ >=sys-libs/zlib-1.1.3"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ # Fix those $&*%^$%%$ info files
+ patch -p1 < "${FILESDIR}/gnupg-1.0.6.diff"
+}
+
+src_compile() {
+ # Check to see if we're using nls
+ local myconf
+ if [ -z "`use nls`" ]; then
+ myconf="--disable-nls"
+ fi
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-static-rnd=linux \
+ --enable-m-guard --host="${CHOST}" \
+ ${myconf} || die
+ emake || die
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog INSTALL NEWS PROJECTS
+ dodoc README TODO VERSION
+ docinto doc
+ cd doc
+ dodoc FAQ HACKING DETAILS ChangeLog
+ docinto sgml
+ dodoc gpg.sgml gpgv.sgml
+ dohtml faq.html
+ docinto txt
+ dodoc faq.raw
+ chmod +s "${D}/usr/bin/gpg"
+}
+
+pkg_postinst() {
+ einfo "gpg is installed SUID root to make use of protected memory space"
+ einfo "This is needed in order to have a secure place to store your passphrases,"
+ einfo "etc. at runtime but may make some sysadmins nervous"
+}