summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2014-04-28 13:22:02 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2014-04-28 13:22:02 +0000
commit8cd75061b9250f88ab587ca0204237a55deeaa7b (patch)
tree18fcf88850734698a5ec4af98fdc7d43bd7aa402 /app-crypt
parentAdd ~x86 keyword, wrt bug #499468 (diff)
downloadgentoo-2-8cd75061b9250f88ab587ca0204237a55deeaa7b.tar.gz
gentoo-2-8cd75061b9250f88ab587ca0204237a55deeaa7b.tar.bz2
gentoo-2-8cd75061b9250f88ab587ca0204237a55deeaa7b.zip
Fix bug#508892, thanks to Fabio Coatti
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key BF20DC51)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/dirmngr/ChangeLog8
-rw-r--r--app-crypt/dirmngr/dirmngr-1.1.1-r1.ebuild41
-rw-r--r--app-crypt/dirmngr/files/dirmngr-1.1.1-pth.patch17
3 files changed, 65 insertions, 1 deletions
diff --git a/app-crypt/dirmngr/ChangeLog b/app-crypt/dirmngr/ChangeLog
index 62b9802a4281..aa9e50419f1b 100644
--- a/app-crypt/dirmngr/ChangeLog
+++ b/app-crypt/dirmngr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/dirmngr
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/dirmngr/ChangeLog,v 1.65 2014/03/01 22:20:16 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/dirmngr/ChangeLog,v 1.66 2014/04/28 13:22:02 alonbl Exp $
+
+*dirmngr-1.1.1-r1 (28 Apr 2014)
+
+ 28 Apr 2014; Alon Bar-Lev <alonbl@gentoo.org> +dirmngr-1.1.1-r1.ebuild,
+ +files/dirmngr-1.1.1-pth.patch:
+ Fix bug#508892, thanks to Fabio Coatti
01 Mar 2014; Michał Górny <mgorny@gentoo.org> dirmngr-1.1.0.ebuild,
dirmngr-1.1.1.ebuild:
diff --git a/app-crypt/dirmngr/dirmngr-1.1.1-r1.ebuild b/app-crypt/dirmngr/dirmngr-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..a7f391721f5b
--- /dev/null
+++ b/app-crypt/dirmngr/dirmngr-1.1.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/dirmngr/dirmngr-1.1.1-r1.ebuild,v 1.1 2014/04/28 13:22:02 alonbl Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="DirMngr is a daemon to handle CRL and certificate requests for GnuPG"
+HOMEPAGE="http://www.gnupg.org/download/index.en.html#dirmngr"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND=">=net-nds/openldap-2.1.26
+ >=dev-libs/libgpg-error-1.4
+ >=dev-libs/libgcrypt-1.4.0:0
+ >=dev-libs/libksba-1.0.2
+ >=dev-libs/pth-1.3.7
+ nls? ( virtual/libintl )"
+
+DEPEND="${RDEPEND}
+ >=dev-libs/libassuan-2
+ nls? ( >=sys-devel/gettext-0.12.1 )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-pth.patch"
+}
+
+src_configure() {
+ econf --docdir="/usr/share/doc/${PF}" $(use_enable nls) \
+ LDAPLIBS="-lldap -llber"
+}
+
+src_install() {
+ default
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}
diff --git a/app-crypt/dirmngr/files/dirmngr-1.1.1-pth.patch b/app-crypt/dirmngr/files/dirmngr-1.1.1-pth.patch
new file mode 100644
index 000000000000..862458ed1db6
--- /dev/null
+++ b/app-crypt/dirmngr/files/dirmngr-1.1.1-pth.patch
@@ -0,0 +1,17 @@
+Index: src/dirmngr.c
+===================================================================
+--- src/dirmngr.c (revision 348)
++++ src/dirmngr.c (working copy)
+@@ -665,8 +665,11 @@
+ the option parsing may need services of the libraries. */
+
+ /* Libgcrypt requires us to register the threading model first.
+- Note that this will also do the pth_init. */
++ Note that this will also do the pth_init for libgcrypt < 1.6 */
+
++#if GCRYPT_VERSION_NUMBER >= 0x010600
++ pth_init ();
++#endif
+ /* Init Libgcrypt. */
+ rc = gcry_control (GCRYCTL_SET_THREAD_CBS, &gcry_threads_pth);
+ if (rc)