summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Hammer <mueli@gentoo.org>2008-05-13 12:35:37 +0000
committerMichael Hammer <mueli@gentoo.org>2008-05-13 12:35:37 +0000
commit9323aed15bec3d1311378905fc203094577bd766 (patch)
tree4c371f3f055384143b1a13d7b38727045bc25d15 /app-crypt
parentVersion bump. No need to patch files that we'll remove. Updated patch for b0r... (diff)
downloadgentoo-2-9323aed15bec3d1311378905fc203094577bd766.tar.gz
gentoo-2-9323aed15bec3d1311378905fc203094577bd766.tar.bz2
gentoo-2-9323aed15bec3d1311378905fc203094577bd766.zip
Added new ebuild app-crypt/kstart which was written by me. It is related to the bug #174594
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/kstart/ChangeLog10
-rw-r--r--app-crypt/kstart/Manifest4
-rw-r--r--app-crypt/kstart/kstart-3.12.ebuild38
-rw-r--r--app-crypt/kstart/metadata.xml13
4 files changed, 65 insertions, 0 deletions
diff --git a/app-crypt/kstart/ChangeLog b/app-crypt/kstart/ChangeLog
new file mode 100644
index 000000000000..c07df5333a9f
--- /dev/null
+++ b/app-crypt/kstart/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-crypt/kstart
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/kstart/ChangeLog,v 1.1 2008/05/13 12:35:37 mueli Exp $
+
+*kstart-3.12 (13 May 2008)
+
+ 13 May 2008; Michael Hammer <mueli@gentoo.org> +metadata.xml,
+ +kstart-3.12.ebuild:
+ New ebuild for foo. Ebuild is written by me and is related to #174594
+
diff --git a/app-crypt/kstart/Manifest b/app-crypt/kstart/Manifest
new file mode 100644
index 000000000000..b14d78d2e705
--- /dev/null
+++ b/app-crypt/kstart/Manifest
@@ -0,0 +1,4 @@
+DIST kstart-3.12.tar.gz 206402 RMD160 6c6f90cdb62c486fa7d004c0289198c1df194ef2 SHA1 d21640f8724ba45060d96598daa13e1620f69d47 SHA256 f7de39d1843869a1f92f525282a6fd65425f3f04c36c31191fba573357143639
+EBUILD kstart-3.12.ebuild 825 RMD160 ea8595a0773b0bedce039199638c5097b72c2964 SHA1 0ea234372e563b077d5ac77d1ce4428a0f725527 SHA256 924921eab368d4b05005fde61934006e9fbe5444624d3ca1f7129840be0d9930
+MISC ChangeLog 305 RMD160 24eae89034524816f08e1b8b129ff09be68139c8 SHA1 3dbed55afe322cc0e49edbb367462e19ee8e956e SHA256 d7338d7724fc497ea9be9a187ecd5c2ca48f484ea81e69f5af5d99c3179420bf
+MISC metadata.xml 541 RMD160 bdca002a1a27afc6f08bdd04dfe5f012e09daff2 SHA1 594ecd18c0593ba1adc2efb6777b977726bf85e0 SHA256 43d6bb570ee82bebf7493ee1e4de41ef34ebf27e04295bef044bf0b9de389a4a
diff --git a/app-crypt/kstart/kstart-3.12.ebuild b/app-crypt/kstart/kstart-3.12.ebuild
new file mode 100644
index 000000000000..438897c38df6
--- /dev/null
+++ b/app-crypt/kstart/kstart-3.12.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/kstart/kstart-3.12.ebuild,v 1.1 2008/05/13 12:35:37 mueli Exp $
+
+inherit eutils
+
+DESCRIPTION="Modified versions of kinit for automatic ticket refresh"
+HOMEPAGE="http://www.eyrie.org/~eagle/software/kstart"
+SRC_URI="http://archives.eyrie.org/software/kerberos/${P}.tar.gz"
+
+LICENSE="|| ( MIT Stanford ISC )"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="afs"
+
+DEPEND="virtual/krb5"
+RDEPEND="$DEPEND
+ afs? ( net-fs/openafs )"
+
+src_compile() {
+ myconf="--disable-k4start \
+ --with-kerberos \
+ $(use_with afs afs /usr/bin/aklog)"
+ econf $myconf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_test() {
+ emake -j1 check \
+ || die "Make test failed. See above for details."
+}
+
+src_install() {
+ dobin k5start krenew
+ doman k5start.1 krenew.1
+ dodoc README NEWS || die
+}
+
diff --git a/app-crypt/kstart/metadata.xml b/app-crypt/kstart/metadata.xml
new file mode 100644
index 000000000000..9d8e73f63f50
--- /dev/null
+++ b/app-crypt/kstart/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kerberos</herd>
+ <longdescription>Modified versions of kinit that can use srvtabs or
+ keytabs to authenticate, can run as daemons and wake up periodically
+ to refresh a ticket, and can run single commands with their own
+ authentication credentials and refresh those credentials until the
+ command exits.</longdescription>
+ <maintainer>
+ <email>mueli@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>