summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-07-06 19:09:25 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-07-06 19:09:25 +0000
commite251cfefb2ee85e3cbb3149c8f186ccb04135d5c (patch)
treebc9d6ab2a609422d44f827e0c54430249d56e6c9 /app-crypt
parentStable on ppc; bug #184059. (diff)
downloadgentoo-2-e251cfefb2ee85e3cbb3149c8f186ccb04135d5c.tar.gz
gentoo-2-e251cfefb2ee85e3cbb3149c8f186ccb04135d5c.tar.bz2
gentoo-2-e251cfefb2ee85e3cbb3149c8f186ccb04135d5c.zip
Version bump
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/pinentry/ChangeLog7
-rw-r--r--app-crypt/pinentry/files/digest-pinentry-0.7.33
-rw-r--r--app-crypt/pinentry/pinentry-0.7.3.ebuild76
3 files changed, 85 insertions, 1 deletions
diff --git a/app-crypt/pinentry/ChangeLog b/app-crypt/pinentry/ChangeLog
index fe62b452f6c9..fb53bc976399 100644
--- a/app-crypt/pinentry/ChangeLog
+++ b/app-crypt/pinentry/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/pinentry
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.61 2007/06/15 16:25:32 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.62 2007/07/06 19:09:25 alonbl Exp $
+
+*pinentry-0.7.3 (06 Jul 2007)
+
+ 06 Jul 2007; Alon Bar-Lev <alonbl@gentoo.org> +pinentry-0.7.3.ebuild:
+ Version bump
*pinentry-0.7.2-r4 (15 Jun 2007)
diff --git a/app-crypt/pinentry/files/digest-pinentry-0.7.3 b/app-crypt/pinentry/files/digest-pinentry-0.7.3
new file mode 100644
index 000000000000..27ca54927979
--- /dev/null
+++ b/app-crypt/pinentry/files/digest-pinentry-0.7.3
@@ -0,0 +1,3 @@
+MD5 59282278405a8264b39ea28678c78cf4 pinentry-0.7.3.tar.gz 417000
+RMD160 b7bb850e55337cefb7ec0d4eea91924c6903cce2 pinentry-0.7.3.tar.gz 417000
+SHA256 df1d2c47d501031b4c995cee3e464e62578b8959559121a207a8046e2cd9a5bf pinentry-0.7.3.tar.gz 417000
diff --git a/app-crypt/pinentry/pinentry-0.7.3.ebuild b/app-crypt/pinentry/pinentry-0.7.3.ebuild
new file mode 100644
index 000000000000..51b673d97197
--- /dev/null
+++ b/app-crypt/pinentry/pinentry-0.7.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.3.ebuild,v 1.1 2007/07/06 19:09:25 alonbl Exp $
+
+#WANT_AUTOCONF="2.5"
+#WANT_AUTOMAKE="1.9"
+
+inherit flag-o-matic qt3 multilib eutils autotools
+
+DESCRIPTION="Collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol"
+HOMEPAGE="http://www.gnupg.org/aegypten/"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk ncurses qt3 caps"
+
+DEPEND="gtk? ( =x11-libs/gtk+-2* )
+ ncurses? ( sys-libs/ncurses )
+ qt3? ( $(qt_min_version 3.3) )
+ !gtk? ( !qt3? ( !ncurses? ( sys-libs/ncurses ) ) )
+ caps? ( sys-libs/libcap )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/0.7.2-libcap.patch"
+ epatch "${FILESDIR}/0.7.2-info.patch"
+ epatch "${FILESDIR}/${PN}-0.7.2-grab.patch"
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ local myconf=""
+
+ if ! ( use qt3 || use gtk || use ncurses )
+ then
+ myconf="--enable-pinentry-curses --enable-fallback-curses"
+ fi
+
+ append-ldflags $(bindnow-flags)
+
+ # Issues finding qt on multilib systems
+ export QTLIB="${QTDIR}/$(get_libdir)"
+
+ econf \
+ --disable-dependency-tracking \
+ --enable-maintainer-mode \
+ --disable-pinentry-gtk \
+ $(use_enable gtk pinentry-gtk2) \
+ $(use_enable qt3 pinentry-qt) \
+ $(use_enable ncurses pinentry-curses) \
+ $(use_enable ncurses fallback-curses) \
+ $(use_with caps libcap) \
+ ${myconf} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "We no longer install pinentry-curses and pinentry-qt SUID root by default."
+ elog "Linux kernels >=2.6.9 support memory locking for unprivileged processes."
+ elog "The soft resource limit for memory locking specifies the limit an"
+ elog "unprivileged process may lock into memory. You can also use POSIX"
+ elog "capabilities to allow pinentry to lock memory. To do so activate the caps"
+ elog "USE flag and add the CAP_IPC_LOCK capability to the permitted set of"
+ elog "your users."
+}