summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-03-15 05:05:59 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-03-15 05:05:59 +0000
commita7e0a44156fab80d20126f7271695b81fd751a07 (patch)
treedb9ccae4e50e834b9ba4eea16583256687455469 /app-dicts/gwaei
parentForce recent version of glibc for tls support. (diff)
downloadgentoo-2-a7e0a44156fab80d20126f7271695b81fd751a07.tar.gz
gentoo-2-a7e0a44156fab80d20126f7271695b81fd751a07.tar.bz2
gentoo-2-a7e0a44156fab80d20126f7271695b81fd751a07.zip
Version bumped.
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'app-dicts/gwaei')
-rw-r--r--app-dicts/gwaei/ChangeLog7
-rw-r--r--app-dicts/gwaei/gwaei-0.15.3.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/app-dicts/gwaei/ChangeLog b/app-dicts/gwaei/ChangeLog
index 17c5f1198fd7..96e7f3113d63 100644
--- a/app-dicts/gwaei/ChangeLog
+++ b/app-dicts/gwaei/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-dicts/gwaei
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/gwaei/ChangeLog,v 1.13 2009/03/13 12:31:57 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/gwaei/ChangeLog,v 1.14 2009/03/15 05:05:59 matsuu Exp $
+
+*gwaei-0.15.3 (15 Mar 2009)
+
+ 15 Mar 2009; MATSUU Takuto <matsuu@gentoo.org> +gwaei-0.15.3.ebuild:
+ Version bumped.
13 Mar 2009; MATSUU Takuto <matsuu@gentoo.org>
-files/gwaei-0.15.1-glib.patch, -gwaei-0.14.0-r1.ebuild,
diff --git a/app-dicts/gwaei/gwaei-0.15.3.ebuild b/app-dicts/gwaei/gwaei-0.15.3.ebuild
new file mode 100644
index 000000000000..ec4dc244dc7a
--- /dev/null
+++ b/app-dicts/gwaei/gwaei-0.15.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/gwaei/gwaei-0.15.3.ebuild,v 1.1 2009/03/15 05:05:59 matsuu Exp $
+
+inherit gnome2-utils
+
+DESCRIPTION="Japanese-English Dictionary for GNOME"
+HOMEPAGE="http://gwaei.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gwaei/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome libsexy nls"
+
+RDEPEND=">=x11-libs/gtk+-2.12
+ >=net-misc/curl-7.18
+ >=dev-libs/glib-2.16.5
+ >=gnome-base/gconf-2.22
+ gnome? ( >=gnome-base/libgnome-2.20 )
+ libsexy? ( >=x11-libs/libsexy-0.1.11 )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.17 )
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf \
+ $(use_enable gnome) \
+ $(use_enable libsexy) \
+ $(use_enable nls) \
+ --disable-schemas-install || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ rm -rf "${D}/usr/share/doc/${P}"
+ dodoc AUTHORS ChangeLog NEWS README
+}
+pkg_preinst() {
+ if use gnome ; then
+ gnome2_gconf_savelist
+ gnome2_icon_savelist
+ fi
+}
+
+pkg_postinst() {
+ use gnome && gnome2_gconf_install
+}