summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-04-22 16:54:28 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-04-22 16:54:28 +0000
commita1c173ad8e8e59473fb3161fdba9c44e5d48a0a4 (patch)
tree0ac038be9c05485c299173fb5f29e191a2ef4126 /app-dicts/kasumi/kasumi-2.3-r1.ebuild
parentVersion bumped. (diff)
downloadgentoo-2-a1c173ad8e8e59473fb3161fdba9c44e5d48a0a4.tar.gz
gentoo-2-a1c173ad8e8e59473fb3161fdba9c44e5d48a0a4.tar.bz2
gentoo-2-a1c173ad8e8e59473fb3161fdba9c44e5d48a0a4.zip
Fixed to compile with gcc-4.3, bug #218107.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-dicts/kasumi/kasumi-2.3-r1.ebuild')
-rw-r--r--app-dicts/kasumi/kasumi-2.3-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-dicts/kasumi/kasumi-2.3-r1.ebuild b/app-dicts/kasumi/kasumi-2.3-r1.ebuild
new file mode 100644
index 000000000000..5e2cd3ed60a6
--- /dev/null
+++ b/app-dicts/kasumi/kasumi-2.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/kasumi/kasumi-2.3-r1.ebuild,v 1.1 2008/04/22 16:54:28 matsuu Exp $
+
+inherit eutils
+
+DESCRIPTION="Anthy dictionary maintenance tool"
+HOMEPAGE="http://kasumi.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/27825/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ nls? ( virtual/libintl )
+ virtual/libiconv
+ >=app-i18n/anthy-6131"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
+src_compile() {
+ econf $(use_enable nls) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc README ChangeLog AUTHORS
+}