summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-09-05 23:40:02 +0000
committerUlrich Müller <ulm@gentoo.org>2009-09-05 23:40:02 +0000
commite37b812eaa255fff1e506fec2d688be0573d8a25 (patch)
tree42daef8cc38e4323ab8371025e216124241c37d4 /app-doc/elisp-manual/elisp-manual-22.2.9.ebuild
parentVersion bump. Set SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-e37b812eaa255fff1e506fec2d688be0573d8a25.tar.gz
gentoo-2-e37b812eaa255fff1e506fec2d688be0573d8a25.tar.bz2
gentoo-2-e37b812eaa255fff1e506fec2d688be0573d8a25.zip
Add stand-alone manual for Emacs 22 and 23.
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'app-doc/elisp-manual/elisp-manual-22.2.9.ebuild')
-rw-r--r--app-doc/elisp-manual/elisp-manual-22.2.9.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-doc/elisp-manual/elisp-manual-22.2.9.ebuild b/app-doc/elisp-manual/elisp-manual-22.2.9.ebuild
new file mode 100644
index 000000000000..8332ca6466e8
--- /dev/null
+++ b/app-doc/elisp-manual/elisp-manual-22.2.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/elisp-manual/elisp-manual-22.2.9.ebuild,v 1.1 2009/09/05 23:40:01 ulm Exp $
+
+inherit eutils
+
+MY_P=${PN}-${PV/./-}
+DESCRIPTION="The GNU Emacs Lisp Reference Manual"
+HOMEPAGE="http://www.gnu.org/software/emacs/manual/"
+# Taken from lispref/ of emacs-22.3
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+
+LICENSE="FDL-1.2"
+SLOT="22"
+KEYWORDS="~amd64 ~ppc ~s390 ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-direntry.patch"
+}
+
+src_compile() {
+ makeinfo elisp.texi || die "makeinfo failed"
+}
+
+src_install() {
+ doinfo elisp22.info* || die "doinfo failed"
+ dodoc ChangeLog README
+}