summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2015-04-04 21:42:45 +0000
committerRyan Hill <rhill@gentoo.org>2015-04-04 21:42:45 +0000
commite6a6c25d40330c79b2553ccc335da3094d9a197d (patch)
tree085d5a637f37df81c044ad8e05cd01eaa3662dc6 /app-doc/linuxfromscratch/linuxfromscratch-7.7.ebuild
parentMark arm64/m68k/s390/sh stable. (diff)
downloadgentoo-2-e6a6c25d40330c79b2553ccc335da3094d9a197d.tar.gz
gentoo-2-e6a6c25d40330c79b2553ccc335da3094d9a197d.tar.bz2
gentoo-2-e6a6c25d40330c79b2553ccc335da3094d9a197d.zip
Version bump (bug #523696).
Signed-off-by: Ryan Hill <rhill@gentoo.org> (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 957A8463)
Diffstat (limited to 'app-doc/linuxfromscratch/linuxfromscratch-7.7.ebuild')
-rw-r--r--app-doc/linuxfromscratch/linuxfromscratch-7.7.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-doc/linuxfromscratch/linuxfromscratch-7.7.ebuild b/app-doc/linuxfromscratch/linuxfromscratch-7.7.ebuild
new file mode 100644
index 000000000000..5dfc1d0f231b
--- /dev/null
+++ b/app-doc/linuxfromscratch/linuxfromscratch-7.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/linuxfromscratch/linuxfromscratch-7.7.ebuild,v 1.1 2015/04/04 21:42:45 rhill Exp $
+
+EAPI=5
+
+MY_SRC="http://www.linuxfromscratch.org/lfs/downloads/${PV}"
+BOOTSCRIPT_PV="20150222"
+
+DESCRIPTION="LFS documents building a Linux system entirely from source"
+HOMEPAGE="http://www.linuxfromscratch.org/lfs"
+SRC_URI="${MY_SRC}/LFS-BOOK-${PV}.tar.bz2
+ ${MY_SRC}/lfs-bootscripts-${BOOTSCRIPT_PV}.tar.bz2
+ htmlsingle? ( ${MY_SRC}/LFS-BOOK-${PV}-NOCHUNKS.html )
+ pdf? ( ${MY_SRC}/LFS-BOOK-${PV}.pdf )"
+
+LICENSE="CC-BY-NC-SA-2.5 MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="htmlsingle pdf"
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack LFS-BOOK-${PV}.tar.bz2 \
+ lfs-bootscripts-${BOOTSCRIPT_PV}.tar.bz2
+
+ use htmlsingle && cp "${DISTDIR}"/LFS-BOOK-${PV}-NOCHUNKS.html "${S}"
+ use pdf && cp "${DISTDIR}"/LFS-BOOK-${PV}.pdf "${S}"
+}
+
+src_install() {
+ dodoc -r *
+ docompress -x /usr/share/doc/${PF}
+}