summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-09-25 13:55:47 +0000
committerUlrich Müller <ulm@gentoo.org>2010-09-25 13:55:47 +0000
commitd08e23c3d853ebbb49dd9927d2c2a1e4019751b3 (patch)
tree4350a2884a63b6f9f1267e1534e951abe983879e /app-editors/emacs
parentarm stable, bug #335383 (diff)
downloadgentoo-2-d08e23c3d853ebbb49dd9927d2c2a1e4019751b3.tar.gz
gentoo-2-d08e23c3d853ebbb49dd9927d2c2a1e4019751b3.tar.bz2
gentoo-2-d08e23c3d853ebbb49dd9927d2c2a1e4019751b3.zip
Move regeneration of Info dir to pkg_preinst.
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/emacs')
-rw-r--r--app-editors/emacs/ChangeLog10
-rw-r--r--app-editors/emacs/emacs-21.4-r21.ebuild183
-rw-r--r--app-editors/emacs/emacs-22.3-r5.ebuild255
-rw-r--r--app-editors/emacs/emacs-23.2-r1.ebuild316
4 files changed, 763 insertions, 1 deletions
diff --git a/app-editors/emacs/ChangeLog b/app-editors/emacs/ChangeLog
index 88a8d40b932e..599d6e3d118a 100644
--- a/app-editors/emacs/ChangeLog
+++ b/app-editors/emacs/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-editors/emacs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.384 2010/09/22 07:35:12 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.385 2010/09/25 13:55:47 ulm Exp $
+
+*emacs-23.2-r1 (25 Sep 2010)
+*emacs-22.3-r5 (25 Sep 2010)
+*emacs-21.4-r21 (25 Sep 2010)
+
+ 25 Sep 2010; Ulrich Mueller <ulm@gentoo.org> +emacs-21.4-r21.ebuild,
+ +emacs-22.3-r5.ebuild, +emacs-23.2-r1.ebuild:
+ Move regeneration of Info dir to pkg_preinst.
22 Sep 2010; Markos Chandras <hwoarang@gentoo.org> emacs-23.2.ebuild:
Stable on amd64 wrt bug #337417
diff --git a/app-editors/emacs/emacs-21.4-r21.ebuild b/app-editors/emacs/emacs-21.4-r21.ebuild
new file mode 100644
index 000000000000..f77c6122e05a
--- /dev/null
+++ b/app-editors/emacs/emacs-21.4-r21.ebuild
@@ -0,0 +1,183 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.4-r21.ebuild,v 1.1 2010/09/25 13:55:47 ulm Exp $
+
+EAPI=2
+
+inherit flag-o-matic eutils toolchain-funcs autotools
+
+DESCRIPTION="The extensible, customizable, self-documenting real-time display editor"
+HOMEPAGE="http://www.gnu.org/software/emacs/"
+SRC_URI="mirror://gnu/emacs/${P}a.tar.gz
+ mirror://gentoo/${P}-patches-11.tar.bz2
+ leim? ( mirror://gnu/emacs/leim-${PV}.tar.gz )"
+
+LICENSE="GPL-2 FDL-1.1 BSD as-is MIT"
+SLOT="21"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="X Xaw3d leim motif sendmail"
+
+DEPEND="sys-libs/ncurses
+ >=app-admin/eselect-emacs-1.2
+ X? (
+ x11-libs/libXext
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-misc/xbitmaps
+ >=media-libs/giflib-4.1.0.1b
+ >=media-libs/jpeg-6b-r2:0
+ >=media-libs/tiff-3.5.5-r3
+ >=media-libs/libpng-1.2.1
+ Xaw3d? ( x11-libs/Xaw3d )
+ !Xaw3d? ( motif? ( x11-libs/openmotif ) )
+ )"
+
+RDEPEND="${DEPEND}
+ >=app-emacs/emacs-common-gentoo-1[X?]
+ sendmail? ( virtual/mta )"
+
+src_prepare() {
+ EPATCH_SUFFIX=patch epatch
+
+ sed -i \
+ -e "s:/usr/lib/crtbegin.o:$(`tc-getCC` -print-file-name=crtbegin.o):g" \
+ -e "s:/usr/lib/crtend.o:$(`tc-getCC` -print-file-name=crtend.o):g" \
+ "${S}"/src/s/freebsd.h || die "unable to sed freebsd.h settings"
+
+ # This will need to be updated for X-Compilation
+ sed -i -e "s:/usr/lib/\([^ ]*\).o:/usr/$(get_libdir)/\1.o:g" \
+ "${S}/src/s/gnu-linux.h" || die
+
+ # custom aclocal.m4 was only needed for autoconf 2.13 and earlier
+ rm aclocal.m4
+ eaclocal
+ eautoconf
+}
+
+src_configure() {
+ # -fstack-protector gets internal compiler error at xterm.c (bug 33265)
+ filter-flags -fstack-protector
+
+ # emacs doesn't handle LDFLAGS properly (bug #77430 and bug #65002)
+ unset LDFLAGS
+
+ # ever since GCC 3.2
+ replace-flags -O[3-9] -O2
+
+ # -march is known to cause signal 6 on some environment
+ filter-flags "-march=*"
+
+ local myconf
+ if use X ; then
+ myconf="${myconf}
+ --with-x
+ --with-xpm
+ --with-jpeg
+ --with-tiff
+ --with-gif
+ --with-png"
+
+ if use Xaw3d ; then
+ einfo "Configuring to build with Xaw3d (Athena/Lucid) toolkit"
+ myconf="${myconf} --with-x-toolkit=athena"
+ use motif \
+ && ewarn "USE flag \"motif\" ignored (superseded by \"Xaw3d\")"
+ elif use motif ; then
+ einfo "Configuring to build with Motif toolkit"
+ myconf="${myconf} --with-x-toolkit=motif"
+ else
+ # do not build emacs with any toolkit, bug 35300
+ einfo "Configuring to build with no toolkit"
+ myconf="${myconf} --with-x-toolkit=no"
+ fi
+ else
+ myconf="${myconf} --without-x"
+ fi
+ econf ${myconf} || die "econf failed"
+}
+
+src_compile() {
+ export SANDBOX_ON=0
+ emake CC="$(tc-getCC)" || die "emake failed"
+
+ einfo "Recompiling patched lisp files..."
+ (cd lisp; emake recompile) || die "emake recompile failed"
+ (cd src; emake versionclean)
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ local i m
+
+ einstall || die "einstall failed"
+ for i in "${D}"/usr/bin/* ; do
+ mv "${i}" "${i}-emacs-${SLOT}" || die "mv ${i} failed"
+ done
+ mv "${D}"/usr/bin/emacs{-emacs,}-${SLOT} || die "mv emacs failed"
+ rm "${D}"/usr/bin/emacs-${PV}-emacs-${SLOT}
+
+ # move info documentation to the correct place
+ mkdir "${T}/emacs-${SLOT}"
+ mv "${D}/usr/share/info/dir" "${T}"
+ for i in "${D}"/usr/share/info/*
+ do
+ mv "${i}" "${T}/emacs-${SLOT}/${i##*/}.info"
+ done
+ mv "${T}/emacs-${SLOT}" "${D}/usr/share/info"
+ mv "${T}/dir" "${D}/usr/share/info/emacs-${SLOT}"
+
+ # move man pages to the correct place
+ for m in "${D}"/usr/share/man/man1/* ; do
+ mv "${m}" "${m%.1}-emacs-${SLOT}.1" || die "mv ${m} failed"
+ done
+
+ # avoid collision between slots
+ rm "${D}"/usr/share/emacs/site-lisp/subdirs.el
+
+ # fix permissions
+ find "${D}" -perm 664 |xargs chmod -f 644 2>/dev/null
+ find "${D}" -type d |xargs chmod -f 755 2>/dev/null
+
+ keepdir /usr/share/emacs/${PV}/leim
+
+ dodoc BUGS ChangeLog README
+}
+
+pkg_preinst() {
+ # Depending on Portage version and user's settings, the Info dir file
+ # may have been compressed or removed. We rebuild it in both cases.
+ local infodir=/usr/share/info/emacs-${SLOT} f
+ if [ -f "${D}"${infodir}/dir.info ]; then
+ # prefer existing file if it has survived to here
+ mv "${D}"${infodir}/dir{.info,} || die "mv dir.info failed"
+ else
+ einfo "Regenerating Info directory index in ${infodir} ..."
+ rm -f "${D}"${infodir}/dir{,.*}
+ for f in "${D}"${infodir}/*.info*; do
+ [[ ${f##*/} != *[0-9].info* && -e ${f} ]] \
+ && install-info --info-dir="${D}"${infodir} "${f}" &>/dev/null
+ done
+ fi
+}
+
+pkg_postinst() {
+ eselect emacs update ifunset
+
+ if ! use sendmail && ! has_version "virtual/mta"; then
+ elog "You disabled sendmail support for Emacs. If you later install"
+ elog "a MTA then you will need to recompile Emacs. See Bug #11104."
+ fi
+
+ if use X; then
+ echo
+ elog "You need to install some fonts for Emacs."
+ elog "Installing media-fonts/font-adobe-{75,100}dpi on the X server's"
+ elog "machine would satisfy basic Emacs requirements under X11."
+ fi
+}
+
+pkg_postrm() {
+ eselect emacs update ifunset
+}
diff --git a/app-editors/emacs/emacs-22.3-r5.ebuild b/app-editors/emacs/emacs-22.3-r5.ebuild
new file mode 100644
index 000000000000..f0379f64a285
--- /dev/null
+++ b/app-editors/emacs/emacs-22.3-r5.ebuild
@@ -0,0 +1,255 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-22.3-r5.ebuild,v 1.1 2010/09/25 13:55:47 ulm Exp $
+
+EAPI=2
+
+inherit autotools elisp-common eutils flag-o-matic
+
+DESCRIPTION="The extensible, customizable, self-documenting real-time display editor"
+HOMEPAGE="http://www.gnu.org/software/emacs/"
+SRC_URI="mirror://gnu/emacs/${P}.tar.gz
+ mirror://gentoo/${P}-patches-5.tar.bz2"
+
+LICENSE="GPL-3 FDL-1.2 BSD as-is MIT"
+SLOT="22"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="alsa gif gtk gzip-el hesiod jpeg kerberos motif png sound source tiff toolkit-scroll-bars X Xaw3d +xpm"
+RESTRICT="strip"
+
+RDEPEND="sys-libs/ncurses
+ >=app-admin/eselect-emacs-1.2
+ net-libs/liblockfile
+ hesiod? ( net-dns/hesiod )
+ kerberos? ( virtual/krb5 )
+ alsa? ( media-libs/alsa-lib )
+ X? (
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-misc/xbitmaps
+ gif? ( media-libs/giflib )
+ jpeg? ( media-libs/jpeg:0 )
+ png? ( media-libs/libpng )
+ tiff? ( media-libs/tiff )
+ xpm? ( x11-libs/libXpm )
+ gtk? ( x11-libs/gtk+:2 )
+ !gtk? (
+ Xaw3d? ( x11-libs/Xaw3d )
+ !Xaw3d? ( motif? ( x11-libs/openmotif ) )
+ )
+ )"
+
+DEPEND="${RDEPEND}
+ alsa? ( dev-util/pkgconfig )
+ X? ( gtk? ( dev-util/pkgconfig ) )
+ gzip-el? ( app-arch/gzip )"
+
+RDEPEND="${RDEPEND}
+ !<app-editors/emacs-vcs-22.1
+ >=app-emacs/emacs-common-gentoo-1[X?]"
+
+# FULL_VERSION keeps the full version number, which is needed in order to
+# determine some path information correctly for copy/move operations later on
+FULL_VERSION="${PV}"
+EMACS_SUFFIX="emacs-${SLOT}"
+SITEFILE="20${PN}-${SLOT}-gentoo.el"
+
+src_prepare() {
+ EPATCH_SUFFIX=patch epatch
+
+ sed -i \
+ -e "s:/usr/lib/crtbegin.o:$(`tc-getCC` -print-file-name=crtbegin.o):g" \
+ -e "s:/usr/lib/crtend.o:$(`tc-getCC` -print-file-name=crtend.o):g" \
+ "${S}"/src/s/freebsd.h || die "unable to sed freebsd.h settings"
+
+ if ! use alsa; then
+ # ALSA is detected even if not requested by its USE flag.
+ # Suppress it by supplying pkg-config with a wrong library name.
+ sed -i -e "/ALSA_MODULES=/s/alsa/DiSaBlEaLsA/" configure.in \
+ || die "unable to sed configure.in"
+ fi
+ if ! use gzip-el; then
+ # Emacs' build system automatically detects the gzip binary and
+ # compresses el files. We don't want that so confuse it with a
+ # wrong binary name
+ sed -i -e "s/ gzip/ PrEvEnTcOmPrEsSiOn/" configure.in \
+ || die "unable to sed configure.in"
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ ALLOWED_FLAGS=""
+ strip-flags
+ #unset LDFLAGS
+ replace-flags -O[3-9] -O2
+ sed -i -e "s/-lungif/-lgif/g" configure* src/Makefile* || die
+
+ local myconf
+
+ if use alsa && ! use sound; then
+ echo
+ einfo "Although sound USE flag is disabled you chose to have alsa,"
+ einfo "so sound is switched on anyway."
+ echo
+ myconf="${myconf} --with-sound"
+ else
+ myconf="${myconf} $(use_with sound)"
+ fi
+
+ if use X; then
+ myconf="${myconf} --with-x"
+ myconf="${myconf} $(use_with toolkit-scroll-bars)"
+ myconf="${myconf} $(use_with gif) $(use_with jpeg)"
+ myconf="${myconf} $(use_with png) $(use_with tiff)"
+ myconf="${myconf} $(use_with xpm)"
+
+ # GTK+ is the default toolkit if USE=gtk is chosen with other
+ # possibilities. Emacs upstream thinks this should be standard
+ # policy on all distributions
+ if use gtk; then
+ einfo "Configuring to build with GIMP Toolkit (GTK+)"
+ myconf="${myconf} --with-x-toolkit=gtk"
+ elif use Xaw3d; then
+ einfo "Configuring to build with Xaw3d (Athena/Lucid) toolkit"
+ myconf="${myconf} --with-x-toolkit=athena"
+ myconf="${myconf} --without-gtk"
+ elif use motif; then
+ einfo "Configuring to build with Motif toolkit"
+ myconf="${myconf} --with-x-toolkit=motif"
+ myconf="${myconf} --without-gtk"
+ else
+ einfo "Configuring to build with no toolkit"
+ myconf="${myconf} --with-x-toolkit=no"
+ myconf="${myconf} --without-gtk"
+ fi
+
+ local f tk=
+ for f in gtk Xaw3d motif; do
+ use ${f} || continue
+ [ "${tk}" ] \
+ && ewarn "USE flag \"${f}\" ignored (superseded by \"${tk}\")"
+ tk="${tk}${tk:+ }${f}"
+ done
+ else
+ myconf="${myconf} --without-x"
+ fi
+
+ myconf="${myconf} $(use_with hesiod)"
+ myconf="${myconf} $(use_with kerberos) $(use_with kerberos kerberos5)"
+
+ econf \
+ --program-suffix=-${EMACS_SUFFIX} \
+ --infodir=/usr/share/info/${EMACS_SUFFIX} \
+ --without-carbon \
+ ${myconf} || die "econf emacs failed"
+}
+
+src_compile() {
+ export SANDBOX_ON=0 # for the unbelievers, see Bug #131505
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install () {
+ local i m
+
+ emake install DESTDIR="${D}" || die "make install failed"
+
+ rm "${D}"/usr/bin/emacs-${FULL_VERSION}-${EMACS_SUFFIX} \
+ || die "removing duplicate emacs executable failed"
+ mv "${D}"/usr/bin/emacs-${EMACS_SUFFIX} "${D}"/usr/bin/${EMACS_SUFFIX} \
+ || die "moving Emacs executable failed"
+
+ # move info documentation to the correct place
+ for i in "${D}"/usr/share/info/${EMACS_SUFFIX}/*; do
+ mv "${i}" "${i}.info" || die "mv info failed"
+ done
+
+ # move man pages to the correct place
+ for m in "${D}"/usr/share/man/man1/* ; do
+ mv "${m}" "${m%.1}-${EMACS_SUFFIX}.1" || die "mv man failed"
+ done
+
+ # avoid collision between slots, see bug #169033 e.g.
+ rm "${D}"/usr/share/emacs/site-lisp/subdirs.el
+ rm "${D}"/var/lib/games/emacs/{snake,tetris}-scores
+ keepdir /var/lib/games/emacs
+
+ local c=";;"
+ if use source; then
+ insinto /usr/share/emacs/${FULL_VERSION}/src
+ # This is not meant to install all the source -- just the
+ # C source you might find via find-function
+ doins src/*.[ch]
+ c=""
+ fi
+
+ sed 's/^X//' >"${T}/${SITEFILE}" <<-EOF
+ X
+ ;;; ${PN}-${SLOT} site-lisp configuration
+ X
+ (when (string-match "\\\\\`${FULL_VERSION//./\\\\.}\\\\>" emacs-version)
+ X ${c}(setq find-function-C-source-directory
+ X ${c} "/usr/share/emacs/${FULL_VERSION}/src")
+ X (let ((path (getenv "INFOPATH"))
+ X (dir "/usr/share/info/${EMACS_SUFFIX}")
+ X (re "\\\\\`/usr/share/info\\\\>"))
+ X (and path
+ X ;; move Emacs Info dir before anything else in /usr/share/info
+ X (let* ((p (cons nil (split-string path ":" t))) (q p))
+ X (while (and (cdr q) (not (string-match re (cadr q))))
+ X (setq q (cdr q)))
+ X (setcdr q (cons dir (delete dir (cdr q))))
+ X (setq Info-directory-list (prune-directory-list (cdr p)))))))
+ EOF
+ elisp-site-file-install "${T}/${SITEFILE}" || die
+
+ dodoc AUTHORS BUGS CONTRIBUTE README || die "dodoc failed"
+}
+
+pkg_preinst() {
+ # Depending on Portage version and user's settings, the Info dir file
+ # may have been compressed or removed. We rebuild it in both cases.
+ local infodir=/usr/share/info/${EMACS_SUFFIX} f
+ if [ -f "${D}"${infodir}/dir.info ]; then
+ # prefer existing file if it has survived to here
+ mv "${D}"${infodir}/dir{.info,} || die "mv dir.info failed"
+ else
+ einfo "Regenerating Info directory index in ${infodir} ..."
+ rm -f "${D}"${infodir}/dir{,.*}
+ for f in "${D}"${infodir}/*.info*; do
+ [[ ${f##*/} != *[0-9].info* && -e ${f} ]] \
+ && install-info --info-dir="${D}"${infodir} "${f}" &>/dev/null
+ done
+ fi
+}
+
+pkg_postinst() {
+ local f
+ for f in "${ROOT}"/var/lib/games/emacs/{snake,tetris}-scores; do
+ [ -e "${f}" ] || touch "${f}"
+ done
+ chown games:games "${ROOT}"/var/lib/games/emacs
+
+ elisp-site-regen
+ eselect emacs update ifunset
+
+ if use X; then
+ echo
+ elog "You need to install some fonts for Emacs."
+ elog "Installing media-fonts/font-adobe-{75,100}dpi on the X server's"
+ elog "machine would satisfy basic Emacs requirements under X11."
+ fi
+
+ echo
+ elog "You can set the version to be started by /usr/bin/emacs through"
+ elog "the Emacs eselect module, which also redirects man and info pages."
+ elog "Therefore, several Emacs versions can be installed at the same time."
+ elog "\"man emacs.eselect\" for details."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+ eselect emacs update ifunset
+}
diff --git a/app-editors/emacs/emacs-23.2-r1.ebuild b/app-editors/emacs/emacs-23.2-r1.ebuild
new file mode 100644
index 000000000000..a6ae2807f7d7
--- /dev/null
+++ b/app-editors/emacs/emacs-23.2-r1.ebuild
@@ -0,0 +1,316 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-23.2-r1.ebuild,v 1.1 2010/09/25 13:55:47 ulm Exp $
+
+EAPI=2
+
+inherit autotools elisp-common eutils flag-o-matic multilib
+
+if [ "${PV##*.}" = "9999" ]; then
+ inherit bzr
+ EMACS_BRANCH="emacs-23"
+ EBZR_REPO_URI="http://bzr.savannah.gnu.org/r/emacs/${EMACS_BRANCH}/"
+ EBZR_CACHE_DIR="emacs-${EMACS_BRANCH#emacs-}"
+ SRC_URI=""
+else
+ SRC_URI="mirror://gnu/emacs/${P}.tar.bz2
+ mirror://gentoo/${P}-patches-1.tar.bz2"
+ # FULL_VERSION keeps the full version number, which is needed in
+ # order to determine some path information correctly for copy/move
+ # operations later on
+ FULL_VERSION="${PV%%_*}"
+ S="${WORKDIR}/emacs-${FULL_VERSION}"
+fi
+
+DESCRIPTION="The extensible, customizable, self-documenting real-time display editor"
+HOMEPAGE="http://www.gnu.org/software/emacs/"
+
+LICENSE="GPL-3 FDL-1.3 BSD as-is MIT W3C unicode"
+SLOT="23"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="alsa dbus gconf gif gpm gtk gzip-el hesiod jpeg kerberos m17n-lib motif png sound source svg tiff toolkit-scroll-bars X Xaw3d xft +xpm"
+RESTRICT="strip"
+
+RDEPEND="sys-libs/ncurses
+ >=app-admin/eselect-emacs-1.2
+ net-libs/liblockfile
+ hesiod? ( net-dns/hesiod )
+ kerberos? ( virtual/krb5 )
+ alsa? ( media-libs/alsa-lib )
+ gpm? ( sys-libs/gpm )
+ dbus? ( sys-apps/dbus )
+ X? (
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-misc/xbitmaps
+ gconf? ( >=gnome-base/gconf-2.26.2 )
+ gif? ( media-libs/giflib )
+ jpeg? ( media-libs/jpeg:0 )
+ png? ( media-libs/libpng )
+ svg? ( >=gnome-base/librsvg-2.0 )
+ tiff? ( media-libs/tiff )
+ xpm? ( x11-libs/libXpm )
+ xft? (
+ media-libs/fontconfig
+ media-libs/freetype
+ x11-libs/libXft
+ m17n-lib? (
+ >=dev-libs/libotf-0.9.4
+ >=dev-libs/m17n-lib-1.5.1
+ )
+ )
+ gtk? ( x11-libs/gtk+:2 )
+ !gtk? (
+ Xaw3d? ( x11-libs/Xaw3d )
+ !Xaw3d? ( motif? ( x11-libs/openmotif ) )
+ )
+ )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ gzip-el? ( app-arch/gzip )"
+
+RDEPEND="${RDEPEND}
+ !<app-editors/emacs-vcs-${PV}
+ >=app-emacs/emacs-common-gentoo-1[X?]"
+
+EMACS_SUFFIX="emacs-${SLOT}"
+SITEFILE="20${PN}-${SLOT}-gentoo.el"
+
+src_prepare() {
+ if [ "${PV##*.}" = "9999" ]; then
+ FULL_VERSION=$(grep 'defconst[ ]*emacs-version' lisp/version.el \
+ | sed -e 's/^[^"]*"\([^"]*\)".*$/\1/')
+ [ "${FULL_VERSION}" ] || die "Cannot determine current Emacs version"
+ echo
+ einfo "Emacs branch: ${EMACS_BRANCH}"
+ einfo "Emacs version number: ${FULL_VERSION}"
+ [ "${FULL_VERSION%.*}" = ${PV%.*} ] \
+ || die "Upstream version number changed to ${FULL_VERSION}"
+ echo
+ else
+ EPATCH_SUFFIX=patch epatch
+ fi
+
+ sed -i \
+ -e "s:/usr/lib/crtbegin.o:$(`tc-getCC` -print-file-name=crtbegin.o):g" \
+ -e "s:/usr/lib/crtend.o:$(`tc-getCC` -print-file-name=crtend.o):g" \
+ "${S}"/src/s/freebsd.h || die "unable to sed freebsd.h settings"
+
+ if ! use alsa; then
+ # ALSA is detected even if not requested by its USE flag.
+ # Suppress it by supplying pkg-config with a wrong library name.
+ sed -i -e "/ALSA_MODULES=/s/alsa/DiSaBlEaLsA/" configure.in \
+ || die "unable to sed configure.in"
+ fi
+ if ! use gzip-el; then
+ # Emacs' build system automatically detects the gzip binary and
+ # compresses el files. We don't want that so confuse it with a
+ # wrong binary name
+ sed -i -e "s/ gzip/ PrEvEnTcOmPrEsSiOn/" configure.in \
+ || die "unable to sed configure.in"
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ ALLOWED_FLAGS=""
+ strip-flags
+ #unset LDFLAGS
+ if use sh; then
+ replace-flags -O[1-9] -O0 #262359
+ elif use ia64; then
+ replace-flags -O[2-9] -O1 #325373
+ else
+ replace-flags -O[3-9] -O2
+ fi
+
+ local myconf
+
+ if use alsa && ! use sound; then
+ echo
+ einfo "Although sound USE flag is disabled you chose to have alsa,"
+ einfo "so sound is switched on anyway."
+ echo
+ myconf="${myconf} --with-sound"
+ else
+ myconf="${myconf} $(use_with sound)"
+ fi
+
+ if use X; then
+ myconf="${myconf} --with-x"
+ myconf="${myconf} $(use_with gconf)"
+ myconf="${myconf} $(use_with toolkit-scroll-bars)"
+ myconf="${myconf} $(use_with gif) $(use_with jpeg)"
+ myconf="${myconf} $(use_with png) $(use_with svg rsvg)"
+ myconf="${myconf} $(use_with tiff) $(use_with xpm)"
+ myconf="${myconf} $(use_with xft)"
+
+ if use xft; then
+ myconf="${myconf} $(use_with m17n-lib libotf)"
+ myconf="${myconf} $(use_with m17n-lib m17n-flt)"
+ else
+ myconf="${myconf} --without-libotf --without-m17n-flt"
+ use m17n-lib && ewarn \
+ "USE flag \"m17n-lib\" has no effect because xft is not set."
+ fi
+
+ # GTK+ is the default toolkit if USE=gtk is chosen with other
+ # possibilities. Emacs upstream thinks this should be standard
+ # policy on all distributions
+ if use gtk; then
+ einfo "Configuring to build with GIMP Toolkit (GTK+)"
+ myconf="${myconf} --with-x-toolkit=gtk"
+ elif use Xaw3d; then
+ einfo "Configuring to build with Xaw3d (Athena/Lucid) toolkit"
+ myconf="${myconf} --with-x-toolkit=athena"
+ elif use motif; then
+ einfo "Configuring to build with Motif toolkit"
+ myconf="${myconf} --with-x-toolkit=motif"
+ else
+ einfo "Configuring to build with no toolkit"
+ myconf="${myconf} --with-x-toolkit=no"
+ fi
+
+ local f tk=
+ for f in gtk Xaw3d motif; do
+ use ${f} || continue
+ [ "${tk}" ] \
+ && ewarn "USE flag \"${f}\" ignored (superseded by \"${tk}\")"
+ tk="${tk}${tk:+ }${f}"
+ done
+ else
+ myconf="${myconf} --without-x"
+ fi
+
+ myconf="${myconf} $(use_with hesiod)"
+ myconf="${myconf} $(use_with kerberos) $(use_with kerberos kerberos5)"
+ myconf="${myconf} $(use_with gpm) $(use_with dbus)"
+
+ econf \
+ --program-suffix=-${EMACS_SUFFIX} \
+ --infodir=/usr/share/info/${EMACS_SUFFIX} \
+ --with-crt-dir=/usr/$(get_libdir) \
+ ${myconf} || die "econf emacs failed"
+}
+
+src_compile() {
+ export SANDBOX_ON=0 # for the unbelievers, see Bug #131505
+ if [ "${PV##*.}" = "9999" ]; then
+ emake CC="$(tc-getCC)" bootstrap || die "make bootstrap failed"
+ # cleanup, otherwise emacs will be dumped again in src_install
+ (cd src; emake versionclean)
+ fi
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install () {
+ local i m
+
+ emake install DESTDIR="${D}" || die "make install failed"
+
+ rm "${D}"/usr/bin/emacs-${FULL_VERSION}-${EMACS_SUFFIX} \
+ || die "removing duplicate emacs executable failed"
+ mv "${D}"/usr/bin/emacs-${EMACS_SUFFIX} "${D}"/usr/bin/${EMACS_SUFFIX} \
+ || die "moving Emacs executable failed"
+
+ # move info documentation to the correct place
+ for i in "${D}"/usr/share/info/${EMACS_SUFFIX}/*; do
+ mv "${i}" "${i}.info" || die "mv info failed"
+ done
+
+ # move man pages to the correct place
+ for m in "${D}"/usr/share/man/man1/* ; do
+ mv "${m}" "${m%.1}-${EMACS_SUFFIX}.1" || die "mv man failed"
+ done
+
+ # avoid collision between slots, see bug #169033 e.g.
+ rm "${D}"/usr/share/emacs/site-lisp/subdirs.el
+ rm -rf "${D}"/usr/share/{applications,icons}
+ rm "${D}"/var/lib/games/emacs/{snake,tetris}-scores
+ keepdir /var/lib/games/emacs
+
+ local c=";;"
+ if use source; then
+ insinto /usr/share/emacs/${FULL_VERSION}/src
+ # This is not meant to install all the source -- just the
+ # C source you might find via find-function
+ doins src/*.[ch]
+ c=""
+ fi
+
+ sed 's/^X//' >"${T}/${SITEFILE}" <<-EOF
+ X
+ ;;; ${PN}-${SLOT} site-lisp configuration
+ X
+ (when (string-match "\\\\\`${FULL_VERSION//./\\\\.}\\\\>" emacs-version)
+ X ${c}(setq find-function-C-source-directory
+ X ${c} "/usr/share/emacs/${FULL_VERSION}/src")
+ X (let ((path (getenv "INFOPATH"))
+ X (dir "/usr/share/info/${EMACS_SUFFIX}")
+ X (re "\\\\\`/usr/share/info\\\\>"))
+ X (and path
+ X ;; move Emacs Info dir before anything else in /usr/share/info
+ X (let* ((p (cons nil (split-string path ":" t))) (q p))
+ X (while (and (cdr q) (not (string-match re (cadr q))))
+ X (setq q (cdr q)))
+ X (setcdr q (cons dir (delete dir (cdr q))))
+ X (setq Info-directory-list (prune-directory-list (cdr p)))))))
+ EOF
+ elisp-site-file-install "${T}/${SITEFILE}" || die
+
+ dodoc README BUGS || die "dodoc failed"
+}
+
+pkg_preinst() {
+ # Depending on Portage version and user's settings, the Info dir file
+ # may have been compressed or removed. We rebuild it in both cases.
+ local infodir=/usr/share/info/${EMACS_SUFFIX} f
+ if [ -f "${D}"${infodir}/dir.info ]; then
+ # prefer existing file if it has survived to here
+ mv "${D}"${infodir}/dir{.info,} || die "mv dir.info failed"
+ else
+ einfo "Regenerating Info directory index in ${infodir} ..."
+ rm -f "${D}"${infodir}/dir{,.*}
+ for f in "${D}"${infodir}/*.info*; do
+ [[ ${f##*/} != *[0-9].info* && -e ${f} ]] \
+ && install-info --info-dir="${D}"${infodir} "${f}" &>/dev/null
+ done
+ fi
+}
+
+pkg_postinst() {
+ local f
+ for f in "${ROOT}"/var/lib/games/emacs/{snake,tetris}-scores; do
+ [ -e "${f}" ] || touch "${f}"
+ done
+ chown games:games "${ROOT}"/var/lib/games/emacs
+
+ elisp-site-regen
+ eselect emacs update ifunset
+
+ if use X; then
+ echo
+ elog "You need to install some fonts for Emacs."
+ elog "Installing media-fonts/font-adobe-{75,100}dpi on the X server's"
+ elog "machine would satisfy basic Emacs requirements under X11."
+ elog "See also http://www.gentoo.org/proj/en/lisp/emacs/xft.xml"
+ elog "for how to enable anti-aliased fonts."
+ fi
+
+ echo
+ elog "You can set the version to be started by /usr/bin/emacs through"
+ elog "the Emacs eselect module, which also redirects man and info pages."
+ elog "Therefore, several Emacs versions can be installed at the same time."
+ elog "\"man emacs.eselect\" for details."
+ echo
+ elog "If you upgrade from a previous major version of Emacs, then it is"
+ elog "strongly recommended that you use app-admin/emacs-updater to rebuild"
+ elog "all byte-compiled elisp files of the installed Emacs packages."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+ eselect emacs update ifunset
+}