summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Kelly <pioto@gentoo.org>2007-04-29 22:28:28 +0000
committerMike Kelly <pioto@gentoo.org>2007-04-29 22:28:28 +0000
commit7c014c1e7601be70bb74490132fcff0e450f3e33 (patch)
tree342fbf96c3fb42cc8272b6dd1a2061f6f283b7fb /app-editors/gvim/gvim-7.0.235.ebuild
parentVersion bump. Fixes 2 security issues with modelines and other bugs. (diff)
downloadgentoo-2-7c014c1e7601be70bb74490132fcff0e450f3e33.tar.gz
gentoo-2-7c014c1e7601be70bb74490132fcff0e450f3e33.tar.bz2
gentoo-2-7c014c1e7601be70bb74490132fcff0e450f3e33.zip
Version bump. Fixes 2 security issues with modelines and other bugs.
(Portage version: 2.1.2.5)
Diffstat (limited to 'app-editors/gvim/gvim-7.0.235.ebuild')
-rw-r--r--app-editors/gvim/gvim-7.0.235.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-editors/gvim/gvim-7.0.235.ebuild b/app-editors/gvim/gvim-7.0.235.ebuild
new file mode 100644
index 000000000000..fc0e9935dda2
--- /dev/null
+++ b/app-editors/gvim/gvim-7.0.235.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-7.0.235.ebuild,v 1.1 2007/04/29 22:28:28 pioto Exp $
+
+inherit vim
+
+VIM_VERSION="7.0"
+VIM_SNAPSHOT="vim-7.0-r1.tar.bz2"
+VIM_GENTOO_PATCHES="vim-7.0-gentoo-patches-r1.tar.bz2"
+VIM_ORG_PATCHES="vim-patches-${PV}.tar.gz"
+GVIMRC_FILE_SUFFIX="-r1"
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/${VIM_SNAPSHOT}
+ mirror://gentoo/${VIM_GENTOO_PATCHES}
+ mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S=${WORKDIR}/vim${VIM_VERSION/.*}
+DESCRIPTION="GUI version of the Vim text editor"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="aqua gnome gtk motif nextaw"
+PROVIDE="virtual/editor"
+DEPEND="${DEPEND}
+ ~app-editors/vim-core-${PV}
+ || ( x11-libs/libXext virtual/x11 )
+ !aqua? (
+ gtk? (
+ >=x11-libs/gtk+-2.6
+ virtual/xft
+ gnome? ( >=gnome-base/libgnomeui-2.6 )
+ )
+ !gtk? (
+ motif? (
+ x11-libs/openmotif
+ )
+ !motif? (
+ nextaw? (
+ x11-libs/neXtaw
+ )
+ !nextaw? (
+ || ( x11-libs/libXaw virtual/x11 )
+ )
+ )
+ )
+ )"