summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-03-13 22:18:23 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-03-13 22:18:23 +0000
commitf69c3f02a8d694a31fb8de08f67c1decd6730897 (patch)
tree686acee4a2dd85bbaf05516a1d2dfc018c777982 /app-editors/gvim
parentbump (diff)
downloadgentoo-2-f69c3f02a8d694a31fb8de08f67c1decd6730897.tar.gz
gentoo-2-f69c3f02a8d694a31fb8de08f67c1decd6730897.tar.bz2
gentoo-2-f69c3f02a8d694a31fb8de08f67c1decd6730897.zip
massive vim eclass and vim/gvim overhauls
Diffstat (limited to 'app-editors/gvim')
-rw-r--r--app-editors/gvim/files/digest-gvim-6.1-r63
-rw-r--r--app-editors/gvim/files/vimpatch.tar.bz2bin3116 -> 0 bytes
-rw-r--r--app-editors/gvim/gvim-6.1-r6.ebuild78
3 files changed, 7 insertions, 74 deletions
diff --git a/app-editors/gvim/files/digest-gvim-6.1-r6 b/app-editors/gvim/files/digest-gvim-6.1-r6
index 5bcad15a6311..a5fb23e1e02b 100644
--- a/app-editors/gvim/files/digest-gvim-6.1-r6
+++ b/app-editors/gvim/files/digest-gvim-6.1-r6
@@ -1,3 +1,4 @@
MD5 7fd0f915adc7c0dab89772884268b030 vim-6.1.tar.bz2 2890049
-MD5 9ead3eaf912e0b63aae3ee5b55b70f25 vimpatch-1-300.tar.bz2 220361
+MD5 317606a613f68d03f381dba377a20031 vim-6.1-patches-001-300.tar.bz2 407085
+MD5 81071e861e9f07b06f18b29ee03769d3 vim-6.1-gentoo-patches.tar.bz2 3572
MD5 ed6742805866d11d6a28267330980ab1 vim-6.1-lang.tar.gz 866974
diff --git a/app-editors/gvim/files/vimpatch.tar.bz2 b/app-editors/gvim/files/vimpatch.tar.bz2
deleted file mode 100644
index f150f41bbfeb..000000000000
--- a/app-editors/gvim/files/vimpatch.tar.bz2
+++ /dev/null
Binary files differ
diff --git a/app-editors/gvim/gvim-6.1-r6.ebuild b/app-editors/gvim/gvim-6.1-r6.ebuild
index 9967fdba79f5..11aa1220625c 100644
--- a/app-editors/gvim/gvim-6.1-r6.ebuild
+++ b/app-editors/gvim/gvim-6.1-r6.ebuild
@@ -1,11 +1,13 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-6.1-r6.ebuild,v 1.5 2003/03/11 21:11:44 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-6.1-r6.ebuild,v 1.6 2003/03/13 22:18:23 seemant Exp $
-VIMPATCH="vimpatch-1-300.tar.bz2"
+EGUI_ENABLE=yes
+
+VIMPATCH="300"
inherit vim
-DESCRIPTION="graphical vim"
+DESCRIPTION="Graphical Vim"
KEYWORDS="x86 ppc sparc alpha"
DEPEND="dev-util/cscope
>=sys-libs/ncurses-5.2-r2
@@ -27,73 +29,3 @@ DEPEND="dev-util/cscope
#
# Please don't re-enable the tclinterp flag without verifying first
# that the above works. Thanks. (08 Sep 2001 agriffis)
-
-src_compile() {
- #default myconf options added by ZhEN on 11/20/02 for unicode support
- local myconf="--with-features=big --enable-multibyte"
- use nls && myconf="--enable-multibyte" || myconf="--disable-nls"
- use perl && myconf="$myconf --enable-perlinterp"
- use python && myconf="$myconf --enable-pythoninterp"
- use ruby && myconf="$myconf --enable-rubyinterp"
-
-# tclinterp is BROKEN. See note above DEPEND=
-# use tcltk && myconf="$myconf --enable-tclinterp"
-
-# Added back gpm for temporary will remove if necessary, I think that I have
-# fixed most of gpm so it should be fine.
- use gpm || myconf="$myconf --disable-gpm"
-
- if use gnome; then
- guiconf="--enable-gui=gnome --with-x"
- elif use gtk; then
- guiconf="--enable-gui=gtk --with-x"
- else
- guiconf="--enable-gui=athena --with-x"
- fi
-
- # This should fix a sandbox violation.
- for file in /dev/pty/s*
- do
- addwrite $file
- done
-
- if [ -n "$guiconf" ]; then
- ./configure \
- --prefix=/usr --mandir=/usr/share/man --host=$CHOST \
- --with-features=huge --enable-cscope $myconf $guiconf \
- --with-vim-name=gvim || die "gvim configure failed"
-
- # move config files to /etc/vim/
- echo "#define SYS_VIMRC_FILE \"/etc/vim/vimrc\"" \
- >>${WORKDIR}/vim61/src/feature.h
- echo "#define SYS_GVIMRC_FILE \"/etc/vim/gvimrc\"" \
- >>${WORKDIR}/vim61/src/feature.h
-
- # Parallel make does not work
- make || die "gvim make failed"
- fi
-}
-
-src_install() {
- dobin src/gvim
- ln -s gvim ${D}/usr/bin/gvimdiff
- # Default gvimrc
- insinto /etc/vim/
- doins ${FILESDIR}/gvimrc
-}
-
-#added by ZhEN 11/20/02 for unicode
-pkg_postinst() {
- einfo
- einfo "To enable UTF-8 viewing, set guifont and guifontwide: "
- einfo ":set guifont=-misc-fixed-medium-r-normal-*-18-120-100-100-c-90-iso10646-1"
- einfo ":set guifontwide=-misc-fixed-medium-r-normal-*-18-120-100-100-c-180-iso10646-1"
- einfo
- einfo "note: to find out which fonts you can use, please read the UTF-8 help:"
- einfo ":h utf-8"
- einfo
- einfo "Then, set read encoding to UTF-8:"
- einfo ":set encoding=utf-8"
- einfo
-
-}