summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2009-02-20 16:01:53 +0000
committerJim Ramsay <lack@gentoo.org>2009-02-20 16:01:53 +0000
commitf963d4806544282102d0fa6308b087a2c83788f6 (patch)
tree5054586f2a4a54ffaa8e8209cfb9e2afea5bbc1a /app-editors/gvim
parentAdded latest patchlevels of 7.0 and 7.1 (diff)
downloadgentoo-2-f963d4806544282102d0fa6308b087a2c83788f6.tar.gz
gentoo-2-f963d4806544282102d0fa6308b087a2c83788f6.tar.bz2
gentoo-2-f963d4806544282102d0fa6308b087a2c83788f6.zip
Added latest patchlevels of 7.0 and 7.1
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/gvim')
-rw-r--r--app-editors/gvim/ChangeLog9
-rw-r--r--app-editors/gvim/gvim-7.0.243.ebuild42
-rw-r--r--app-editors/gvim/gvim-7.1.330.ebuild43
3 files changed, 93 insertions, 1 deletions
diff --git a/app-editors/gvim/ChangeLog b/app-editors/gvim/ChangeLog
index 7a0cd53b3589..b6396ab0e574 100644
--- a/app-editors/gvim/ChangeLog
+++ b/app-editors/gvim/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/gvim
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/ChangeLog,v 1.285 2009/02/19 19:30:41 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/ChangeLog,v 1.286 2009/02/20 16:01:53 lack Exp $
+
+*gvim-7.1.330 (20 Feb 2009)
+*gvim-7.0.243 (20 Feb 2009)
+
+ 20 Feb 2009; Jim Ramsay <lack@gentoo.org> +gvim-7.0.243.ebuild,
+ +gvim-7.1.330.ebuild:
+ Added latest patchlevels of 7.0 and 7.1
*gvim-7.2.108 (19 Feb 2009)
diff --git a/app-editors/gvim/gvim-7.0.243.ebuild b/app-editors/gvim/gvim-7.0.243.ebuild
new file mode 100644
index 000000000000..849c4278acbe
--- /dev/null
+++ b/app-editors/gvim/gvim-7.0.243.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-7.0.243.ebuild,v 1.1 2009/02/20 16:01:53 lack Exp $
+
+inherit vim
+
+VIM_VERSION="7.0"
+VIM_SNAPSHOT="vim-7.0-r1.tar.bz2"
+VIM_GENTOO_PATCHES="vim-7.0-gentoo-patches-r1.tar.bz2"
+VIM_ORG_PATCHES="vim-patches-${PV}.tar"
+GVIMRC_FILE_SUFFIX="-r1"
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/${VIM_SNAPSHOT}
+ mirror://gentoo/${VIM_GENTOO_PATCHES}
+ mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S=${WORKDIR}/vim${VIM_VERSION/.*}
+DESCRIPTION="GUI version of the Vim text editor"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="aqua gnome gtk motif nextaw"
+DEPEND="${DEPEND}
+ ~app-editors/vim-core-${PV}
+ x11-libs/libXext
+ !aqua? (
+ gtk? (
+ >=x11-libs/gtk+-2.6
+ x11-libs/libXft
+ gnome? ( >=gnome-base/libgnomeui-2.6 )
+ )
+ !gtk? (
+ motif? (
+ x11-libs/openmotif
+ )
+ !motif? (
+ nextaw? (
+ x11-libs/neXtaw
+ )
+ !nextaw? ( x11-libs/libXaw )
+ )
+ )
+ )"
diff --git a/app-editors/gvim/gvim-7.1.330.ebuild b/app-editors/gvim/gvim-7.1.330.ebuild
new file mode 100644
index 000000000000..6a3437998db2
--- /dev/null
+++ b/app-editors/gvim/gvim-7.1.330.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-7.1.330.ebuild,v 1.1 2009/02/20 16:01:53 lack Exp $
+
+inherit vim
+
+VIM_VERSION="7.1"
+VIM_GENTOO_PATCHES="vim-${VIM_VERSION}-gentoo-patches.tar.bz2"
+VIM_ORG_PATCHES="vim-patches-${PV}.tar"
+GVIMRC_FILE_SUFFIX="-r1"
+GVIM_DESKTOP_SUFFIX="-r1"
+
+SRC_URI="ftp://ftp.vim.org/pub/vim/unstable/unix/vim-${VIM_VERSION}.tar.bz2
+ ftp://ftp.vim.org/pub/vim/extra/vim-${VIM_VERSION}-lang.tar.gz
+ ftp://ftp.vim.org/pub/vim/extra/vim-${VIM_VERSION}-extra.tar.gz
+ mirror://gentoo/${VIM_GENTOO_PATCHES}
+ mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S="${WORKDIR}/vim${VIM_VERSION/.}"
+DESCRIPTION="GUI version of the Vim text editor"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="aqua gnome gtk motif nextaw"
+DEPEND="${DEPEND}
+ ~app-editors/vim-core-${PV}
+ x11-libs/libXext
+ !aqua? (
+ gtk? (
+ >=x11-libs/gtk+-2.6
+ x11-libs/libXft
+ gnome? ( >=gnome-base/libgnomeui-2.6 )
+ )
+ !gtk? (
+ motif? (
+ x11-libs/openmotif
+ )
+ !motif? (
+ nextaw? (
+ x11-libs/neXtaw
+ )
+ !nextaw? ( x11-libs/libXaw )
+ )
+ )
+ )"