summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Knight <tomk@gentoo.org>2006-08-23 08:58:17 +0000
committerTom Knight <tomk@gentoo.org>2006-08-23 08:58:17 +0000
commit3d369beabae74b057d5b024144019a542431a79c (patch)
tree32f219594fdffdb3aa41d76f6e2035d26ee5f1ee /app-editors/joe
parentfix dep typo (diff)
downloadgentoo-2-3d369beabae74b057d5b024144019a542431a79c.tar.gz
gentoo-2-3d369beabae74b057d5b024144019a542431a79c.tar.bz2
gentoo-2-3d369beabae74b057d5b024144019a542431a79c.zip
Version bump to joe 3.5, thanks to Daevid Vincent, fixes bug #144810
(Portage version: 2.1-r1)
Diffstat (limited to 'app-editors/joe')
-rw-r--r--app-editors/joe/ChangeLog7
-rw-r--r--app-editors/joe/files/digest-joe-3.53
-rw-r--r--app-editors/joe/joe-3.5.ebuild61
3 files changed, 70 insertions, 1 deletions
diff --git a/app-editors/joe/ChangeLog b/app-editors/joe/ChangeLog
index 8a6154b05d22..908c655977cf 100644
--- a/app-editors/joe/ChangeLog
+++ b/app-editors/joe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/joe
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/ChangeLog,v 1.46 2006/07/14 18:52:33 tomk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/ChangeLog,v 1.47 2006/08/23 08:58:17 tomk Exp $
+
+*joe-3.5 (23 Aug 2006)
+
+ 23 Aug 2006; Tom Knight <tomk@gentoo.org> +joe-3.5.ebuild:
+ Version bump to joe 3.5, thanks to Daevid Vincent, fixes bug #144810
*joe-3.4 (14 Jul 2006)
diff --git a/app-editors/joe/files/digest-joe-3.5 b/app-editors/joe/files/digest-joe-3.5
new file mode 100644
index 000000000000..a28868cfa323
--- /dev/null
+++ b/app-editors/joe/files/digest-joe-3.5
@@ -0,0 +1,3 @@
+MD5 9bdffecce7ef910feaa06452d48843de joe-3.5.tar.gz 613815
+RMD160 c58d2bdd4882bf698722d5a8e840f3d7a0221fc6 joe-3.5.tar.gz 613815
+SHA256 a295f1c5e0cb0f0ae0446c419a248517cb04ae1881f982964a7a7595cde9f2e6 joe-3.5.tar.gz 613815
diff --git a/app-editors/joe/joe-3.5.ebuild b/app-editors/joe/joe-3.5.ebuild
new file mode 100644
index 000000000000..6555794e0346
--- /dev/null
+++ b/app-editors/joe/joe-3.5.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-3.5.ebuild,v 1.1 2006/08/23 08:58:17 tomk Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="A free ASCII-Text Screen Editor for UNIX"
+HOMEPAGE="http://sourceforge.net/projects/joe-editor/"
+SRC_URI="mirror://sourceforge/joe-editor/${P}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~mips ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+IUSE="xterm"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+RDEPEND="!ppc-macos? ( xterm? ( >=x11-terms/xterm-215-r1 ) )"
+PROVIDE="virtual/editor"
+
+pkg_setup() {
+ if use xterm && ! built_with_use x11-terms/xterm paste64; then
+ die "For full xterm clipboard support build x11-terms/xterm with USE=paste64"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"/rc
+
+ # Enable xterm mouse support in the rc files
+ if use xterm; then
+ for i in *rc*.in; do
+ sed -e 's/^ -\(mouse\|joexterm\)/-\1/' -i "${i}" || die "sed failed"
+ done
+ fi
+}
+
+src_compile() {
+ # Bug 34609 (joe 2.9.8 editor seg-faults on 'find and replace' when compiled with -Os)
+ replace-flags "-Os" "-O2"
+
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+ dodoc ChangeLog HACKING HINTS LIST NEWS README TODO
+ # remove superfluous documentation, fixes bug #116861
+ rm -rf "${D}"/etc/joe/doc
+}
+
+pkg_postinst() {
+ if use xterm; then
+ einfo "To enable full xterm clipboard you need to set the allowWindowOps"
+ einfo "resources to true. This is usually found in /etc/X11/app-defaults/XTerm"
+ einfo "This is false by default due to potential security problems on some"
+ einfo "architectures (see bug #91453)."
+
+ fi
+}