summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2009-02-22 17:02:16 +0000
committerCarsten Lohrke <carlo@gentoo.org>2009-02-22 17:02:16 +0000
commit5e450fc5d34aab9aab2e560e643bc72f80ec44ed (patch)
treeb025c6b3df02941c8b0c642112a80f905d90f30a /app-editors/kile
parent Get rid of invalid aRts dependency. (diff)
downloadgentoo-2-5e450fc5d34aab9aab2e560e643bc72f80ec44ed.tar.gz
gentoo-2-5e450fc5d34aab9aab2e560e643bc72f80ec44ed.tar.bz2
gentoo-2-5e450fc5d34aab9aab2e560e643bc72f80ec44ed.zip
Version bump. Missing eclass function call.
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'app-editors/kile')
-rw-r--r--app-editors/kile/ChangeLog10
-rw-r--r--app-editors/kile/kile-2.0.2.ebuild6
-rw-r--r--app-editors/kile/kile-2.0.3.ebuild75
3 files changed, 87 insertions, 4 deletions
diff --git a/app-editors/kile/ChangeLog b/app-editors/kile/ChangeLog
index 337e1ad361cb..399caa7658cf 100644
--- a/app-editors/kile/ChangeLog
+++ b/app-editors/kile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/kile
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/kile/ChangeLog,v 1.109 2008/09/08 19:45:11 tgurr Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/kile/ChangeLog,v 1.110 2009/02/22 17:02:16 carlo Exp $
+
+*kile-2.0.3 (22 Feb 2009)
+
+ 22 Feb 2009; Carsten Lohrke <carlo@gentoo.org> kile-2.0.2.ebuild,
+ +kile-2.0.3.ebuild:
+ Version bump. Missing eclass function call.
*kile-2.0.2 (08 Sep 2008)
diff --git a/app-editors/kile/kile-2.0.2.ebuild b/app-editors/kile/kile-2.0.2.ebuild
index b49045b4d562..e485e682573c 100644
--- a/app-editors/kile/kile-2.0.2.ebuild
+++ b/app-editors/kile/kile-2.0.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/kile/kile-2.0.2.ebuild,v 1.1 2008/09/08 19:45:11 tgurr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/kile/kile-2.0.2.ebuild,v 1.2 2009/02/22 17:02:16 carlo Exp $
ARTS_REQUIRED="never"
@@ -48,6 +48,8 @@ src_unpack() {
}
pkg_postinst() {
+ kde_pkg_postinst
+
echo
elog "${P} can use the following optional tools:"
elog "- Adobe Reader (PDF Viewer) - app-text/acroread"
diff --git a/app-editors/kile/kile-2.0.3.ebuild b/app-editors/kile/kile-2.0.3.ebuild
new file mode 100644
index 000000000000..1dc9c582fb28
--- /dev/null
+++ b/app-editors/kile/kile-2.0.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/kile/kile-2.0.3.ebuild,v 1.1 2009/02/22 17:02:16 carlo Exp $
+
+EAPI="1"
+
+ARTS_REQUIRED="never"
+
+inherit kde
+
+DESCRIPTION="A LaTeX Editor and TeX shell for kde"
+HOMEPAGE="http://kile.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="kde"
+
+RDEPEND="dev-lang/perl
+ virtual/latex-base
+ dev-tex/latex2html
+ kde? (
+ || ( ( kde-base/kpdf:3.5
+ kde-base/kghostview:3.5
+ kde-base/kdvi:3.5
+ kde-base/kviewshell:3.5 )
+ kde-base/kdegraphics:3.5 )
+ )"
+
+need-kde 3.5
+
+LANGS="ar bg br ca cs cy da de el en_GB es et eu fi fr ga gl hi hu is it ja lt ms mt nb
+nds nl nn pa pl pt pt_BR ro ru rw sk sr sr@Latn sv ta th tr uk zh_CN"
+
+for lang in ${LANGS}; do
+ IUSE="${IUSE} linguas_${lang}"
+done
+
+PATCHES=( "${FILESDIR}/kile-2.0.1-desktop-entry.diff" )
+
+src_unpack() {
+ kde_src_unpack
+
+ if [[ -n ${LINGUAS} ]]; then
+ MAKE_TRANSL=$(echo $(echo "${LINGUAS} ${LANGS}" | tr '[[:space:]]' '\n' | sort | uniq -d))
+ sed -i -e "s:^SUBDIRS.*=.*:SUBDIRS = ${MAKE_TRANSL}:" "${S}/translations/Makefile.am" || die "sed for locale failed"
+ rm -f "${S}/configure"
+ fi
+}
+
+pkg_postinst() {
+ kde_pkg_postinst
+
+ echo
+ elog "${P} can use the following optional tools:"
+ elog "- Adobe Reader (PDF Viewer) - app-text/acroread"
+ elog "- DVIPNG (PNG previews) - app-text/dvipng"
+ elog "- ImageMagick (PNG previews) - media-gfx/imagemagick"
+ elog "- zip (Archive) - app-arch/zip"
+ elog "- DBlatex (Docbook to LaTeX) - cf. Gentoo bug 129368"
+ elog "- Asymptote - media-gfx/asymptote"
+ elog "- Tex4ht (LaTeX to Web) - dev-tex/tex4ht"
+ elog "- Lilypond (Music Typesetting) - media-sound/lilypond"
+ elog "- Web-Browser (either of) - kde-base/konqueror"
+ elog " - www-client/mozilla-firefox"
+ elog " - www-client/seamonkey"
+ elog "For viewing BibTeX files:"
+ elog "- Kbibtex - app-text/kbibtex"
+ elog "- KBib - cf. Gentoo bug 147057"
+ elog "- JabRef - app-text/jabref"
+ elog "- pybliographer - app-office/pybliographer"
+ echo
+ elog "If you want to use either of these, please install them separately."
+}