summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-09-16 09:30:39 +0000
committerPacho Ramos <pacho@gentoo.org>2012-09-16 09:30:39 +0000
commit79ce037d74aab4d1b500f38d6281f322200f32ca (patch)
tree19e2f679a859479eb836d172c8d84762ba80a9ff /app-editors/lfhex
parentInitial commit, ebuild by me (bug #191494). (diff)
downloadgentoo-2-79ce037d74aab4d1b500f38d6281f322200f32ca.tar.gz
gentoo-2-79ce037d74aab4d1b500f38d6281f322200f32ca.tar.bz2
gentoo-2-79ce037d74aab4d1b500f38d6281f322200f32ca.zip
Apply debian patches to fix compilation errors like gcc-4.7 compat issues, also install a desktop entry.
(Portage version: 2.1.11.17/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/lfhex')
-rw-r--r--app-editors/lfhex/ChangeLog10
-rw-r--r--app-editors/lfhex/files/01-abs-llabs.dpatch19
-rw-r--r--app-editors/lfhex/files/02-gcc-4.7.dpatch19
-rw-r--r--app-editors/lfhex/lfhex-0.42.ebuild18
4 files changed, 57 insertions, 9 deletions
diff --git a/app-editors/lfhex/ChangeLog b/app-editors/lfhex/ChangeLog
index 09b054d9332b..581cdecb11fd 100644
--- a/app-editors/lfhex/ChangeLog
+++ b/app-editors/lfhex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/lfhex
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/lfhex/ChangeLog,v 1.29 2010/03/26 23:58:39 yngwin Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/lfhex/ChangeLog,v 1.30 2012/09/16 09:30:39 pacho Exp $
+
+ 16 Sep 2012; Pacho Ramos <pacho@gentoo.org> +files/01-abs-llabs.dpatch,
+ +files/02-gcc-4.7.dpatch, lfhex-0.42.ebuild:
+ Apply debian patches to fix compilation errors like gcc-4.7 compat issues,
+ also install a desktop entry.
26 Mar 2010; Ben de Groot <yngwin@gentoo.org> lfhex-0.42.ebuild:
Use qt4-r2.eclass (bug #311481). Formatting.
@@ -115,4 +120,3 @@
+lfhex-0.3.7.ebuild:
Initial import. Ebuild thanks to CJ Kucera <gentoo@apocalyptech.com> in bug
#52295
-
diff --git a/app-editors/lfhex/files/01-abs-llabs.dpatch b/app-editors/lfhex/files/01-abs-llabs.dpatch
new file mode 100644
index 000000000000..74ffcbce7299
--- /dev/null
+++ b/app-editors/lfhex/files/01-abs-llabs.dpatch
@@ -0,0 +1,19 @@
+#!/bin/sh /usr/share/dpatch/dpatch-run
+## 01-abs-llabs.dpatch by Thiemo Seufer
+##
+## DP: Fixes FTBFS due to abs() not being in the global anymore since g++ 4.3
+## (#495467)
+
+diff -up lfhex-0.42.orig/src/reader.cpp lfhex-0.42/src/reader.cpp
+--- lfhex-0.42.orig/src/reader.cpp 2008-10-08 19:25:57.000000000 +0200
++++ lfhex-0.42/src/reader.cpp 2008-10-08 19:26:16.000000000 +0200
+@@ -238,7 +238,7 @@ bool Reader::loadPage(off_t pageIdx)
+ // free the page which is the furthest away from the page we are loading
+
+ // this could be trouble if off_t is unsigned!
+- if( abs(_firstPage - pageIdx) > abs(_lastPage - pageIdx) )
++ if( ::llabs(_firstPage - pageIdx) > ::llabs(_lastPage - pageIdx) )
+ while(!freePage(_firstPage++));
+ else
+ while(!freePage(_lastPage--));
+
diff --git a/app-editors/lfhex/files/02-gcc-4.7.dpatch b/app-editors/lfhex/files/02-gcc-4.7.dpatch
new file mode 100644
index 000000000000..0d58072d9574
--- /dev/null
+++ b/app-editors/lfhex/files/02-gcc-4.7.dpatch
@@ -0,0 +1,19 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 02-gcc-4.7.dpatch by gregor herrmann <gregoa@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: add missing include to avoid FTBFS with gcc 4.7
+## DP: Bug-Debian: http://bugs.debian.org/667238
+
+@DPATCH@
+diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' lfhex-0.42~/src/expr.h lfhex-0.42/src/expr.h
+--- lfhex-0.42~/src/expr.h 2008-09-19 02:36:49.000000000 +0200
++++ lfhex-0.42/src/expr.h 2012-05-07 17:03:22.788794002 +0200
+@@ -19,6 +19,7 @@
+ */
+
+ #include <string>
++#include <sys/types.h>
+
+ bool expr_eval( const std::string &str, off_t &value );
+
diff --git a/app-editors/lfhex/lfhex-0.42.ebuild b/app-editors/lfhex/lfhex-0.42.ebuild
index 30720a516a62..34966f194be6 100644
--- a/app-editors/lfhex/lfhex-0.42.ebuild
+++ b/app-editors/lfhex/lfhex-0.42.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/lfhex/lfhex-0.42.ebuild,v 1.7 2010/03/26 23:58:39 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/lfhex/lfhex-0.42.ebuild,v 1.8 2012/09/16 09:30:39 pacho Exp $
-EAPI="2"
-inherit base qt4-r2
+EAPI=4
+inherit eutils qt4-r2
DESCRIPTION="A fast, efficient hex-editor with support for large files and comparing binary files"
HOMEPAGE="http://stoopidsimple.com/lfhex"
@@ -22,11 +22,17 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${P}/src
+src_prepare() {
+ # Apply Debian patches to fix compilation errors like gcc-4.7 compat
+ epatch "${FILESDIR}"/*.dpatch
+}
+
src_configure() {
eqmake4
}
src_install() {
- dobin lfhex || die
- dodoc ../README || die
+ dobin lfhex
+ dodoc ../README
+ make_desktop_entry "${PN}" "${PN}"
}