summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-11-28 21:43:36 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-11-28 21:43:36 +0000
commite8b695827f4e59b20501b7ef6277a13abadbb6a6 (patch)
treec1c808638446127f618f517a736ea050f34763d0 /app-editors/lfhex
parentx11-apps/xinit: fix customizations patch (see bug #293342) (diff)
downloadgentoo-2-e8b695827f4e59b20501b7ef6277a13abadbb6a6.tar.gz
gentoo-2-e8b695827f4e59b20501b7ef6277a13abadbb6a6.tar.bz2
gentoo-2-e8b695827f4e59b20501b7ef6277a13abadbb6a6.zip
QA: move to maintainer-needed since there is 0 interest around from former dev aparently.
Drop all old ebuilds including STABLE one (better to have no non-working ebuild in stable than pretend that we have stable). Clear latest ebuild. (Portage version: 2.2_rc53/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/lfhex')
-rw-r--r--app-editors/lfhex/ChangeLog12
-rw-r--r--app-editors/lfhex/files/lfhex-gcc3-inline-fix.patch19
-rw-r--r--app-editors/lfhex/files/ndebug.patch23
-rw-r--r--app-editors/lfhex/lfhex-0.3.7.2.ebuild28
-rw-r--r--app-editors/lfhex/lfhex-0.4-r1.ebuild39
-rw-r--r--app-editors/lfhex/lfhex-0.42.ebuild24
-rw-r--r--app-editors/lfhex/metadata.xml6
7 files changed, 23 insertions, 128 deletions
diff --git a/app-editors/lfhex/ChangeLog b/app-editors/lfhex/ChangeLog
index f0a859f4215e..5679e53fc067 100644
--- a/app-editors/lfhex/ChangeLog
+++ b/app-editors/lfhex/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-editors/lfhex
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/lfhex/ChangeLog,v 1.24 2009/10/05 19:15:22 ayoy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/lfhex/ChangeLog,v 1.25 2009/11/28 21:43:36 scarabeus Exp $
+
+ 28 Nov 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ -files/lfhex-gcc3-inline-fix.patch, -lfhex-0.3.7.2.ebuild,
+ -lfhex-0.4-r1.ebuild, lfhex-0.42.ebuild, -files/ndebug.patch,
+ metadata.xml:
+ QA: move to maintainer-needed since there is 0 interest around from former
+ dev aparently.
+ Drop all old ebuilds including STABLE one (better to have no non-working
+ ebuild in stable than pretend that we have stable).
+ Clear latest ebuild.
05 Oct 2009; Dominik Kapusta <ayoy@gentoo.org> lfhex-0.4-r1.ebuild,
lfhex-0.42.ebuild:
diff --git a/app-editors/lfhex/files/lfhex-gcc3-inline-fix.patch b/app-editors/lfhex/files/lfhex-gcc3-inline-fix.patch
deleted file mode 100644
index c03754e884af..000000000000
--- a/app-editors/lfhex/files/lfhex-gcc3-inline-fix.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff -ur lfhex-0.3.7.old/src/reader.hpp lfhex-0.3.7.new/src/reader.hpp
---- lfhex-0.3.7.old/src/reader.hpp 2004-02-12 23:28:32.000000000 -0500
-+++ lfhex-0.3.7.new/src/reader.hpp 2004-07-22 18:06:55.038879120 -0400
-@@ -34,9 +34,13 @@
- #include "local.h"
-
- #ifdef DEBUG
--#define INLINE
-+# define INLINE
- #else
--#define INLINE inline
-+# if defined(__GNUC__) && __GNUC__ == 3 && __GNUC_MINOR__ >= 1
-+# define INLINE __attribute__((always_inline))
-+# else
-+# define INLINE inline
-+# endif
- #endif
-
- typedef vector<uchar> ReadBuffer;
diff --git a/app-editors/lfhex/files/ndebug.patch b/app-editors/lfhex/files/ndebug.patch
deleted file mode 100644
index e2f76607f32a..000000000000
--- a/app-editors/lfhex/files/ndebug.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Patches lfhex to compile fine with -DNDEBUG (which is typically used to
-compile release versions without debugging information).
-
-The original version made an essential function call within an assert()
-statement - but defining NDEBUG makes any assert statements into no-ops.
-
-Patch written 2008 by Guenther Brunthaler <gb_about_gnu@gmx.net>
-Index: src/reader.cpp
-===================================================================
---- src.orig/reader.cpp
-+++ src/reader.cpp
-@@ -278,7 +278,11 @@ uchar Reader::operator[] (off_t offset)
- "attempt to access past end of file");
-
- off_t page_idx = offset/_pageSize;
-+ #ifdef NDEBUG
-+ (void)loadPage( page_idx );
-+ #else
- assert( loadPage( page_idx ) );
-+ #endif
- return _data[page_idx][ offset%_pageSize ];
- }
-
diff --git a/app-editors/lfhex/lfhex-0.3.7.2.ebuild b/app-editors/lfhex/lfhex-0.3.7.2.ebuild
deleted file mode 100644
index d8b1b1b3eedc..000000000000
--- a/app-editors/lfhex/lfhex-0.3.7.2.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/lfhex/lfhex-0.3.7.2.ebuild,v 1.5 2009/10/05 19:15:22 ayoy Exp $
-
-inherit eutils
-
-DESCRIPTION="A fast, efficient hex-editor with support for large files and comparing binary files"
-HOMEPAGE="http://freshmeat.net/projects/lfhex"
-SRC_URI="http://home.earthlink.net/~eyekode/data/${P}.tar.gz"
-LICENSE="QPL-1.0"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-
-IUSE=""
-
-RDEPEND="=x11-libs/qt-3*
- >=x11-libs/libXt-1.0.0"
-
-DEPEND="${RDEPEND}
- sys-devel/flex
- sys-devel/bison
- sys-apps/grep
- sys-apps/net-tools"
-
-src_install() {
- dobin bin/lfhex
- dodoc README
-}
diff --git a/app-editors/lfhex/lfhex-0.4-r1.ebuild b/app-editors/lfhex/lfhex-0.4-r1.ebuild
deleted file mode 100644
index 2d34b62c3619..000000000000
--- a/app-editors/lfhex/lfhex-0.4-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/lfhex/lfhex-0.4-r1.ebuild,v 1.4 2009/10/05 19:15:22 ayoy Exp $
-
-EAPI="1"
-
-inherit qt4 toolchain-funcs
-
-DESCRIPTION="A fast, efficient hex-editor with support for large files and comparing binary files"
-HOMEPAGE="http://stoopidsimple.com/lfhex"
-SRC_URI="http://stoopidsimple.com/files/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-
-IUSE=""
-
-RDEPEND="x11-libs/qt-gui:4
- >=x11-libs/libXt-1.0.0"
-
-DEPEND="sys-devel/flex
- sys-devel/bison
- ${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/ndebug.patch
-}
-src_compile() {
-# eqmake4 lfhex.pro
- eqmake4 || die "eqmake4 failed"
- emake || die "emake failed"
-}
-
-src_install() {
- dobin lfhex
- dodoc README
-}
diff --git a/app-editors/lfhex/lfhex-0.42.ebuild b/app-editors/lfhex/lfhex-0.42.ebuild
index c6dd78b98d84..3d6b4a18eb92 100644
--- a/app-editors/lfhex/lfhex-0.42.ebuild
+++ b/app-editors/lfhex/lfhex-0.42.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/lfhex/lfhex-0.42.ebuild,v 1.2 2009/10/05 19:15:22 ayoy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/lfhex/lfhex-0.42.ebuild,v 1.3 2009/11/28 21:43:36 scarabeus Exp $
-EAPI="1"
+EAPI="2"
-inherit qt4 toolchain-funcs
+inherit base qt4
DESCRIPTION="A fast, efficient hex-editor with support for large files and comparing binary files"
HOMEPAGE="http://stoopidsimple.com/lfhex"
@@ -16,20 +16,18 @@ KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
RDEPEND="x11-libs/qt-gui:4
- >=x11-libs/libXt-1.0.0"
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison"
-DEPEND="sys-devel/flex
- sys-devel/bison
- ${RDEPEND}"
-S="${WORKDIR}"/${P}/src
+S=${WORKDIR}/${P}/src
-src_compile() {
-# eqmake4 lfhex.pro
+src_configure() {
eqmake4 || die "eqmake4 failed"
- emake || die "emake failed"
}
src_install() {
- dobin lfhex
- dodoc ../README
+ dobin lfhex || die
+ dodoc ../README || die
}
diff --git a/app-editors/lfhex/metadata.xml b/app-editors/lfhex/metadata.xml
index b9fc2b9c6f11..616f0488f72e 100644
--- a/app-editors/lfhex/metadata.xml
+++ b/app-editors/lfhex/metadata.xml
@@ -3,10 +3,6 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
- <email>dragonheart@gentoo.org</email>
- <name>Daniel Black</name>
- <description>A user ebuild that I felt obliged to include. Please take over if you want
-it</description>
+ <email>maintainer-needed@gentoo.org</email>
</maintainer>
-<longdescription></longdescription>
</pkgmetadata>