summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2003-10-04 15:22:24 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2003-10-04 15:22:24 +0000
commitf5fc3b900c1939fdba4ed50a6e695574e5fd643a (patch)
treecdc9921503d508c6853f25dfec608ebd66930e27 /app-editors/lpe/lpe-1.2.6.ebuild
parentInitial import (diff)
downloadgentoo-2-f5fc3b900c1939fdba4ed50a6e695574e5fd643a.tar.gz
gentoo-2-f5fc3b900c1939fdba4ed50a6e695574e5fd643a.tar.bz2
gentoo-2-f5fc3b900c1939fdba4ed50a6e695574e5fd643a.zip
Initial import
Diffstat (limited to 'app-editors/lpe/lpe-1.2.6.ebuild')
-rw-r--r--app-editors/lpe/lpe-1.2.6.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-editors/lpe/lpe-1.2.6.ebuild b/app-editors/lpe/lpe-1.2.6.ebuild
new file mode 100644
index 000000000000..75a6f86761f1
--- /dev/null
+++ b/app-editors/lpe/lpe-1.2.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/lpe/lpe-1.2.6.ebuild,v 1.1 2003/10/04 15:22:15 pyrania Exp $
+
+DESCRIPTION="Lightweight Programmers Editor"
+HOMEPAGE="http://cdsmith.twu.net/professional/opensource/lpe.html"
+SRC_URI="ftp://ftp.twu.net/users/cdsmith/lpe/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT=0
+KEYWORDS="~x86 ~sparc"
+IUSE="nls"
+
+DEPEND="sys-libs/slang"
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+
+ epatch ${FILESDIR}/${P}-gentoo.patch
+}
+
+
+src_compile() {
+ econf `use_enable nls` || die
+
+ emake || die
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ datadir=${D}/usr/share \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ docdir=${D}/usr/share/doc/${PF} \
+ exdir=${D}/usr/share/doc/${PF}/examples \
+ install || die
+ prealldocs
+}