summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-09-23 15:53:11 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-09-23 15:53:11 +0000
commit1a6a8a8354d04f6df890b11551ff7efcc679f3b9 (patch)
treeda500293a163ba1182b06f904cff35b7df91ec0a /app-editors/lpe
parentVersion bump. This corresponds to Emacs 23.2. (diff)
downloadgentoo-2-1a6a8a8354d04f6df890b11551ff7efcc679f3b9.tar.gz
gentoo-2-1a6a8a8354d04f6df890b11551ff7efcc679f3b9.tar.bz2
gentoo-2-1a6a8a8354d04f6df890b11551ff7efcc679f3b9.zip
Fix building with make >= 3.82 wrt #335324 by Diego E. Pettenò.
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/lpe')
-rw-r--r--app-editors/lpe/ChangeLog6
-rw-r--r--app-editors/lpe/files/lpe-1.2.6.13-make-382.patch23
-rw-r--r--app-editors/lpe/lpe-1.2.6.13.ebuild11
3 files changed, 35 insertions, 5 deletions
diff --git a/app-editors/lpe/ChangeLog b/app-editors/lpe/ChangeLog
index 5eb2ed0e911a..2cac583f54b7 100644
--- a/app-editors/lpe/ChangeLog
+++ b/app-editors/lpe/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/lpe
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/lpe/ChangeLog,v 1.23 2010/04/05 04:10:05 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/lpe/ChangeLog,v 1.24 2010/09/23 15:53:11 ssuominen Exp $
+
+ 23 Sep 2010; Samuli Suominen <ssuominen@gentoo.org> lpe-1.2.6.13.ebuild,
+ +files/lpe-1.2.6.13-make-382.patch:
+ Fix building with make >= 3.82 wrt #335324 by Diego E. Pettenò.
05 Apr 2010; Jonathan Callen <abcd@gentoo.org> lpe-1.2.6.13.ebuild:
Bump to EAPI=3, add prefix keywords
diff --git a/app-editors/lpe/files/lpe-1.2.6.13-make-382.patch b/app-editors/lpe/files/lpe-1.2.6.13-make-382.patch
new file mode 100644
index 000000000000..f8d96ef087e9
--- /dev/null
+++ b/app-editors/lpe/files/lpe-1.2.6.13-make-382.patch
@@ -0,0 +1,23 @@
+http://bugs.gentoo.org/335324
+
+--- intl/Makefile.in
++++ intl/Makefile.in
+@@ -202,12 +202,12 @@
+ # The dependency for intlh.inst is different in gettext and all other
+ # packages. Because we cannot you GNU make features we have to solve
+ # the problem while rewriting Makefile.in.
+-@GT_YES@intlh.inst: intlh.inst.in ../config.status
+-@GT_YES@ cd .. \
+-@GT_YES@ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= \
+-@GT_YES@ $(SHELL) ./config.status
+-@GT_NO@.PHONY: intlh.inst
+-@GT_NO@intlh.inst:
++intlh.inst: intlh.inst.in ../config.status
++ cd .. \
++ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= \
++ $(SHELL) ./config.status
++.PHONY: intlh.inst
++intlh.inst:
+
+ # Tell versions [3.59,3.63) of GNU make not to export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/app-editors/lpe/lpe-1.2.6.13.ebuild b/app-editors/lpe/lpe-1.2.6.13.ebuild
index 3769cbb01b03..a4d387e6bce7 100644
--- a/app-editors/lpe/lpe-1.2.6.13.ebuild
+++ b/app-editors/lpe/lpe-1.2.6.13.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/lpe/lpe-1.2.6.13.ebuild,v 1.10 2010/04/05 04:10:05 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/lpe/lpe-1.2.6.13.ebuild,v 1.11 2010/09/23 15:53:11 ssuominen Exp $
-EAPI="3"
-
-inherit multilib
+EAPI=3
+inherit eutils multilib
DESCRIPTION="a lightweight programmers editor"
HOMEPAGE="http://packages.qa.debian.org/l/lpe.html"
@@ -19,6 +18,10 @@ RDEPEND=">=sys-libs/slang-2.1.3"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-make-382.patch
+}
+
src_configure() {
econf $(use_enable nls)
}