summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-08-18 19:07:51 +0000
committerMike Frysinger <vapier@gentoo.org>2004-08-18 19:07:51 +0000
commit98a17263f84f3f1ff2f0ff41da3b1a86a507212b (patch)
tree87a3fcc1a8e9e8c1f0c423ca6c87f20a9e7382ec /app-editors/nano
parentVersion bump to 0.7.0. Closes #60757. (Manifest recommit) (diff)
downloadgentoo-2-98a17263f84f3f1ff2f0ff41da3b1a86a507212b.tar.gz
gentoo-2-98a17263f84f3f1ff2f0ff41da3b1a86a507212b.tar.bz2
gentoo-2-98a17263f84f3f1ff2f0ff41da3b1a86a507212b.zip
add patch from upstream to fix nanorc tabbing
Diffstat (limited to 'app-editors/nano')
-rw-r--r--app-editors/nano/files/1.3.4-nanobrack.patch15
-rw-r--r--app-editors/nano/nano-1.3.4.ebuild3
2 files changed, 17 insertions, 1 deletions
diff --git a/app-editors/nano/files/1.3.4-nanobrack.patch b/app-editors/nano/files/1.3.4-nanobrack.patch
new file mode 100644
index 000000000000..606f0580bc04
--- /dev/null
+++ b/app-editors/nano/files/1.3.4-nanobrack.patch
@@ -0,0 +1,15 @@
+diff -ur nano-1.3.4/src/rcfile.c nano-1.3.4-fixed/src/rcfile.c
+--- nano-1.3.4/src/rcfile.c 2004-08-18 05:31:26.000000000 +0200
++++ nano-1.3.4-fixed/src/rcfile.c 2004-08-18 18:01:24.000000000 +0200
+@@ -611,9 +611,10 @@
+ else
+ #endif
+ if (strcasecmp(rcopts[i].name, "tabsize") == 0) {
+- if (!parse_num(option, &tabsize) || tabsize <= 0)
++ if (!parse_num(option, &tabsize) || tabsize <= 0) {
+ rcfile_error(N_("Requested tab size %s invalid"), option);
+ tabsize = -1;
++ }
+ }
+ } else
+ SET(rcopts[i].flag);
diff --git a/app-editors/nano/nano-1.3.4.ebuild b/app-editors/nano/nano-1.3.4.ebuild
index 20ce001d2815..a59776987978 100644
--- a/app-editors/nano/nano-1.3.4.ebuild
+++ b/app-editors/nano/nano-1.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.3.4.ebuild,v 1.1 2004/08/18 04:09:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.3.4.ebuild,v 1.2 2004/08/18 19:07:51 vapier Exp $
inherit eutils
@@ -24,6 +24,7 @@ S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
cd ${S}
+ epatch ${FILESDIR}/${PV}-nanobrack.patch
use nomac && epatch ${FILESDIR}/${PV}-nomac.patch
}