summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2010-05-11 22:58:10 +0000
committerHarald van Dijk <truedfx@gentoo.org>2010-05-11 22:58:10 +0000
commitba13d1081f602af7dcf4a2600482bb0c0203bc09 (patch)
tree4fc6175a7409707caa52032a5f354bd79b9789b6 /app-editors/nvi
parentstable ppc64, bug 318809 (diff)
downloadgentoo-2-ba13d1081f602af7dcf4a2600482bb0c0203bc09.tar.gz
gentoo-2-ba13d1081f602af7dcf4a2600482bb0c0203bc09.tar.bz2
gentoo-2-ba13d1081f602af7dcf4a2600482bb0c0203bc09.zip
Allow building with DB 4.8.30
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/nvi')
-rw-r--r--app-editors/nvi/ChangeLog5
-rw-r--r--app-editors/nvi/nvi-1.81.6-r3.ebuild24
2 files changed, 23 insertions, 6 deletions
diff --git a/app-editors/nvi/ChangeLog b/app-editors/nvi/ChangeLog
index 27b197f3c13b..d4c0b9b77e25 100644
--- a/app-editors/nvi/ChangeLog
+++ b/app-editors/nvi/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-editors/nvi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nvi/ChangeLog,v 1.75 2010/01/10 18:34:15 truedfx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nvi/ChangeLog,v 1.76 2010/05/11 22:58:10 truedfx Exp $
+
+ 11 May 2010; Harald van Dijk <truedfx@gentoo.org> nvi-1.81.6-r3.ebuild:
+ Allow building with DB 4.8.30
10 Jan 2010; Harald van Dijk <truedfx@gentoo.org> nvi-1.81.6-r2.ebuild,
nvi-1.81.6-r3.ebuild:
diff --git a/app-editors/nvi/nvi-1.81.6-r3.ebuild b/app-editors/nvi/nvi-1.81.6-r3.ebuild
index 06d8fa72c717..ba8d0e7be5dc 100644
--- a/app-editors/nvi/nvi-1.81.6-r3.ebuild
+++ b/app-editors/nvi/nvi-1.81.6-r3.ebuild
@@ -1,10 +1,24 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nvi/nvi-1.81.6-r3.ebuild,v 1.4 2010/01/10 18:34:15 truedfx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nvi/nvi-1.81.6-r3.ebuild,v 1.5 2010/05/11 22:58:10 truedfx Exp $
+
+EAPI=1
inherit autotools db-use eutils flag-o-matic
-DBVERS="4.7 4.6 4.5 4.4 4.3 4.2"
+DBVERS="4.8.30 4.7 4.6 4.5 4.4 4.3 4.2"
+DBSLOTS=
+DBDEPENDS=
+for DBVER in ${DBVERS}
+do
+ if [[ ${DBVER} = *.*.* ]]; then
+ DBSLOTS="${DBSLOTS} ${DBVER%.*}"
+ DBDEPENDS="${DBDEPENDS} >=sys-libs/db-${DBVER}:${DBVER%.*}"
+ else
+ DBSLOTS="${DBSLOTS} ${DBVER}"
+ DBDEPENDS="${DBDEPENDS} sys-libs/db:${DBVER}"
+ fi
+done
DESCRIPTION="Vi clone"
HOMEPAGE="http://www.bostic.com/vi/"
@@ -15,7 +29,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="perl tcl unicode"
-DEPEND="|| ( $(printf "=sys-libs/db-%s*\n" ${DBVERS}) )
+DEPEND="|| ( ${DBDEPENDS} )
perl? ( dev-lang/perl )
tcl? ( !unicode? ( >=dev-lang/tcl-8.5 ) )"
RDEPEND="${DEPEND}
@@ -40,8 +54,8 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-perl-shortnames.patch
cd ../dist || die
chmod +x findconfig || die
- append-flags -I"$(db_includedir ${DBVERS})"
- sed -i -e "s@-ldb@-l$(db_libname ${DBVERS})@" configure.in || die
+ append-flags -I"$(db_includedir ${DBSLOTS})"
+ sed -i -e "s@-ldb@-l$(db_libname ${DBSLOTS})@" configure.in || die
rm -f configure || die
eautoreconf -Im4
}