summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2009-01-11 00:29:39 +0000
committerHarald van Dijk <truedfx@gentoo.org>2009-01-11 00:29:39 +0000
commitbb5e0d8bdc69bf833e3541674a53e7666835ad95 (patch)
treed61995a00629631eb1fec8d3569129c16683a411 /app-editors/ted/ted-2.17-r1.ebuild
parentstable sparc, bug 253234 (diff)
downloadgentoo-2-bb5e0d8bdc69bf833e3541674a53e7666835ad95.tar.gz
gentoo-2-bb5e0d8bdc69bf833e3541674a53e7666835ad95.tar.bz2
gentoo-2-bb5e0d8bdc69bf833e3541674a53e7666835ad95.zip
Regenerate all configure scripts to fix locale issues
(Portage version: 2.2_rc20/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'app-editors/ted/ted-2.17-r1.ebuild')
-rw-r--r--app-editors/ted/ted-2.17-r1.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/app-editors/ted/ted-2.17-r1.ebuild b/app-editors/ted/ted-2.17-r1.ebuild
index a15fbd8ac263..7a9fc4d902ab 100644
--- a/app-editors/ted/ted-2.17-r1.ebuild
+++ b/app-editors/ted/ted-2.17-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ted-2.17-r1.ebuild,v 1.2 2008/09/14 16:41:30 truedfx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ted-2.17-r1.ebuild,v 1.3 2009/01/11 00:29:39 truedfx Exp $
inherit autotools
@@ -26,14 +26,17 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${P}-motif.patch
- cd "${S}"/appFrame
- eautoreconf
+ local configure
+ for configure in $(find . -name configure.in)
+ do
+ pushd "$(dirname "${configure}")" >/dev/null || die
+ eautoreconf
+ popd >/dev/null || die
+ done
- cd "${S}"/Ted
- eautoreconf
sed -i \
-e 's@^CFLAGS=@CFLAGS= -DDOCUMENT_DIR=\\"/usr/share/doc/${PF}/\\"@' \
- makefile.in
+ Ted/makefile.in || die "sed failed"
}
src_compile() {