summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-10-27 22:52:30 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-10-27 22:52:30 +0000
commitfe303aeb25ba195008e46fc56663c2b4ab27e2e2 (patch)
treeab0add5e4e63efc4e762a360958ec4a2ab93d698 /app-editors/vim
parentMasked new vim ebuilds that use the eclass (diff)
downloadgentoo-2-fe303aeb25ba195008e46fc56663c2b4ab27e2e2.tar.gz
gentoo-2-fe303aeb25ba195008e46fc56663c2b4ab27e2e2.tar.bz2
gentoo-2-fe303aeb25ba195008e46fc56663c2b4ab27e2e2.zip
Added vim ebuilds that support the vim eclass
Diffstat (limited to 'app-editors/vim')
-rw-r--r--app-editors/vim/ChangeLog8
-rw-r--r--app-editors/vim/files/digest-vim-6.1-r162
-rw-r--r--app-editors/vim/vim-6.1-r16.ebuild51
3 files changed, 60 insertions, 1 deletions
diff --git a/app-editors/vim/ChangeLog b/app-editors/vim/ChangeLog
index d7296d589704..63b8434b65d0 100644
--- a/app-editors/vim/ChangeLog
+++ b/app-editors/vim/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/vim
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.23 2002/10/09 05:17:35 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.24 2002/10/27 22:52:29 rphillips Exp $
+
+*vim-6.1-r16.ebuild (27 Oct 2002)
+
+ 27 Oct 2002; Ryan Phillips <rphillips@gentoo.org> vim-6.1-r16.ebuild :
+
+ Added vim eclass support
*vim-6.1-r15.ebuild (8 Oct 2002)
diff --git a/app-editors/vim/files/digest-vim-6.1-r16 b/app-editors/vim/files/digest-vim-6.1-r16
new file mode 100644
index 000000000000..bb72db297329
--- /dev/null
+++ b/app-editors/vim/files/digest-vim-6.1-r16
@@ -0,0 +1,2 @@
+MD5 7fd0f915adc7c0dab89772884268b030 vim-6.1.tar.bz2 2890049
+MD5 3b5a00da4fec4f3e5cbd3fba9940d153 vimpatch-1-213.tar.bz2 158015
diff --git a/app-editors/vim/vim-6.1-r16.ebuild b/app-editors/vim/vim-6.1-r16.ebuild
new file mode 100644
index 000000000000..adf356fcdf98
--- /dev/null
+++ b/app-editors/vim/vim-6.1-r16.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-6.1-r16.ebuild,v 1.1 2002/10/27 22:52:29 rphillips Exp $
+
+inherit vim
+
+DESCRIPTION="Vi IMproved!"
+
+src_compile() {
+ local myconf
+ myconf="--without-x"
+ use nls && myconf="$myconf --enable-multibyte"
+ use nls || myconf="$myconf --disable-nls"
+ use perl && myconf="$myconf --enable-perlinterp"
+ use python && myconf="$myconf --enable-pythoninterp"
+ use ruby && myconf="$myconf --enable-rubyinterp"
+
+# tclinterp is BROKEN. See note above DEPEND=
+# use tcltk && myconf="$myconf --enable-tclinterp"
+
+# Added back gpm for temporary will remove if necessary, I think that I have
+# fixed most of gpm so it should be fine.
+ use gpm || myconf="$myconf --disable-gpm"
+
+ # This should fix a sandbox violation.
+ addwrite "${SSH_TTY}"
+
+ #
+ # Build a nogui version, this will install as /usr/bin/vim
+ #
+ ./configure \
+ --prefix=/usr --mandir=/usr/share/man --host=$CHOST \
+ --with-features=huge --with-cscope $myconf \
+ --enable-gui=no \
+ || die "vim configure failed"
+ # Parallel make does not work
+ make || die "vim make failed"
+}
+
+src_install() {
+ dobin src/vim
+ ln -s vim ${D}/usr/bin/vimdiff
+ # Default vimrc
+ insinto /usr/share/vim
+ doins ${FILESDIR}/vimrc
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "gvim has now a seperate ebuild, 'emerge gvim' will install gvim"
+}