summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-27 22:22:00 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-27 22:22:00 +0000
commit3e332a62c7e50fcf435825ddb60322be03678f28 (patch)
treef63e73226d6099d94d47fb9e542889283db2f68f /app-editors/xemacs-gtk
parenttouch the libc (Manifest recommit) (diff)
downloadgentoo-2-3e332a62c7e50fcf435825ddb60322be03678f28.tar.gz
gentoo-2-3e332a62c7e50fcf435825ddb60322be03678f28.tar.bz2
gentoo-2-3e332a62c7e50fcf435825ddb60322be03678f28.zip
touch the libc
Diffstat (limited to 'app-editors/xemacs-gtk')
-rw-r--r--app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r2.ebuild23
-rw-r--r--app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r3.ebuild22
2 files changed, 16 insertions, 29 deletions
diff --git a/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r2.ebuild b/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r2.ebuild
index 3ee9298491c5..d2ea272fac72 100644
--- a/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r2.ebuild
+++ b/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r2.ebuild
@@ -1,32 +1,31 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r2.ebuild,v 1.16 2004/06/24 22:04:01 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r2.ebuild,v 1.17 2004/06/27 22:21:35 vapier Exp $
inherit eutils
-IUSE="gpm postgres xface tiff gtk jpeg mule nas esd X png gnome"
-
# this is just TEMPORARY until we can get to the core of the problem
SANDBOX_DISABLED="1"
-
REAL_P=${P//-gtk/}
S="${WORKDIR}/${REAL_P}"
-DESCRIPTION="highly customizable text editor and application development system"
-
EFS=1.29
BASE=1.63
MULE=1.40
-
+DESCRIPTION="highly customizable text editor and application development system"
+HOMEPAGE="http://www.xemacs.org"
SRC_URI="http://ftp.xemacs.org/xemacs-21.4/${REAL_P}.tar.gz
http://ftp.xemacs.org/pub/packages/efs-${EFS}-pkg.tar.gz
http://ftp.xemacs.org/pub/packages/xemacs-base-${BASE}-pkg.tar.gz
http://ftp.xemacs.org/packages/mule-base-${MULE}-pkg.tar.gz"
-HOMEPAGE="http://www.xemacs.org"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 sparc"
+IUSE="gpm postgres xface tiff gtk jpeg mule nas esd X png gnome"
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
!virtual/xemacs
>=sys-libs/gdbm-1.8.0
@@ -49,16 +48,10 @@ RDEPEND="virtual/glibc
jpeg? ( media-libs/jpeg )
X? ( virtual/x11 )"
-
DEPEND="${RDEPEND}
>=sys-libs/ncurses-5.2"
-
PROVIDE="virtual/xemacs"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 sparc "
-
src_unpack() {
cd ${WORKDIR}
unpack ${REAL_P}.tar.gz
diff --git a/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r3.ebuild b/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r3.ebuild
index 6abc87fa6490..918a46288215 100644
--- a/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r3.ebuild
+++ b/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r3.ebuild
@@ -1,31 +1,31 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r3.ebuild,v 1.18 2004/06/24 22:04:01 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r3.ebuild,v 1.19 2004/06/27 22:21:35 vapier Exp $
inherit eutils
-IUSE="gpm postgres xface tiff gtk jpeg mule nas esd X png gnome"
-
# this is just TEMPORARY until we can get to the core of the problem
SANDBOX_DISABLED="1"
REAL_P=${P//-gtk/}
S="${WORKDIR}/${REAL_P}"
-DESCRIPTION="highly customizable text editor and application development system"
-
EFS=1.29
BASE=1.66
MULE=1.42
-
+DESCRIPTION="highly customizable text editor and application development system"
+HOMEPAGE="http://www.xemacs.org/"
SRC_URI="http://ftp.xemacs.org/xemacs-21.4/${REAL_P}.tar.gz
http://ftp.xemacs.org/pub/packages/efs-${EFS}-pkg.tar.gz
http://ftp.xemacs.org/pub/packages/xemacs-base-${BASE}-pkg.tar.gz
http://ftp.xemacs.org/packages/mule-base-${MULE}-pkg.tar.gz"
-HOMEPAGE="http://www.xemacs.org"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 sparc"
+IUSE="gpm postgres xface tiff gtk jpeg mule nas esd X png gnome"
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
!virtual/xemacs
>=sys-libs/gdbm-1.8.0
@@ -48,16 +48,10 @@ RDEPEND="virtual/glibc
jpeg? ( media-libs/jpeg )
X? ( virtual/x11 )"
-
DEPEND="${RDEPEND}
>=sys-libs/ncurses-5.2"
-
PROVIDE="virtual/xemacs"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 sparc "
-
src_unpack() {
cd ${WORKDIR}
unpack ${REAL_P}.tar.gz