summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-04-30 20:53:34 +0000
committerTim Harder <radhermit@gentoo.org>2011-04-30 20:53:34 +0000
commit26f1829eb82104609afaa446802a30cfdd72ea4b (patch)
tree9752c5db700ba1abccb7a77b99061f6be332940b /app-editors/xvile
parentBackport sdbox patch - bug #365445. Thanks to Kerin Millar. (diff)
downloadgentoo-2-26f1829eb82104609afaa446802a30cfdd72ea4b.tar.gz
gentoo-2-26f1829eb82104609afaa446802a30cfdd72ea4b.tar.bz2
gentoo-2-26f1829eb82104609afaa446802a30cfdd72ea4b.zip
Version bump. Update to EAPI 4.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/xvile')
-rw-r--r--app-editors/xvile/ChangeLog9
-rw-r--r--app-editors/xvile/xvile-9.8e.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/app-editors/xvile/ChangeLog b/app-editors/xvile/ChangeLog
index b1132e04e549..8db198f13f5f 100644
--- a/app-editors/xvile/ChangeLog
+++ b/app-editors/xvile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/xvile
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xvile/ChangeLog,v 1.20 2008/06/29 19:34:26 hawking Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xvile/ChangeLog,v 1.21 2011/04/30 20:53:34 radhermit Exp $
+
+*xvile-9.8e (30 Apr 2011)
+
+ 30 Apr 2011; Tim Harder <radhermit@gentoo.org> +xvile-9.8e.ebuild:
+ Version bump. Update to EAPI 4.
*xvile-9.6 (29 Jun 2008)
diff --git a/app-editors/xvile/xvile-9.8e.ebuild b/app-editors/xvile/xvile-9.8e.ebuild
new file mode 100644
index 000000000000..3769b6d0871b
--- /dev/null
+++ b/app-editors/xvile/xvile-9.8e.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xvile/xvile-9.8e.ebuild,v 1.1 2011/04/30 20:53:34 radhermit Exp $
+
+EAPI=4
+
+inherit eutils versionator
+
+MY_P="${PN/x/}-${PV}"
+DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
+HOMEPAGE="http://invisible-island.net/vile/"
+SRC_URI="ftp://invisible-island.net/vile/current/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="perl"
+
+RDEPEND="perl? ( dev-lang/perl )
+ =app-editors/vile-${PV}
+ >=x11-libs/libX11-1.0.0
+ >=x11-libs/libXt-1.0.0
+ >=x11-libs/libICE-1.0.0
+ >=x11-libs/libSM-1.0.0
+ >=x11-libs/libXaw-1.0.1
+ >=x11-libs/libXpm-3.5.4.2
+ >=x11-proto/xproto-7.0.4"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf \
+ --with-ncurses \
+ --with-x \
+ $(use_with perl)
+}
+
+src_install() {
+ dobin xvile
+ dodoc CHANGES* README doc/*.doc
+ dohtml doc/*.html
+}