summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-12-13 22:02:55 +0000
committerTim Harder <radhermit@gentoo.org>2011-12-13 22:02:55 +0000
commitc71fb396159f436b79f82159120d3d219d87c21e (patch)
tree5cb25b1e0b369afbb1bc7692176bc14cf4909a98 /app-editors/xvile
parentRemove unnecessary eutils eclass. (diff)
downloadgentoo-2-c71fb396159f436b79f82159120d3d219d87c21e.tar.gz
gentoo-2-c71fb396159f436b79f82159120d3d219d87c21e.tar.bz2
gentoo-2-c71fb396159f436b79f82159120d3d219d87c21e.zip
Version bump.
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/xvile')
-rw-r--r--app-editors/xvile/ChangeLog7
-rw-r--r--app-editors/xvile/xvile-9.8f.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/app-editors/xvile/ChangeLog b/app-editors/xvile/ChangeLog
index e340effbdd7d..efb3db2db7df 100644
--- a/app-editors/xvile/ChangeLog
+++ b/app-editors/xvile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/xvile
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xvile/ChangeLog,v 1.22 2011/10/17 07:32:51 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xvile/ChangeLog,v 1.23 2011/12/13 22:02:55 radhermit Exp $
+
+*xvile-9.8f (13 Dec 2011)
+
+ 13 Dec 2011; Tim Harder <radhermit@gentoo.org> +xvile-9.8f.ebuild:
+ Version bump.
17 Oct 2011; Tim Harder <radhermit@gentoo.org> -xvile-9.4d-r1.ebuild,
-xvile-9.6.ebuild:
diff --git a/app-editors/xvile/xvile-9.8f.ebuild b/app-editors/xvile/xvile-9.8f.ebuild
new file mode 100644
index 000000000000..dd91c477d151
--- /dev/null
+++ b/app-editors/xvile/xvile-9.8f.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xvile/xvile-9.8f.ebuild,v 1.1 2011/12/13 22:02:55 radhermit Exp $
+
+EAPI="4"
+
+inherit versionator
+
+MY_P="${PN/x/}-${PV}"
+DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
+HOMEPAGE="http://invisible-island.net/vile/"
+SRC_URI="ftp://invisible-island.net/vile/current/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="perl"
+
+RDEPEND="perl? ( dev-lang/perl )
+ =app-editors/vile-${PV}
+ >=x11-libs/libX11-1.0.0
+ >=x11-libs/libXt-1.0.0
+ >=x11-libs/libICE-1.0.0
+ >=x11-libs/libSM-1.0.0
+ >=x11-libs/libXaw-1.0.1
+ >=x11-libs/libXpm-3.5.4.2
+ >=x11-proto/xproto-7.0.4"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf \
+ --with-ncurses \
+ --with-x \
+ $(use_with perl)
+}
+
+src_install() {
+ dobin xvile
+ dodoc CHANGES* README doc/*.doc
+ dohtml doc/*.html
+}