summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-10-08 11:44:36 +0000
committerUlrich Müller <ulm@gentoo.org>2011-10-08 11:44:36 +0000
commit79d2b2359e8a43c0052d7811518db16bf4ce26e2 (patch)
tree1855ad6014137e957a8ec8c10fe081a79cb10d75 /app-editors/zile
parentMissing USE="opengl" depend for x11-libs/fltk:1 wrt #385499 by Eric F. GARIOUD (diff)
downloadgentoo-2-79d2b2359e8a43c0052d7811518db16bf4ce26e2.tar.gz
gentoo-2-79d2b2359e8a43c0052d7811518db16bf4ce26e2.tar.bz2
gentoo-2-79d2b2359e8a43c0052d7811518db16bf4ce26e2.zip
Version bump. Drop livecd USE flag.
(Portage version: 2.1.10.23/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/zile')
-rw-r--r--app-editors/zile/ChangeLog7
-rw-r--r--app-editors/zile/zile-2.4.1.ebuild10
-rw-r--r--app-editors/zile/zile-2.4.2.ebuild39
3 files changed, 47 insertions, 9 deletions
diff --git a/app-editors/zile/ChangeLog b/app-editors/zile/ChangeLog
index 498a51e2f331..018f9611b487 100644
--- a/app-editors/zile/ChangeLog
+++ b/app-editors/zile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/zile
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/ChangeLog,v 1.154 2011/09/26 17:46:57 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/ChangeLog,v 1.155 2011/10/08 11:44:36 ulm Exp $
+
+*zile-2.4.2 (08 Oct 2011)
+
+ 08 Oct 2011; Ulrich Mueller <ulm@gentoo.org> +zile-2.4.2.ebuild:
+ Version bump. Drop livecd USE flag.
26 Sep 2011; Fabian Groffen <grobian@gentoo.org> zile-2.4.1.ebuild:
Fix docdir for Prefix
diff --git a/app-editors/zile/zile-2.4.1.ebuild b/app-editors/zile/zile-2.4.1.ebuild
index 341dc55ba854..619e31bdde64 100644
--- a/app-editors/zile/zile-2.4.1.ebuild
+++ b/app-editors/zile/zile-2.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/zile-2.4.1.ebuild,v 1.3 2011/09/26 17:46:57 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/zile-2.4.1.ebuild,v 1.4 2011/10/08 11:44:36 ulm Exp $
EAPI=4
@@ -11,7 +11,7 @@ SRC_URI="mirror://gnu/zile/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-IUSE="acl livecd test valgrind"
+IUSE="acl test valgrind"
RDEPEND="dev-libs/boehm-gc
sys-libs/ncurses
@@ -37,9 +37,3 @@ src_install() {
# Zile should never install charset.alias (even on non-glibc arches)
rm -f "${ED}"/usr/lib/charset.alias
}
-
-pkg_postinst() {
- if use livecd; then
- [[ -e ${EROOT}/usr/bin/emacs ]] || ln -s zile "${EROOT}"/usr/bin/emacs
- fi
-}
diff --git a/app-editors/zile/zile-2.4.2.ebuild b/app-editors/zile/zile-2.4.2.ebuild
new file mode 100644
index 000000000000..a8e70814ae15
--- /dev/null
+++ b/app-editors/zile/zile-2.4.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/zile-2.4.2.ebuild,v 1.1 2011/10/08 11:44:36 ulm Exp $
+
+EAPI=4
+
+DESCRIPTION="Zile is a small Emacs clone"
+HOMEPAGE="http://www.gnu.org/software/zile/"
+SRC_URI="mirror://gnu/zile/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="acl test valgrind"
+
+RDEPEND="dev-libs/boehm-gc
+ sys-libs/ncurses
+ acl? ( virtual/acl )"
+
+DEPEND="${RDEPEND}
+ test? ( valgrind? ( dev-util/valgrind ) )"
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --disable-silent-rules \
+ $(use_enable acl) \
+ $(use test && use_with valgrind || echo --without-valgrind)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # AUTHORS, FAQ, and NEWS are installed by the build system
+ dodoc README THANKS
+
+ # Zile should never install charset.alias (even on non-glibc arches)
+ rm -f "${ED}"/usr/lib/charset.alias
+}