summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-09-25 15:56:32 +0000
committerUlrich Müller <ulm@gentoo.org>2011-09-25 15:56:32 +0000
commitf68038b14411162670123aff4cd0d5b79a2dbeee (patch)
tree36581fca4e1da7efc5ed17be7623d53c6bbafbed /app-editors/zile
parentRemove negation from ipset module check. (diff)
downloadgentoo-2-f68038b14411162670123aff4cd0d5b79a2dbeee.tar.gz
gentoo-2-f68038b14411162670123aff4cd0d5b79a2dbeee.tar.bz2
gentoo-2-f68038b14411162670123aff4cd0d5b79a2dbeee.zip
Version bump. All BSD and Interix beywords dropped because of new dependency on dev-libs/boehm-gc.
(Portage version: 2.1.10.19/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/zile')
-rw-r--r--app-editors/zile/ChangeLog8
-rw-r--r--app-editors/zile/zile-2.4.1.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/app-editors/zile/ChangeLog b/app-editors/zile/ChangeLog
index f799796ca650..22056c292ec4 100644
--- a/app-editors/zile/ChangeLog
+++ b/app-editors/zile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/zile
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/ChangeLog,v 1.151 2011/09/24 17:18:28 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/ChangeLog,v 1.152 2011/09/25 15:56:32 ulm Exp $
+
+*zile-2.4.1 (25 Sep 2011)
+
+ 25 Sep 2011; Ulrich Mueller <ulm@gentoo.org> +zile-2.4.1.ebuild:
+ Version bump. All BSD and Interix beywords dropped because of new dependency
+ on dev-libs/boehm-gc.
24 Sep 2011; Raúl Porcel <armin76@gentoo.org> zile-2.3.24-r1.ebuild:
alpha/sparc stable wrt #382597
diff --git a/app-editors/zile/zile-2.4.1.ebuild b/app-editors/zile/zile-2.4.1.ebuild
new file mode 100644
index 000000000000..e3c3ed9b14a2
--- /dev/null
+++ b/app-editors/zile/zile-2.4.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/zile-2.4.1.ebuild,v 1.1 2011/09/25 15:56:32 ulm Exp $
+
+EAPI=4
+
+DESCRIPTION="Zile is a small Emacs clone"
+HOMEPAGE="http://www.gnu.org/software/zile/"
+SRC_URI="mirror://gnu/zile/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="acl livecd test valgrind"
+
+RDEPEND="dev-libs/boehm-gc
+ sys-libs/ncurses
+ acl? ( virtual/acl )"
+
+DEPEND="${RDEPEND}
+ test? ( valgrind? ( dev-util/valgrind ) )"
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ --disable-silent-rules \
+ $(use_enable acl) \
+ $(use test && use_with valgrind || echo --without-valgrind)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # AUTHORS, FAQ, and NEWS are installed by the build system
+ dodoc README THANKS
+
+ # Zile should never install charset.alias (even on non-glibc arches)
+ rm -f "${ED}"/usr/lib/charset.alias
+}
+
+pkg_postinst() {
+ if use livecd; then
+ [[ -e ${EROOT}/usr/bin/emacs ]] || ln -s zile "${EROOT}"/usr/bin/emacs
+ fi
+}