summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-04-02 14:40:18 +0000
committerAron Griffis <agriffis@gentoo.org>2003-04-02 14:40:18 +0000
commit66e6f7527eab9164d26c50f6eb0ec73728b01c62 (patch)
treeca4bb6eba41e7f340878075f3125aefecfe38520 /app-editors
parentfix bug 18488 (diff)
downloadgentoo-2-66e6f7527eab9164d26c50f6eb0ec73728b01c62.tar.gz
gentoo-2-66e6f7527eab9164d26c50f6eb0ec73728b01c62.tar.bz2
gentoo-2-66e6f7527eab9164d26c50f6eb0ec73728b01c62.zip
move primary deps to eclass and add IUSE=ncurses
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gvim/gvim-6.1-r8.ebuild18
-rw-r--r--app-editors/vim-core/vim-core-6.1-r5.ebuild11
-rw-r--r--app-editors/vim/vim-6.1-r21.ebuild14
3 files changed, 12 insertions, 31 deletions
diff --git a/app-editors/gvim/gvim-6.1-r8.ebuild b/app-editors/gvim/gvim-6.1-r8.ebuild
index 5041b74ea4c1..457d0d86c2da 100644
--- a/app-editors/gvim/gvim-6.1-r8.ebuild
+++ b/app-editors/gvim/gvim-6.1-r8.ebuild
@@ -1,25 +1,19 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-6.1-r8.ebuild,v 1.1 2003/03/23 20:36:26 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-6.1-r8.ebuild,v 1.2 2003/04/02 14:40:18 agriffis Exp $
-IUSE="gnome gpm gtk gtk2 nls perl python ruby X"
+IUSE="gnome gpm gtk gtk2 ncurses nls perl python ruby X"
VIMPATCH="411"
inherit vim
DESCRIPTION="Graphical Vim"
KEYWORDS="x86 ~ppc ~sparc alpha"
-DEPEND="dev-util/cscope
- >=sys-libs/ncurses-5.2-r2
+DEPEND="${DEPEND}
>=app-editors/vim-core-6.1-r5
x11-base/xfree
- gpm? ( >=sys-libs/gpm-1.19.3 )
- gnome? ( gnome-base/gnome-libs )
- gtk? ( =x11-libs/gtk+-1.2* )
- gtk2? ( >=x11-libs/gtk+-2.1
- virtual/xft )
- perl? ( dev-lang/perl )
- python? ( dev-lang/python )
- ruby? ( >=dev-lang/ruby-1.6.4 )"
+ gtk2? ( >=x11-libs/gtk+-2.1 virtual/xft ) :
+ ( gnome? ( gnome-base/gnome-libs ) :
+ ( gtk? ( =x11-libs/gtk+-1.2* ) ) )"
src_unpack() {
vim_src_unpack
diff --git a/app-editors/vim-core/vim-core-6.1-r5.ebuild b/app-editors/vim-core/vim-core-6.1-r5.ebuild
index 9a9055bb4173..2120679c565a 100644
--- a/app-editors/vim-core/vim-core-6.1-r5.ebuild
+++ b/app-editors/vim-core/vim-core-6.1-r5.ebuild
@@ -1,17 +1,10 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/vim-core-6.1-r5.ebuild,v 1.2 2003/03/28 16:51:25 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/vim-core-6.1-r5.ebuild,v 1.3 2003/04/02 14:40:04 agriffis Exp $
-IUSE="gpm nls perl python ruby"
+IUSE="ncurses gpm nls perl python ruby"
VIMPATCH="411"
inherit vim
DESCRIPTION="vim, gvim and kvim shared files"
KEYWORDS="x86 ~ppc sparc alpha ~hppa ~arm ~mips"
-DEPEND="dev-util/cscope
- sys-libs/libtermcap-compat
- >=sys-libs/ncurses-5.2-r2
- gpm? ( >=sys-libs/gpm-1.19.3 )
- perl? ( dev-lang/perl )
- python? ( dev-lang/python )
- ruby? ( >=dev-lang/ruby-1.6.4 )"
diff --git a/app-editors/vim/vim-6.1-r21.ebuild b/app-editors/vim/vim-6.1-r21.ebuild
index 7aae61ba942d..6051a7ee39ad 100644
--- a/app-editors/vim/vim-6.1-r21.ebuild
+++ b/app-editors/vim/vim-6.1-r21.ebuild
@@ -1,20 +1,14 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-6.1-r21.ebuild,v 1.2 2003/03/28 16:51:45 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-6.1-r21.ebuild,v 1.3 2003/04/02 14:39:45 agriffis Exp $
-IUSE="gpm nls perl python ruby tcltk X"
+IUSE="gpm ncurses nls perl python ruby tcltk X"
VIMPATCH="411"
inherit vim
DESCRIPTION="Vi IMproved!"
KEYWORDS="x86 ~ppc sparc alpha ~hppa ~arm ~mips"
-DEPEND=">=app-editors/vim-core-6.1-r5
- sys-libs/libtermcap-compat
- dev-util/cscope
- >=sys-libs/ncurses-5.2-r2
- gpm? ( >=sys-libs/gpm-1.19.3 )
- perl? ( dev-lang/perl )
- python? ( dev-lang/python )
- ruby? ( >=dev-lang/ruby-1.6.4 )"
+DEPEND="${DEPEND}
+ >=app-editors/vim-core-6.1-r5"
PROVIDE="virtual/editor"