summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2004-07-08 22:04:17 +0000
committerRob Cakebread <pythonhead@gentoo.org>2004-07-08 22:04:17 +0000
commit6a3c5fa5aaadf198db23fc2012faede6e0482860 (patch)
tree9a6b630668c5a37d59cf64009ec97cba3ac72736 /app-editors
parentFixed IUSE for lua (Manifest recommit) (diff)
downloadgentoo-2-6a3c5fa5aaadf198db23fc2012faede6e0482860.tar.gz
gentoo-2-6a3c5fa5aaadf198db23fc2012faede6e0482860.tar.bz2
gentoo-2-6a3c5fa5aaadf198db23fc2012faede6e0482860.zip
Added DEPEND for dev-lang/lua scripting support
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/scite/ChangeLog5
-rw-r--r--app-editors/scite/Manifest4
-rw-r--r--app-editors/scite/scite-1.6.1.ebuild22
3 files changed, 16 insertions, 15 deletions
diff --git a/app-editors/scite/ChangeLog b/app-editors/scite/ChangeLog
index 08efc69fe64e..153c0bb5e4c4 100644
--- a/app-editors/scite/ChangeLog
+++ b/app-editors/scite/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-editors/scite
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.25 2004/07/08 22:01:45 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.26 2004/07/08 22:04:17 pythonhead Exp $
+
+ 08 Jul 2004; Rob Cakebread <pythonhead@gentoo.org> scite-1.6.1.ebuild:
+ Added DEPEND for dev-lang/lua scripting support
08 Jul 2004; Rob Cakebread <pythonhead@gentoo.org> scite-1.6.0.ebuild:
Fixed IUSE for lua
diff --git a/app-editors/scite/Manifest b/app-editors/scite/Manifest
index 691308e9a13b..52d741965222 100644
--- a/app-editors/scite/Manifest
+++ b/app-editors/scite/Manifest
@@ -1,4 +1,4 @@
-MD5 00920dd559cbf71d7a7ce68a6e1f753f ChangeLog 3958
+MD5 24d9a4f5a7e8d63d5af9a377e08cadb6 ChangeLog 4082
MD5 4eb1abff335478b86f5c65997e0148f2 metadata.xml 222
MD5 196130e113f6c0f3cae649e4540f4a01 scite-1.4.9.ebuild 1330
MD5 4455a7dabc3c7c06b37513b256b35014 scite-1.5.6.ebuild 1669
@@ -6,7 +6,7 @@ MD5 43af54308e60210a0782e923f79fb579 scite-1.5.7.ebuild 1853
MD5 72e86e2b16e722d9e7a9e5f8d4ecc009 scite-1.5.8.ebuild 1854
MD5 a5913744b2a8e8db1cfa4f2e239d2a57 scite-1.5.9.ebuild 1855
MD5 1e61a964242267d3ce02ee24d274bfe7 scite-1.6.0.ebuild 1885
-MD5 80043dabaab220f76b8c2794e1e8d996 scite-1.6.1.ebuild 1855
+MD5 d3af90c044ef85d7e615f65764d49344 scite-1.6.1.ebuild 1783
MD5 e21b1647de51e2cea2682beaf5522ea7 files/digest-scite-1.4.9 57
MD5 80608721073d877a62ab114df64994fe files/digest-scite-1.5.6 57
MD5 db1df48699c3abfa8938d151233eaefc files/digest-scite-1.5.7 57
diff --git a/app-editors/scite/scite-1.6.1.ebuild b/app-editors/scite/scite-1.6.1.ebuild
index eb795a1ee887..b20e8bfecfed 100644
--- a/app-editors/scite/scite-1.6.1.ebuild
+++ b/app-editors/scite/scite-1.6.1.ebuild
@@ -1,24 +1,21 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/scite-1.6.1.ebuild,v 1.3 2004/06/30 02:34:38 agriffis Exp $
-
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/scite-1.6.1.ebuild,v 1.4 2004/07/08 22:04:17 pythonhead Exp $
MY_PV=$(echo ${PV} | sed 's:\.::g')
+S=${WORKDIR}/${PN}/gtk
DESCRIPTION="A very powerful editor for programmers"
-SRC_URI="mirror://sourceforge/scintilla/${PN}${MY_PV}.tgz"
HOMEPAGE="http://www.scintilla.org"
-
-DEPEND="gtk2? ( >=x11-libs/gtk+-2 )
- !gtk2? ( =x11-libs/gtk+-1.2* )
- >=sys-apps/sed-4"
-
-S=${WORKDIR}/${PN}/gtk
-
-SLOT="0"
+SRC_URI="mirror://sourceforge/scintilla/${PN}${MY_PV}.tgz"
LICENSE="PYTHON"
+SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc"
-IUSE="gtk2"
+IUSE="gtk2 lua"
+DEPEND="gtk2? ( >=x11-libs/gtk+-2 )
+ !gtk2? ( =x11-libs/gtk+-1.2* )
+ >=sys-apps/sed-4
+ lua? ( >=dev-lang/lua-5 )"
src_unpack() {
unpack ${A}
@@ -72,3 +69,4 @@ src_install () {
dodoc ../License.txt ../README
}
+