summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-10-05 11:38:33 +0000
committerUlrich Müller <ulm@gentoo.org>2008-10-05 11:38:33 +0000
commit9bc9a331ca63a9f7f5659f17242aae197094ef93 (patch)
tree570cc5e5b22f2e3fa1396f6c70c446234f2b4e78 /app-editors
parentAdd missing build-time dependency over texi2html. (diff)
downloadgentoo-2-9bc9a331ca63a9f7f5659f17242aae197094ef93.tar.gz
gentoo-2-9bc9a331ca63a9f7f5659f17242aae197094ef93.tar.bz2
gentoo-2-9bc9a331ca63a9f7f5659f17242aae197094ef93.zip
Version bump, fixes bug 239869.
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/jove/ChangeLog7
-rw-r--r--app-editors/jove/jove-4.16.0.70.3.1.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/app-editors/jove/ChangeLog b/app-editors/jove/ChangeLog
index d3ec0644c336..9f7e3a5efe82 100644
--- a/app-editors/jove/ChangeLog
+++ b/app-editors/jove/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/jove
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jove/ChangeLog,v 1.20 2008/07/28 18:49:02 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jove/ChangeLog,v 1.21 2008/10/05 11:38:33 ulm Exp $
+
+*jove-4.16.0.70.3.1 (05 Oct 2008)
+
+ 05 Oct 2008; Ulrich Mueller <ulm@gentoo.org> +jove-4.16.0.70.3.1.ebuild:
+ Version bump, fixes bug 239869.
28 Jul 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/app-editors/jove/jove-4.16.0.70.3.1.ebuild b/app-editors/jove/jove-4.16.0.70.3.1.ebuild
new file mode 100644
index 000000000000..a0efe64196fa
--- /dev/null
+++ b/app-editors/jove/jove-4.16.0.70.3.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jove/jove-4.16.0.70.3.1.ebuild,v 1.1 2008/10/05 11:38:33 ulm Exp $
+
+inherit eutils flag-o-matic versionator
+
+MY_P=${PN}_$(get_version_component_range 1-4)
+MY_DIFFP=${MY_P}-$(get_version_component_range 5-6)
+DESCRIPTION="Jonathan's Own Version of Emacs - a light emacs-like editor without LISP bindings"
+HOMEPAGE="ftp://ftp.cs.toronto.edu/cs/ftp/pub/hugh/jove-dev/"
+SRC_URI="mirror://debian/pool/main/j/${PN}/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/j/${PN}/${MY_DIFFP}.diff.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X unix98"
+
+RDEPEND="sys-libs/ncurses
+ X? ( x11-libs/xview )"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/${MY_P/_/}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}/${MY_DIFFP}.diff"
+
+ sed -i \
+ -e "s:-ltermcap:-lncurses:" \
+ -e "s:^OPTFLAGS =.*:OPTFLAGS = ${CFLAGS}:" \
+ Makefile
+# -e 's:^SYSDEFS =.*:SYSDEFS="-DSYSVR4 -D_XOPEN_SOURCE=500":' \
+}
+
+src_compile() {
+ local myconf
+ if use unix98 ; then
+ emake SYSDEFS="-DSYSVR4 -D_XOPEN_SOURCE=500" || die
+ else
+ emake || die
+ fi
+
+ if use X ; then
+ emake XJOVEHOME=/usr makexjove || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if use X ; then
+ make DESTDIR="${D}" \
+ XJOVEHOME="${D}"/usr \
+ MANDIR="${D}"/usr/share/man/man1 \
+ installxjove || die
+ fi
+
+ keepdir /var/lib/jove/preserve
+}