summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Nall <nall@gentoo.org>2003-01-27 04:58:22 +0000
committerJon Nall <nall@gentoo.org>2003-01-27 04:58:22 +0000
commita4c699ff639cb53360f5ffe36f2344ecad7ef981 (patch)
treed7916de46b45810dd70136f567ea1f3f25c83493 /app-editors
parentuse.mask for PPC (diff)
downloadgentoo-2-a4c699ff639cb53360f5ffe36f2344ecad7ef981.tar.gz
gentoo-2-a4c699ff639cb53360f5ffe36f2344ecad7ef981.tar.bz2
gentoo-2-a4c699ff639cb53360f5ffe36f2344ecad7ef981.zip
fixing bug 14458
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/xemacs/ChangeLog7
-rw-r--r--app-editors/xemacs/files/xemacs-21.4.9-ppc-glibc-2.3.x.diff37
-rw-r--r--app-editors/xemacs/xemacs-21.4.9.ebuild12
3 files changed, 54 insertions, 2 deletions
diff --git a/app-editors/xemacs/ChangeLog b/app-editors/xemacs/ChangeLog
index 12e3fd1d596e..252acd821b8a 100644
--- a/app-editors/xemacs/ChangeLog
+++ b/app-editors/xemacs/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for app-editors/xemacs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/ChangeLog,v 1.31 2003/01/16 15:17:16 rendhalver Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/ChangeLog,v 1.32 2003/01/27 04:58:22 nall Exp $
*xemacs-21.4.12 (16 Jan 2003)
16 Jan 2003: Rendhalver <rendhalver@gentoo.org>
@@ -56,6 +56,11 @@
*xemacs-21.4.9 (26 Sep 2002)
+ 26 Jan 2003; Jon Nall <nall@gentoo.org> files/xemacs-21.4.9-ppc.diff,
+ xemacs-21.4.9.ebuild :
+ added a patch that fixes bug #14458
+ http://sources.redhat.com/ml/bug-glibc/2002-11/msg00066.html
+
16 Oct 2002; Mark Guertin <gerk@gentoo.org> files/xemacs-21.4.9-ppc.diff :
copied this to the new version, it is still needed for this build. closes
bug #9172
diff --git a/app-editors/xemacs/files/xemacs-21.4.9-ppc-glibc-2.3.x.diff b/app-editors/xemacs/files/xemacs-21.4.9-ppc-glibc-2.3.x.diff
new file mode 100644
index 000000000000..3c6d38abcd73
--- /dev/null
+++ b/app-editors/xemacs/files/xemacs-21.4.9-ppc-glibc-2.3.x.diff
@@ -0,0 +1,37 @@
+--- src/alloc.c.orig Mon Dec 17 06:49:22 2001
++++ src/alloc.c Thu Nov 7 00:27:31 2002
+@@ -3882,8 +3890,8 @@
+ #ifdef DOUG_LEA_MALLOC
+ mallopt (M_TRIM_THRESHOLD, 128*1024); /* trim threshold */
+ mallopt (M_MMAP_THRESHOLD, 64*1024); /* mmap threshold */
+-#if 0 /* Moved to emacs.c */
+- mallopt (M_MMAP_MAX, 64); /* max. number of mmap'ed areas */
++#if 1 /* Moved to emacs.c */
++ mallopt (M_MMAP_MAX, 0); /* max. number of mmap'ed areas */
+ #endif
+ #endif
+ init_string_alloc ();
+--- src/emacs.c.orig Thu Oct 31 16:07:36 2002
++++ src/emacs.c Thu Nov 7 00:25:47 2002
+@@ -2713,7 +2713,8 @@
+ if (!initialized)
+ {
+ #ifdef DOUG_LEA_MALLOC
+- mallopt (M_MMAP_MAX, 0);
++ if (mallopt (M_MMAP_MAX, 0) != 1)
++ abort();
+ #endif
+ run_temacs_argc = 0;
+ if (! SETJMP (run_temacs_catch))
+@@ -2770,7 +2771,8 @@
+ defined(_NO_MALLOC_WARNING_) || \
+ (defined(__GLIBC__) && __GLIBC_MINOR__ < 1 && !defined(MULE)) || \
+ defined(DEBUG_DOUG_LEA_MALLOC)
+- mallopt (M_MMAP_MAX, 64);
++ if(mallopt (M_MMAP_MAX, 0) != 1)
++ abort();
+ #endif
+ #ifdef REL_ALLOC
+ r_alloc_reinit ();
+
+
diff --git a/app-editors/xemacs/xemacs-21.4.9.ebuild b/app-editors/xemacs/xemacs-21.4.9.ebuild
index f9185d58b94a..451c8d9f7089 100644
--- a/app-editors/xemacs/xemacs-21.4.9.ebuild
+++ b/app-editors/xemacs/xemacs-21.4.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.9.ebuild,v 1.6 2003/01/07 17:46:30 rendhalver Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.9.ebuild,v 1.7 2003/01/27 04:58:22 nall Exp $
IUSE="gpm esd postgres xface nas X jpeg tiff png mule"
@@ -61,6 +61,16 @@ src_unpack() {
if [ ${ARCH} = "ppc" ] ; then
patch -p0 < ${FILESDIR}/${P}-ppc.diff || die
+
+ # xemacs broke with glibc-2.3.x. this code checks that condition
+ # and patches xemacs appropriately.
+ # http://sources.redhat.com/ml/bug-glibc/2002-11/msg00066.html
+ glibc_version=`/sbin/ldconfig -V | head -1 | sed -e "s/[^0-9]*[0-9]\.//" | sed -e "s/\.//"`
+ if (( $glibc_version >= "31" ))
+ then
+ einfo "PPC runtime fix for glibc >= 2.3.1 (Gentoo bug #14458)"
+ patch -p0 < ${FILESDIR}/${P}-ppc-glibc-2.3.x.diff || die
+ fi
fi
}