summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-08-05 01:40:12 +0000
committerMichael Weber <xmw@gentoo.org>2011-08-05 01:40:12 +0000
commitea89b3f6adab80deb374edbb65c67df3c82889ff (patch)
tree87a0634f1c0befc380253ee38b4e0b9579282dd9 /app-editors
parentVersion bump. (diff)
downloadgentoo-2-ea89b3f6adab80deb374edbb65c67df3c82889ff.tar.gz
gentoo-2-ea89b3f6adab80deb374edbb65c67df3c82889ff.tar.bz2
gentoo-2-ea89b3f6adab80deb374edbb65c67df3c82889ff.zip
Taking maint, revbump with port to gtksourceview:2.0
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/mlview/ChangeLog9
-rw-r--r--app-editors/mlview/files/mlview-0.9.0-r1-10_port_to_gtksourceview2.patch218
-rw-r--r--app-editors/mlview/files/mlview-0.9.0-r1-autoreconf.patch25
-rw-r--r--app-editors/mlview/metadata.xml3
-rw-r--r--app-editors/mlview/mlview-0.9.0-r1.ebuild54
5 files changed, 307 insertions, 2 deletions
diff --git a/app-editors/mlview/ChangeLog b/app-editors/mlview/ChangeLog
index c3ebf3e0b519..0d1e336312a4 100644
--- a/app-editors/mlview/ChangeLog
+++ b/app-editors/mlview/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/mlview
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mlview/ChangeLog,v 1.31 2011/03/21 22:49:04 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mlview/ChangeLog,v 1.32 2011/08/05 01:40:12 xmw Exp $
+
+*mlview-0.9.0-r1 (05 Aug 2011)
+
+ 05 Aug 2011; Michael Weber <xmw@gentoo.org> +mlview-0.9.0-r1.ebuild,
+ +files/mlview-0.9.0-r1-10_port_to_gtksourceview2.patch,
+ +files/mlview-0.9.0-r1-autoreconf.patch, metadata.xml:
+ Taking maint, revbump with port to gtksourceview:2.0
21 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> mlview-0.9.0.ebuild:
Fix slot-deps on gnome libs
diff --git a/app-editors/mlview/files/mlview-0.9.0-r1-10_port_to_gtksourceview2.patch b/app-editors/mlview/files/mlview-0.9.0-r1-10_port_to_gtksourceview2.patch
new file mode 100644
index 000000000000..0ce22957a478
--- /dev/null
+++ b/app-editors/mlview/files/mlview-0.9.0-r1-10_port_to_gtksourceview2.patch
@@ -0,0 +1,218 @@
+Downloaded from http://patch-tracker.debian.org/patch/series/view/mlview/0.9.0-2.2/10_port_to_gtksourceview2.patch
+
+diff -Nur -x '*.orig' -x '*~' mlview-0.9.0/configure.in mlview-0.9.0.new/configure.in
+--- mlview-0.9.0/configure.in 2005-08-07 09:42:07.000000000 +0200
++++ mlview-0.9.0.new/configure.in 2009-08-18 02:45:29.000000000 +0200
+@@ -29,7 +29,7 @@
+ LIBGNOME2_VERSION=2.4.1
+ GCONF2_VERSION=2.6.2
+ SEWFOX_VERSION=0.0.1
+-GTKSOURCEVIEW_VERSION=1.0
++GTKSOURCEVIEW_VERSION=2.0
+ VTE_VERSION=0.11.12
+ DBUS_VERSION=0.22
+ GTKMM2_VERSION=2.4.0
+@@ -306,7 +306,7 @@
+ dnl **********************
+ dnl libgtksourceview
+ dnl **********************
+-PKG_CHECK_MODULES(GTKSOURCEVIEW, gtksourceview-1.0 >= $GTKSOURCEVIEW_VERSION)
++PKG_CHECK_MODULES(GTKSOURCEVIEW, gtksourceview-2.0 >= $GTKSOURCEVIEW_VERSION)
+
+ dnl **********************
+ dnl vte
+diff -Nur -x '*.orig' -x '*~' mlview-0.9.0/src/mlview-source-view.cc mlview-0.9.0.new/src/mlview-source-view.cc
+--- mlview-0.9.0/src/mlview-source-view.cc 2005-08-07 09:42:28.000000000 +0200
++++ mlview-0.9.0.new/src/mlview-source-view.cc 2009-08-18 02:44:12.000000000 +0200
+@@ -25,9 +25,10 @@
+
+ #include <string.h>
+ #include <gtk/gtk.h>
++#include "config.h"
+ #include <gtksourceview/gtksourceview.h>
+ #include <gtksourceview/gtksourcelanguage.h>
+-#include <gtksourceview/gtksourcelanguagesmanager.h>
++#include <gtksourceview/gtksourcelanguagemanager.h>
+ #include <gtksourceview/gtksourcebuffer.h>
+ #include "mlview-safe-ptr-utils.h"
+ #include "mlview-source-view.h"
+@@ -36,6 +37,7 @@
+ #include "mlview-prefs.h"
+ #include "mlview-prefs-category-sourceview.h"
+
++
+ namespace mlview
+ {
+ struct SourceViewPriv
+@@ -48,7 +50,7 @@
+ SafePtr<GtkSourceView, GtkSourceViewRef, GtkSourceViewUnref> native_sv_ptr ;
+ SafePtr<Gtk::Widget, GtkWidgetMMRef, GtkWidgetMMUnref> native_sv_wrapper_ptr ;
+ /* The language manager, used by native_sv */
+- GtkSourceLanguagesManager *languages_manager ;
++ GtkSourceLanguageManager *languages_manager ;
+
+ GtkUIManager *ui_manager ;
+
+@@ -165,8 +167,8 @@
+ gtk_source_view_set_show_line_numbers (source_view,
+ m_prefs->show_line_numbers ());
+
+- gtk_source_view_set_tabs_width (source_view,
+- m_prefs->get_tabs_width ());
++ gtk_source_view_set_tab_width (source_view,
++ m_prefs->get_tabs_width ());
+
+ gtk_source_view_set_auto_indent (source_view,
+ m_prefs->auto_indent ());
+@@ -175,11 +177,11 @@
+ (source_view,
+ m_prefs->replace_tabs_with_spaces ());
+
+- gtk_source_view_set_show_margin (source_view,
+- m_prefs->show_margin ());
++ gtk_source_view_set_show_right_margin (source_view,
++ m_prefs->show_margin ());
+
+- gtk_source_view_set_margin (source_view,
+- m_prefs->get_margin_position ());
++ gtk_source_view_set_right_margin_position (source_view,
++ m_prefs->get_margin_position ());
+
+ const char* fontname = const_cast<char*> (
+ m_prefs->get_font_name ().c_str ());
+@@ -240,8 +242,8 @@
+ {
+ GtkSourceView *source_view = (GtkSourceView*)native_sv_ptr;
+
+- gtk_source_view_set_tabs_width (source_view,
+- m_prefs->get_tabs_width ());
++ gtk_source_view_set_tab_width (source_view,
++ m_prefs->get_tabs_width ());
+ }
+
+ void
+@@ -268,8 +270,8 @@
+ {
+ GtkSourceView *source_view = (GtkSourceView*)native_sv_ptr;
+
+- gtk_source_view_set_show_margin (source_view,
+- m_prefs->show_margin ());
++ gtk_source_view_set_show_right_margin (source_view,
++ m_prefs->show_margin ());
+ }
+
+ void
+@@ -277,8 +279,8 @@
+ {
+ GtkSourceView *source_view = (GtkSourceView*)native_sv_ptr;
+
+- gtk_source_view_set_margin (source_view,
+- m_prefs->get_margin_position ());
++ gtk_source_view_set_right_margin_position (source_view,
++ m_prefs->get_margin_position ());
+ }
+
+ void
+@@ -469,14 +471,13 @@
+ return false;
+ }
+
+-GtkSourceLanguagesManager *
++GtkSourceLanguageManager *
+ SourceView::get_languages_manager ()
+ {
+ THROW_IF_FAIL (m_priv) ;
+
+ if (!m_priv->languages_manager) {
+- m_priv->languages_manager =
+- gtk_source_languages_manager_new () ;
++ m_priv->languages_manager = gtk_source_language_manager_new () ;
+ THROW_IF_FAIL (m_priv->languages_manager) ;
+ }
+ return m_priv->languages_manager ;
+@@ -492,7 +493,7 @@
+ (gtk_text_view_get_buffer (GTK_TEXT_VIEW (m_priv->native_sv_ptr.get ()))) ;
+ THROW_IF_FAIL (source_buffer) ;
+
+- gtk_source_buffer_set_highlight (source_buffer, TRUE) ;
++ gtk_source_buffer_set_highlight_syntax (source_buffer, TRUE) ;
+ gtk_source_buffer_set_language (source_buffer, a_language) ;
+
+ return MLVIEW_OK ;
+@@ -501,22 +502,22 @@
+ enum MlViewStatus
+ SourceView::set_language_from_mime_type (const UString &a_mime_type)
+ {
+- GtkSourceLanguagesManager *lm = NULL ;
++ GtkSourceLanguageManager *lm = NULL ;
+ GtkSourceLanguage *language = NULL ;
+
+ THROW_IF_FAIL (m_priv) ;
+ lm = get_languages_manager () ;
+ THROW_IF_FAIL (lm) ;
+- language = gtk_source_languages_manager_get_language_from_mime_type
+- (lm, a_mime_type.c_str ()) ;
++ language = gtk_source_language_manager_guess_language
++ (lm, NULL, a_mime_type.c_str ()) ;
+ LOG_TO_ERROR_STREAM ("language associated to '"
+ << a_mime_type
+ <<"'mime type: "
+ << language) ;
+ if (!language) {
+ language =
+- gtk_source_languages_manager_get_language_from_mime_type
+- (lm,"text/xml") ;
++ gtk_source_language_manager_guess_language
++ (lm, NULL, "text/xml") ;
+ THROW_IF_FAIL (language) ;
+ LOG_TO_ERROR_STREAM ("falling back to the language associated to"
+ "mime type 'text/xml'") ;
+@@ -1305,7 +1306,7 @@
+ m_priv->show_line_numbers) ;
+
+ m_priv->tabs_width = 4 ;
+- gtk_source_view_set_tabs_width
++ gtk_source_view_set_tab_width
+ (m_priv->native_sv_ptr,
+ m_priv->tabs_width) ;
+
+@@ -1314,11 +1315,11 @@
+ m_priv->set_autoindent) ;
+
+ m_priv->set_show_margin = FALSE ;
+- gtk_source_view_set_show_margin (m_priv->native_sv_ptr,
+- m_priv->set_show_margin) ;
++ gtk_source_view_set_show_right_margin (m_priv->native_sv_ptr,
++ m_priv->set_show_margin) ;
+ m_priv->margin = 2 ;
+- gtk_source_view_set_margin (m_priv->native_sv_ptr,
+- m_priv->margin) ;
++ gtk_source_view_set_right_margin_position (m_priv->native_sv_ptr,
++ m_priv->margin) ;
+
+ set_default_language () ;
+
+diff -Nur -x '*.orig' -x '*~' mlview-0.9.0/src/mlview-source-view.h mlview-0.9.0.new/src/mlview-source-view.h
+--- mlview-0.9.0/src/mlview-source-view.h 2005-08-07 09:42:28.000000000 +0200
++++ mlview-0.9.0.new/src/mlview-source-view.h 2009-08-18 02:39:22.000000000 +0200
+@@ -25,9 +25,10 @@
+ #ifndef __MLVIEW_SOURCE_VIEW_H
+ #define __MLVIEW_SOURCE_VIEW_H
+
++#include "config.h"
+ #include <gtksourceview/gtksourceview.h>
+ #include <gtksourceview/gtksourcelanguage.h>
+-#include <gtksourceview/gtksourcelanguagesmanager.h>
++#include <gtksourceview/gtksourcelanguagemanager.h>
+ #include <gtksourceview/gtksourcebuffer.h>
+ #include "mlview-view-adapter.h"
+ #include "mlview-xml-document.h"
+@@ -112,7 +113,7 @@
+
+ enum MlViewStatus build_edit_menu_body (const UString &a_menu_root_path) ;
+
+- GtkSourceLanguagesManager * get_languages_manager () ;
++ GtkSourceLanguageManager * get_languages_manager () ;
+
+ enum MlViewStatus set_language (GtkSourceLanguage *a_language) ;
+
diff --git a/app-editors/mlview/files/mlview-0.9.0-r1-autoreconf.patch b/app-editors/mlview/files/mlview-0.9.0-r1-autoreconf.patch
new file mode 100644
index 000000000000..205a746c69d5
--- /dev/null
+++ b/app-editors/mlview/files/mlview-0.9.0-r1-autoreconf.patch
@@ -0,0 +1,25 @@
+--- mlview-0.9.0/configure.in
++++ mlview-0.9.0/configure.in
+@@ -77,11 +77,10 @@
+ MLVIEW_EXE=$prefix/bin/mlv
+ AC_SUBST(MLVIEW_VERSION_NUMBER)
+ AC_SUBST(MLVIEW_VERSION)
+-AC_SUBST(AC_PACKAGE_VERSION)
++AC_SUBST([AC_PACKAGE_VERSION])
+ AC_SUBST(LIBMLVIEW_VERSION_NUMBER)
+ AC_SUBST(LIBMLVIEW_VERSION_INFO)
+ AC_SUBST(LIBMLVIEW_VERSION)
+-AC_SUBST(AC_PACKAGE_VERSION)
+ AC_SUBST(MLVIEW_EXE)
+
+ dnl *********************
+--- mlview-0.9.0/pixmaps/Makefile.am
++++ mlview-0.9.0/pixmaps/Makefile.am
+@@ -4,7 +4,6 @@
+ xml-root.png \
+ xml-root-open.png \
+ xml-comment-node.png \
+- xml-text-node.png \
+ xml-pi-node.png \
+ xml-entity-ref-node.png \
+ mlview-xsd-schema.png \
diff --git a/app-editors/mlview/metadata.xml b/app-editors/mlview/metadata.xml
index b715a004b1b4..843bfb15395f 100644
--- a/app-editors/mlview/metadata.xml
+++ b/app-editors/mlview/metadata.xml
@@ -3,7 +3,8 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
- <email>maintainer-needed@gentoo.org</email>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
</maintainer>
<longdescription>
The MlView project is an on going effort to develop an xml editor
diff --git a/app-editors/mlview/mlview-0.9.0-r1.ebuild b/app-editors/mlview/mlview-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..1636f9703c3b
--- /dev/null
+++ b/app-editors/mlview/mlview-0.9.0-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mlview/mlview-0.9.0-r1.ebuild,v 1.1 2011/08/05 01:40:12 xmw Exp $
+
+EAPI=2
+
+GNOME2_LA_PUNT=yes
+inherit autotools eutils gnome2
+
+DESCRIPTION="XML editor for the GNOME environment"
+HOMEPAGE="http://www.freespiders.org/projects/gmlview/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/libxml2-2.6.11:2
+ >=dev-libs/libxslt-1.1.8
+ >=dev-libs/glib-2.6:2
+ >=x11-libs/gtk+-2.6:2
+ >=dev-cpp/gtkmm-2.4:2.4
+ >=gnome-base/libglade-2.4:2.0
+ >=dev-cpp/libglademm-2.6:2.4
+ >=gnome-base/libgnome-2.8.1
+ >=gnome-base/gnome-vfs-2.6:2
+ >=gnome-base/libgnomeui-2.2
+ >=gnome-base/gconf-2.6.2:2
+ x11-libs/gtksourceview:2.0
+ >=x11-libs/vte-0.11.12:0
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+pkg_setup() {
+ DOCS="AUTHORS BRANCHES ChangeLog NEWS README"
+ G2CONF="--disable-dependency-tracking
+ --disable-static
+ $(use_enable debug)"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-desktop.patch
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+ epatch "${FILESDIR}"/${P}-gcc45.patch
+ epatch "${FILESDIR}"/${PF}-10_port_to_gtksourceview2.patch
+ epatch "${FILESDIR}"/${PF}-autoreconf.patch
+ mkdir m4 || die
+ eautoreconf
+ intltoolize --force
+ gnome2_src_prepare
+}