summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-04-08 19:31:17 +0000
committerMike Gilbert <floppym@gentoo.org>2012-04-08 19:31:17 +0000
commitf0174c0aa890ac2827d74499dea1b21a8441d280 (patch)
treee730850ec620b2c76b5297aaaa7cfdde1933b856 /app-editors
parentInitial commit (diff)
downloadgentoo-2-f0174c0aa890ac2827d74499dea1b21a8441d280.tar.gz
gentoo-2-f0174c0aa890ac2827d74499dea1b21a8441d280.tar.bz2
gentoo-2-f0174c0aa890ac2827d74499dea1b21a8441d280.zip
Version bump, #411057 by Ian Delaney. Restrict pypy.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/leo/ChangeLog10
-rw-r--r--app-editors/leo/leo-4.10.ebuild39
-rw-r--r--app-editors/leo/leo-4.8.ebuild6
3 files changed, 50 insertions, 5 deletions
diff --git a/app-editors/leo/ChangeLog b/app-editors/leo/ChangeLog
index e9fbd36b832d..61702708091b 100644
--- a/app-editors/leo/ChangeLog
+++ b/app-editors/leo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/leo
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/ChangeLog,v 1.23 2011/06/23 14:57:14 hwoarang Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/ChangeLog,v 1.24 2012/04/08 19:31:17 floppym Exp $
+
+*leo-4.10 (08 Apr 2012)
+
+ 08 Apr 2012; Mike Gilbert <floppym@gentoo.org> +leo-4.10.ebuild,
+ leo-4.8.ebuild:
+ Version bump, #411057 by Ian Delaney. Restrict pypy.
23 Jun 2011; Markos Chandras <hwoarang@gentoo.org> -leo-4.7.1.ebuild,
-files/leo-4.7.1-fix_syntax_errors.patch:
diff --git a/app-editors/leo/leo-4.10.ebuild b/app-editors/leo/leo-4.10.ebuild
new file mode 100644
index 000000000000..ebb6d7c2114d
--- /dev/null
+++ b/app-editors/leo/leo-4.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/leo-4.10.ebuild,v 1.1 2012/04/08 19:31:17 floppym Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+PYTHON_USE_WITH="tk"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-pypy-* *-jython"
+
+inherit distutils eutils
+
+MY_P="Leo-${PV}-final"
+
+DESCRIPTION="Leo: Literate Editor with Outlines"
+HOMEPAGE="http://leo.sourceforge.net/ http://pypi.python.org/pypi/leo"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="app-text/silvercity
+ dev-python/PyQt4[X]"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${P}-fix_syntax_errors.patch"
+}
+
+src_install() {
+ distutils_src_install
+ dohtml -r leo/doc/html/* || die "dohtml failed"
+}
diff --git a/app-editors/leo/leo-4.8.ebuild b/app-editors/leo/leo-4.8.ebuild
index 7086263b3b6f..9c0e8d57c65a 100644
--- a/app-editors/leo/leo-4.8.ebuild
+++ b/app-editors/leo/leo-4.8.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/leo-4.8.ebuild,v 1.4 2011/05/28 13:54:26 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/leo-4.8.ebuild,v 1.5 2012/04/08 19:31:17 floppym Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
PYTHON_USE_WITH="tk"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-jython"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-pypy-* *-jython"
inherit distutils eutils