summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-11-08 17:45:31 +0000
committerMamoru Komachi <usata@gentoo.org>2003-11-08 17:45:31 +0000
commita5a903109093da5ab58433d358e13570d98ae18c (patch)
tree64eb7372dc35c8e37ced7b912bfd9b7ea1298a94 /app-emacs/bbdb
parentInclude "bits" elisp as well. Closing bug #13351. (diff)
downloadgentoo-2-a5a903109093da5ab58433d358e13570d98ae18c.tar.gz
gentoo-2-a5a903109093da5ab58433d358e13570d98ae18c.tar.bz2
gentoo-2-a5a903109093da5ab58433d358e13570d98ae18c.zip
Include "bits" elisp as well. Closing bug #13351.
Diffstat (limited to 'app-emacs/bbdb')
-rw-r--r--app-emacs/bbdb/ChangeLog8
-rw-r--r--app-emacs/bbdb/Manifest6
-rw-r--r--app-emacs/bbdb/bbdb-2.34-r1.ebuild53
-rw-r--r--app-emacs/bbdb/files/50bbdb-gentoo.el1
-rw-r--r--app-emacs/bbdb/files/digest-bbdb-2.34-r13
5 files changed, 66 insertions, 5 deletions
diff --git a/app-emacs/bbdb/ChangeLog b/app-emacs/bbdb/ChangeLog
index cedab3bad38a..5a9236e6ad2b 100644
--- a/app-emacs/bbdb/ChangeLog
+++ b/app-emacs/bbdb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/bbdb
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/bbdb/ChangeLog,v 1.2 2003/02/12 03:50:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/bbdb/ChangeLog,v 1.3 2003/11/08 17:45:23 usata Exp $
+
+*bbdb-2.34-r1 (09 Nov 2003)
+
+ 09 Nov 2003; Mamoru KOMACHI <usata@gentoo.org> bbdb-2.34-r1.ebuild,
+ files/50bbdb-gentoo.el:
+ Install "bits" elisp as well. Closing bug #13351.
*bbdb-2.34 (01 Jan 2003)
diff --git a/app-emacs/bbdb/Manifest b/app-emacs/bbdb/Manifest
index 6d21df0be10e..5dab7ebb0afc 100644
--- a/app-emacs/bbdb/Manifest
+++ b/app-emacs/bbdb/Manifest
@@ -1,9 +1,7 @@
-MD5 3b504040cb91638ad29d6ab3cabf6d53 ChangeLog 816
+MD5 aea90a60e204d9ca38d70206e7ffeb11 ChangeLog 601
MD5 59b02cf9b889543dab7e4a1d494338d0 bbdb-2.34.ebuild 897
MD5 fcd33d07e4ee719b01157946734f4fe8 metadata.xml 158
-MD5 d370ccd58cf2619ba3f48b31a7ef85af bbdb-2.34-r1.ebuild 1503
+MD5 aeb5e3f645607dc789cc98ed4e686cc0 bbdb-2.34-r1.ebuild 1507
MD5 936a1cf6e98d4e93b6d061f3f6a61557 files/50bbdb-gentoo.el 169
MD5 46ff21db541c51bca257a3f9c7f39242 files/digest-bbdb-2.34 61
-MD5 1979e29c242f16c6a96f091a04a6a74a files/dates.el 7048
-MD5 fc14cd7ca30c3abc4acc1c3ab95c1644 files/point-at.el 440
MD5 08789689a2022d2d3030c3859797f296 files/digest-bbdb-2.34-r1 165
diff --git a/app-emacs/bbdb/bbdb-2.34-r1.ebuild b/app-emacs/bbdb/bbdb-2.34-r1.ebuild
new file mode 100644
index 000000000000..e3f5fdc25f41
--- /dev/null
+++ b/app-emacs/bbdb/bbdb-2.34-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/bbdb/bbdb-2.34-r1.ebuild,v 1.1 2003/11/08 17:45:23 usata Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="The Big Brother Database"
+HOMEPAGE="http://bbdb.sourceforge.net/"
+SRC_URI="http://bbdb.sourceforge.net/${P}.tar.gz
+ http://www.mit.edu/afs/athena/contrib/emacs-contrib/Fin/point-at.el
+ http://www.mit.edu/afs/athena/contrib/emacs-contrib/Fin/dates.el"
+LICENSE="GPL-2 as-is"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/emacs"
+
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+
+ unpack ${P}.tar.gz
+ cd ${S}/bits
+ mv bbdb-mail-folders.el bbdb-mail-folders.txt
+ sed -e "0,/^--- bbdb-mail-folders.el ---$/d" \
+ -e "/^--- end ---$/,+4d" \
+ bbdb-mail-folders.txt > bbdb-mail-folders.el
+ mv bbdb-sort-mailrc.el bbdb-sort-mailrc.txt
+ sed -e "0,/^Bng$/d" \
+ bbdb-sort-mailrc.txt > bbdb-sort-mailrc.el
+ cp ${DISTDIR}/{dates,point-at}.el .
+}
+
+src_compile() {
+
+ econf --with-emacs=emacs || die "econf failed"
+ make || die
+ echo "(add-to-list 'load-path \"${S}/bits\")" > ${T}/lp.el
+ emacs -batch -q --no-site-file --no-init-file \
+ -l ${T}/lp.el -f batch-byte-compile bits/*.el || die
+}
+
+src_install() {
+ elisp-install ${PN} lisp/*.el lisp/*.elc || die
+ elisp-install ${PN}/bits bits/*.el bits/*.elc || die
+ elisp-site-file-install ${FILESDIR}/50bbdb-gentoo.el || die
+
+ doinfo texinfo/*.info*
+ dodoc ChangeLog INSTALL README bits/*.txt
+ newdoc bits/README README.bits
+}
diff --git a/app-emacs/bbdb/files/50bbdb-gentoo.el b/app-emacs/bbdb/files/50bbdb-gentoo.el
index b056e818ac2e..6d47433953cf 100644
--- a/app-emacs/bbdb/files/50bbdb-gentoo.el
+++ b/app-emacs/bbdb/files/50bbdb-gentoo.el
@@ -2,6 +2,7 @@
;;; bbdb site-lisp configuration
(setq load-path (cons "@SITELISP@" load-path))
+(setq load-path (cons "@SITELISP@/bits" load-path))
(require 'bbdb)
(bbdb-initialize)
diff --git a/app-emacs/bbdb/files/digest-bbdb-2.34-r1 b/app-emacs/bbdb/files/digest-bbdb-2.34-r1
new file mode 100644
index 000000000000..03cf66a53665
--- /dev/null
+++ b/app-emacs/bbdb/files/digest-bbdb-2.34-r1
@@ -0,0 +1,3 @@
+MD5 552c6056a5db5ec0935473a9a2760068 bbdb-2.34.tar.gz 363841
+MD5 fc14cd7ca30c3abc4acc1c3ab95c1644 point-at.el 440
+MD5 1979e29c242f16c6a96f091a04a6a74a dates.el 7048