summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-03-03 07:45:42 +0000
committerUlrich Müller <ulm@gentoo.org>2009-03-03 07:45:42 +0000
commit2aada01424dcc72766a7b95e4c789143be46460d (patch)
tree5e389935a1f01f5895b45b4cebba2ab9893a8c41 /app-emacs/cedet
parentBump to 2.1.4. Small fix for upstream typo. (diff)
downloadgentoo-2-2aada01424dcc72766a7b95e4c789143be46460d.tar.gz
gentoo-2-2aada01424dcc72766a7b95e4c789143be46460d.tar.bz2
gentoo-2-2aada01424dcc72766a7b95e4c789143be46460d.zip
Make sure that the compiled elisp files have a later time stamp than the corresponding sources.
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'app-emacs/cedet')
-rw-r--r--app-emacs/cedet/ChangeLog6
-rw-r--r--app-emacs/cedet/cedet-1.0_pre6.ebuild15
2 files changed, 18 insertions, 3 deletions
diff --git a/app-emacs/cedet/ChangeLog b/app-emacs/cedet/ChangeLog
index 2957c882dc86..6d1d784fb52a 100644
--- a/app-emacs/cedet/ChangeLog
+++ b/app-emacs/cedet/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emacs/cedet
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/cedet/ChangeLog,v 1.40 2009/03/01 15:38:25 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/cedet/ChangeLog,v 1.41 2009/03/03 07:45:42 ulm Exp $
+
+ 03 Mar 2009; Ulrich Mueller <ulm@gentoo.org> cedet-1.0_pre6.ebuild:
+ Make sure that the compiled elisp files have a later time stamp than the
+ corresponding sources, in order to suppress warnings at run time.
*cedet-1.0_pre6 (01 Mar 2009)
diff --git a/app-emacs/cedet/cedet-1.0_pre6.ebuild b/app-emacs/cedet/cedet-1.0_pre6.ebuild
index 4f4c42aeef36..968ea96ce9a8 100644
--- a/app-emacs/cedet/cedet-1.0_pre6.ebuild
+++ b/app-emacs/cedet/cedet-1.0_pre6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/cedet/cedet-1.0_pre6.ebuild,v 1.2 2009/03/01 16:10:11 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/cedet/cedet-1.0_pre6.ebuild,v 1.3 2009/03/03 07:45:42 ulm Exp $
NEED_EMACS=22
@@ -46,11 +46,14 @@ src_install() {
| renamelist.txt | semanticdb.sh)
docinto "${dir}"
dodoc "${target}" || die ;;
- *.el | *.elc | *.by | *.wy)
+ *.el | *.by | *.wy)
# install grammar sources along with the elisp files, since
# the location where semantic expects them is not configurable
insinto "${SITELISP}/${PN}/${dir}"
doins "${target}" || die ;;
+ *.elc)
+ # we are in a subshell, so collecting in a variable won't work
+ echo "${target}" >>"${T}/elc-list.txt" ;;
*.srt | *.xpm)
insinto "${SITEETC}/${PN}/${dir}"
doins "${target}" || die ;;
@@ -61,5 +64,13 @@ src_install() {
esac
done
+ # make sure that the compiled elisp files have a later time stamp than
+ # the corresponding sources, in order to suppress warnings at run time
+ while read target; do
+ dir=${target%/*}; dir=${dir#./}
+ insinto "${SITELISP}/${PN}/${dir}"
+ doins "${target}" || die
+ done <"${T}/elc-list.txt"
+
elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
}