summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-09-10 13:07:39 +0000
committerUlrich Müller <ulm@gentoo.org>2009-09-10 13:07:39 +0000
commit349b4399dce86fa9e1a9c6f9340468c01edb6eb7 (patch)
treea1734f41c6209310d1c20251353017a2e7b46d13 /app-emacs/chess/chess-2.0_beta6-r2.ebuild
parentVersion bump to 2.6.31 and removal of all 31_rc (diff)
downloadgentoo-2-349b4399dce86fa9e1a9c6f9340468c01edb6eb7.tar.gz
gentoo-2-349b4399dce86fa9e1a9c6f9340468c01edb6eb7.tar.bz2
gentoo-2-349b4399dce86fa9e1a9c6f9340468c01edb6eb7.zip
Install sounds and pixmaps for pieces under SITEETC.
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'app-emacs/chess/chess-2.0_beta6-r2.ebuild')
-rw-r--r--app-emacs/chess/chess-2.0_beta6-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/chess/chess-2.0_beta6-r2.ebuild b/app-emacs/chess/chess-2.0_beta6-r2.ebuild
new file mode 100644
index 000000000000..615bcfd67926
--- /dev/null
+++ b/app-emacs/chess/chess-2.0_beta6-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/chess/chess-2.0_beta6-r2.ebuild,v 1.1 2009/09/10 13:07:37 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="A chess client and library for Emacs"
+HOMEPAGE="http://emacs-chess.sourceforge.net/"
+SRC_URI="mirror://sourceforge/emacs-chess/${P/_beta/b}.tar.gz
+ mirror://gentoo/emacs-chess-sounds-${PV%%_*}.tar.bz2
+ mirror://gentoo/emacs-chess-pieces-${PV%%_*}.tar.bz2"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="|| ( games-board/gnuchess
+ games-board/crafty
+ games-board/phalanx
+ games-board/sjeng )"
+
+S="${WORKDIR}/${PN}"
+DOCS="ChangeLog EPD.txt PGN.txt PLAN README TODO"
+ELISP_PATCHES="${PV}-chess-pos-move-gentoo.patch
+ ${PV}-chess-common-handler-gentoo.patch"
+SITEFILE="50${PN}-gentoo.el"
+
+# this is needed; elisp.eclass redefines src_compile() from portage default
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ elisp_src_install
+ doinfo chess.info || die "doinfo failed"
+ insinto "${SITEETC}/${PN}"
+ doins -r "${WORKDIR}"/{sounds,pieces} || die "doins failed"
+}