summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-05-29 16:24:19 +0000
committerUlrich Müller <ulm@gentoo.org>2008-05-29 16:24:19 +0000
commit215bb94aaffc78046d9c4eff5542bd4d47c821da (patch)
tree13e3540fa1839878d72e0bc882957d4b4b959268 /app-emacs/edb/edb-1.31.ebuild
parentpython_mod_optimize is ROOT aware. Fixed python_mod_cleanup. Fixed multilib. ... (diff)
downloadgentoo-2-215bb94aaffc78046d9c4eff5542bd4d47c821da.tar.gz
gentoo-2-215bb94aaffc78046d9c4eff5542bd4d47c821da.tar.bz2
gentoo-2-215bb94aaffc78046d9c4eff5542bd4d47c821da.zip
Version bump. Remove old.
(Portage version: 2.1.5.2)
Diffstat (limited to 'app-emacs/edb/edb-1.31.ebuild')
-rw-r--r--app-emacs/edb/edb-1.31.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-emacs/edb/edb-1.31.ebuild b/app-emacs/edb/edb-1.31.ebuild
new file mode 100644
index 000000000000..dd24eff8c238
--- /dev/null
+++ b/app-emacs/edb/edb-1.31.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/edb/edb-1.31.ebuild,v 1.1 2008/05/29 16:24:19 ulm Exp $
+
+inherit elisp eutils
+
+DESCRIPTION="EDB, The Emacs Database"
+HOMEPAGE="http://www.gnuvola.org/software/edb/"
+SRC_URI="http://www.gnuvola.org/software/edb/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc"
+IUSE=""
+
+SITEFILE="52${PN}-gentoo.el"
+
+src_compile() {
+ econf || die "econf failed"
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ einstall sitelisp="${D}${SITELISP}" || die "einstall failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "elisp-site-file-install failed"
+ dodoc AUTHORS BUGS ChangeLog HACKING NEWS README THANKS TODO \
+ doc/refcard.ps || die "dodoc failed"
+ insinto /usr/share/doc/${PF}; doins -r examples
+}