summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-03-12 09:44:24 +0000
committerUlrich Müller <ulm@gentoo.org>2009-03-12 09:44:24 +0000
commit1657f7ed96573155ab584d8ff8c2142df46de298 (patch)
tree56d4e27b4b6a1e8013103bd72030b0711585597e /app-emacs/emacs-common-gentoo
parentremove myself as maintainer (diff)
downloadgentoo-2-1657f7ed96573155ab584d8ff8c2142df46de298.tar.gz
gentoo-2-1657f7ed96573155ab584d8ff8c2142df46de298.tar.bz2
gentoo-2-1657f7ed96573155ab584d8ff8c2142df46de298.zip
Version bump, imported from Emacs overlay.
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'app-emacs/emacs-common-gentoo')
-rw-r--r--app-emacs/emacs-common-gentoo/ChangeLog9
-rw-r--r--app-emacs/emacs-common-gentoo/emacs-common-gentoo-1.0.ebuild94
2 files changed, 101 insertions, 2 deletions
diff --git a/app-emacs/emacs-common-gentoo/ChangeLog b/app-emacs/emacs-common-gentoo/ChangeLog
index 692ea10a92e1..14c5c67a217f 100644
--- a/app-emacs/emacs-common-gentoo/ChangeLog
+++ b/app-emacs/emacs-common-gentoo/ChangeLog
@@ -1,12 +1,17 @@
# ChangeLog for x11-misc/emacs-desktop
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-common-gentoo/ChangeLog,v 1.1 2009/03/12 00:59:02 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-common-gentoo/ChangeLog,v 1.2 2009/03/12 09:44:24 ulm Exp $
+*emacs-common-gentoo-1.0 (12 Mar 2009)
*emacs-common-gentoo-0.3 (12 Mar 2009)
12 Mar 2009; Ulrich Mueller <ulm@gentoo.org> +metadata.xml,
- +emacs-common-gentoo-0.3.ebuild:
+ +emacs-common-gentoo-0.3.ebuild, +emacs-common-gentoo-1.0.ebuild:
Package moved from x11-misc/emacs-desktop to app-emacs/emacs-common-gentoo.
+ Version 1.0 imported from Emacs overlay. Install subdirs.el; install
+ desktop entry only for USE="X". Keywords ~s390 and ~sparc-fbsd carried
+ over from app-editors/emacs, which doesn't install subdirs.el anymore.
+ New pkg_config function will create a default site-start.el file.
20 Sep 2008; Ulrich Mueller <ulm@gentoo.org> -emacs-desktop-0.2-r1.ebuild:
Remove old.
diff --git a/app-emacs/emacs-common-gentoo/emacs-common-gentoo-1.0.ebuild b/app-emacs/emacs-common-gentoo/emacs-common-gentoo-1.0.ebuild
new file mode 100644
index 000000000000..d38470d5a176
--- /dev/null
+++ b/app-emacs/emacs-common-gentoo/emacs-common-gentoo-1.0.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-common-gentoo/emacs-common-gentoo-1.0.ebuild,v 1.1 2009/03/12 09:44:24 ulm Exp $
+
+inherit elisp-common eutils fdo-mime gnome2-utils
+
+DESCRIPTION="Common files needed by all GNU Emacs versions"
+HOMEPAGE="http://www.gentoo.org/proj/en/lisp/emacs/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="X"
+
+PDEPEND="virtual/emacs"
+
+pkg_setup() {
+ # clean up orphan file installed by old Emacs ebuilds
+ rm -f "${ROOT}${SITELISP}/subdirs.el"
+}
+
+src_install() {
+ elisp-install . subdirs.el || die
+
+ if use X; then
+ local i
+ domenu emacs.desktop emacsclient.desktop || die
+ newicon emacs_48.png emacs.png || die
+ for i in 16 24 32 48; do
+ insinto /usr/share/icons/hicolor/${i}x${i}/apps
+ newins emacs_${i}.png emacs.png || die
+ done
+ fi
+}
+
+make-site-start() {
+ ebegin "Creating default ${SITELISP}/site-start.el"
+ cat <<-EOF >"${T}/site-start.el"
+ ;;; site-start.el
+
+ ;;; Commentary:
+ ;; This default site startup file was created by package
+ ;; ${CATEGORY}/${PF}. You may modify this file, replace it
+ ;; by your own site initialisation, or even remove it completely.
+
+ ;;; Code:
+ ;; Load site initialisation for Gentoo installed packages.
+ (require 'site-gentoo)
+
+ ;;; site-start.el ends here
+ EOF
+ mv "${T}/site-start.el" "${ROOT}${SITELISP}/site-start.el"
+ eend $? "Installation of site-start.el failed"
+}
+
+pkg_config() {
+ if [ ! -e "${ROOT}${SITELISP}/site-start.el" ]; then
+ einfo "Press ENTER to create a default site-start.el file"
+ einfo "for GNU Emacs, or Control-C to abort now ..."
+ read
+ make-site-start
+ else
+ einfo "site-start.el for GNU Emacs already exists."
+ fi
+}
+
+pkg_postinst() {
+ if use X; then
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+ fi
+
+ if [ ! -e "${ROOT}${SITELISP}/site-start.el" ]; then
+ if [ ! -e "${ROOT}${SITELISP}"/site-gentoo.el ]; then
+ # This seems to be a new install. Create site-gentoo.el and
+ # a default site-start.el, so that Gentoo packages will work.
+ elisp-site-regen
+ make-site-start
+ else
+ # site-gentoo.el already exists. Give a hint how to
+ # (re-)create the site-start.el file.
+ elog "If this is a new install, you may want to run:"
+ elog "\"emerge --config =${CATEGORY}/${PF}\""
+ fi
+ fi
+}
+
+pkg_postrm() {
+ if use X; then
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+ fi
+}