summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-04-22 23:14:03 +0000
committerUlrich Müller <ulm@gentoo.org>2009-04-22 23:14:03 +0000
commitc231501a82db4bc070ffa4e6b946a04359bfb4d4 (patch)
treed31466f9725fe8d79a470b9af951852f08146096 /app-emacs/emacs-common-gentoo
parentFix install with USE=-hal, bug #266827. (diff)
downloadgentoo-2-c231501a82db4bc070ffa4e6b946a04359bfb4d4.tar.gz
gentoo-2-c231501a82db4bc070ffa4e6b946a04359bfb4d4.tar.bz2
gentoo-2-c231501a82db4bc070ffa4e6b946a04359bfb4d4.zip
Version bump. New "emacs23icons" USE flag for Emacs 23 style icons.
(Portage version: 2.2_rc31/cvs/Linux i686)
Diffstat (limited to 'app-emacs/emacs-common-gentoo')
-rw-r--r--app-emacs/emacs-common-gentoo/ChangeLog8
-rw-r--r--app-emacs/emacs-common-gentoo/emacs-common-gentoo-1.1.ebuild134
-rw-r--r--app-emacs/emacs-common-gentoo/metadata.xml3
3 files changed, 144 insertions, 1 deletions
diff --git a/app-emacs/emacs-common-gentoo/ChangeLog b/app-emacs/emacs-common-gentoo/ChangeLog
index 15e01e60da0c..05e1897fb8c5 100644
--- a/app-emacs/emacs-common-gentoo/ChangeLog
+++ b/app-emacs/emacs-common-gentoo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/emacs-common-gentoo
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-common-gentoo/ChangeLog,v 1.14 2009/04/14 18:02:24 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-common-gentoo/ChangeLog,v 1.15 2009/04/22 23:14:03 ulm Exp $
+
+*emacs-common-gentoo-1.1 (23 Apr 2009)
+
+ 23 Apr 2009; Ulrich Mueller <ulm@gentoo.org> metadata.xml,
+ +emacs-common-gentoo-1.1.ebuild:
+ Version bump. New "emacs23icons" USE flag for Emacs 23 style icons.
14 Apr 2009; Ulrich Mueller <ulm@gentoo.org>
-emacs-common-gentoo-0.3.ebuild:
diff --git a/app-emacs/emacs-common-gentoo/emacs-common-gentoo-1.1.ebuild b/app-emacs/emacs-common-gentoo/emacs-common-gentoo-1.1.ebuild
new file mode 100644
index 000000000000..f46446f2b4ec
--- /dev/null
+++ b/app-emacs/emacs-common-gentoo/emacs-common-gentoo-1.1.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-common-gentoo/emacs-common-gentoo-1.1.ebuild,v 1.1 2009/04/22 23:14:03 ulm Exp $
+
+inherit elisp-common eutils fdo-mime gnome2-utils
+
+DESCRIPTION="Common files needed by all GNU Emacs versions"
+HOMEPAGE="http://www.gentoo.org/proj/en/lisp/emacs/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2 X? ( emacs23icons? ( GPL-3 ) )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="X emacs23icons"
+
+PDEPEND="virtual/emacs"
+
+pkg_setup() {
+ if [ -e "${ROOT}${SITELISP}/subdirs.el" ] \
+ && ! has_version ">=${CATEGORY}/${PN}-1"
+ then
+ ewarn "Removing orphan subdirs.el (installed by old Emacs ebuilds)"
+ rm -f "${ROOT}${SITELISP}/subdirs.el"
+ fi
+
+ NEW_INSTALL=""
+ has_version ${CATEGORY}/${PN} || NEW_INSTALL="true"
+}
+
+src_install() {
+ elisp-install . subdirs.el || die
+
+ if use X; then
+ local i
+ domenu emacs.desktop emacsclient.desktop || die
+ newicon icons/sink.png emacs-sink.png || die
+ if use emacs23icons; then
+ newicon icons/emacs23_48.png emacs.png || die
+ for i in 16 24 32 48 128; do
+ insinto /usr/share/icons/hicolor/${i}x${i}/apps
+ newins icons/emacs23_${i}.png emacs.png || die
+ done
+ insinto /usr/share/icons/hicolor/scalable/apps
+ newins icons/emacs23.svg emacs.svg || die
+ else
+ newicon icons/emacs_48.png emacs.png || die
+ for i in 16 24 32 48; do
+ insinto /usr/share/icons/hicolor/${i}x${i}/apps
+ newins icons/emacs_${i}.png emacs.png || die
+ done
+ fi
+ gnome2_icon_savelist
+ fi
+}
+
+make-site-start() {
+ ebegin "Creating default ${SITELISP}/site-start.el"
+ cat <<-EOF >"${T}/site-start.el"
+ ;;; site-start.el -*- no-byte-compile: t -*-
+
+ ;;; Commentary:
+ ;; This default site startup file for Emacs was created by package
+ ;; ${CATEGORY}/${PF}. You may modify this file, replace
+ ;; it by your own site initialisation, or even remove it completely.
+
+ ;;; Code:
+ ;; Load site initialisation for Gentoo installed packages.
+ (require 'site-gentoo)
+
+ ;;; site-start.el ends here
+ EOF
+ mv "${T}/site-start.el" "${ROOT}${SITELISP}/site-start.el"
+ eend $? "Installation of site-start.el failed"
+}
+
+pkg_config() {
+ if [ ! -e "${ROOT}${SITELISP}/site-start.el" ]; then
+ einfo "Press ENTER to create a default site-start.el file"
+ einfo "for GNU Emacs, or Control-C to abort now ..."
+ read
+ make-site-start
+ else
+ einfo "site-start.el for GNU Emacs already exists."
+ fi
+}
+
+pkg_postinst() {
+ if use X; then
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+ fi
+
+ # make sure that site-gentoo.el exists since site-start.el requires it
+ elisp-site-regen
+
+ if [ ! -e "${ROOT}${SITELISP}/site-start.el" ]; then
+ local line
+ echo
+ while read line; do elog "${line:- }"; done <<-EOF
+ All site initialisation for Gentoo-installed packages is added to
+ /usr/share/emacs/site-lisp/site-gentoo.el. In order for this site
+ initialisation to be loaded for all users automatically, a default
+ site-start.el is created in the same directory. You are responsible
+ for all further maintenance of this file.
+
+ Alternatively, individual users can add the following command:
+
+ (require 'site-gentoo)
+
+ to their ~/.emacs initialisation files, or, for greater flexibility,
+ users may load single package-specific initialisation files from
+ /usr/share/emacs/site-lisp/site-gentoo.d/.
+ EOF
+ echo
+
+ if [ "${NEW_INSTALL}" ]; then
+ # This is a new install. Create default site-start.el, so that
+ # Gentoo packages will work.
+ make-site-start
+ else
+ # This package was already installed, but site-start.el does
+ # not exist. Give a hint how to (re-)create it.
+ elog "If this is a new install, you may want to run:"
+ elog "emerge --config =${CATEGORY}/${PF}"
+ fi
+ fi
+}
+
+pkg_postrm() {
+ if use X; then
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+ fi
+}
diff --git a/app-emacs/emacs-common-gentoo/metadata.xml b/app-emacs/emacs-common-gentoo/metadata.xml
index bc306fe58224..e798a7238eee 100644
--- a/app-emacs/emacs-common-gentoo/metadata.xml
+++ b/app-emacs/emacs-common-gentoo/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>emacs</herd>
+<use>
+ <flag name='emacs23icons'>Install Emacs 23 style icons</flag>
+</use>
</pkgmetadata>